aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-02-13 21:37:13 +0800
committerscheidell <scheidell@FreeBSD.org>2012-02-13 21:37:13 +0800
commit4ad94670fcbd68b555796746985bfd5c93e1069a (patch)
tree5d12e9ba4cffbd764ab30c2656d0e959dd5e7a08 /sysutils
parente3d14dd98126509ae775f1ec751b67ed413f2ce7 (diff)
downloadfreebsd-ports-gnome-4ad94670fcbd68b555796746985bfd5c93e1069a.tar.gz
freebsd-ports-gnome-4ad94670fcbd68b555796746985bfd5c93e1069a.tar.zst
freebsd-ports-gnome-4ad94670fcbd68b555796746985bfd5c93e1069a.zip
- The mount checkpoint was changed in previous update to r230226.
- This patch fixed mount_fusefs to use new path. - Bump PORTREVISION PR: ports/164218 Submitted by: jh@ Approved by: Edward Sanford Sutton, III <mirror176@cox.net> (maintainer), gabor (mentor)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-kmod/Makefile2
-rw-r--r--sysutils/fusefs-kmod/files/patch-mount_fusefs__mount_fusefs.c23
2 files changed, 24 insertions, 1 deletions
diff --git a/sysutils/fusefs-kmod/Makefile b/sysutils/fusefs-kmod/Makefile
index e87746b252e4..c276b53e4ab1 100644
--- a/sysutils/fusefs-kmod/Makefile
+++ b/sysutils/fusefs-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fusefs
DISTVERSION= 0.3.9-pre1.20080208
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= sysutils kld
MASTER_SITES= http://mercurial.creo.hu/repos/fuse4bsd-hg/index.cgi/archive/
PKGNAMESUFFIX= -kmod
diff --git a/sysutils/fusefs-kmod/files/patch-mount_fusefs__mount_fusefs.c b/sysutils/fusefs-kmod/files/patch-mount_fusefs__mount_fusefs.c
new file mode 100644
index 000000000000..ed2cab2bf8c8
--- /dev/null
+++ b/sysutils/fusefs-kmod/files/patch-mount_fusefs__mount_fusefs.c
@@ -0,0 +1,23 @@
+--- mount_fusefs/mount_fusefs.c 2008-02-05 07:25:57.000000000 +0200
++++ mount_fusefs/mount_fusefs.c 2012-01-07 21:07:35.000000000 +0200
+@@ -44,6 +44,7 @@
+ #include <getopt.h>
+ #include <libgen.h>
+ #include <limits.h>
++#include <osreldate.h>
+ #include <paths.h>
+
+ #include "fuse4bsd.h"
+@@ -312,7 +313,12 @@
+ * Resolve the mountpoint with realpath(3) and remove unnecessary
+ * slashes from the devicename if there are any.
+ */
++#if __FreeBSD_version >= 1000005
++ if (checkpath(dir, mntpath) != 0)
++ err(1, "%s", mntpath);
++#else
+ (void)checkpath(dir, mntpath);
++#endif
+ (void)rmslashes(dev, dev);
+
+ if (strcmp(dev, "auto") == 0)