aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-09-21 04:19:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-09-21 04:19:18 +0800
commit4b2be0616d006aa4e163c3c4b17045ef16143dff (patch)
tree207f13f1839ce6c96f041d247cdd3b89519f95d8 /sysutils
parent5c4069845bd168fbb7dfa6f1592bc9308db14e60 (diff)
downloadfreebsd-ports-gnome-4b2be0616d006aa4e163c3c4b17045ef16143dff.tar.gz
freebsd-ports-gnome-4b2be0616d006aa4e163c3c4b17045ef16143dff.tar.zst
freebsd-ports-gnome-4b2be0616d006aa4e163c3c4b17045ef16143dff.zip
- Install complete list of components
- Bump PORTREVISION for package change PR: 202724 Submitted by: <bigangrygreenguy@gmail.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/debhelper/Makefile4
-rw-r--r--sysutils/debhelper/files/patch-Makefile13
-rw-r--r--sysutils/debhelper/files/patch-dh_fixperms14
-rw-r--r--sysutils/debhelper/files/patch-dh_installman12
-rw-r--r--sysutils/debhelper/files/patch-dh_perl13
-rw-r--r--sysutils/debhelper/pkg-plist57
6 files changed, 110 insertions, 3 deletions
diff --git a/sysutils/debhelper/Makefile b/sysutils/debhelper/Makefile
index 04558b7402e6..908da6cb2c24 100644
--- a/sysutils/debhelper/Makefile
+++ b/sysutils/debhelper/Makefile
@@ -3,6 +3,7 @@
PORTNAME= debhelper
PORTVERSION= 9.20150101
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -19,4 +20,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
SHEBANG_FILES= dh*
+post-patch:
+ @${RM} ${WRKSRC}/*.orig
+
.include <bsd.port.mk>
diff --git a/sysutils/debhelper/files/patch-Makefile b/sysutils/debhelper/files/patch-Makefile
index 2bec4ff8f10b..30f656cbfe57 100644
--- a/sysutils/debhelper/files/patch-Makefile
+++ b/sysutils/debhelper/files/patch-Makefile
@@ -1,6 +1,13 @@
---- Makefile.orig 2013-11-11 03:11:15.000000000 +0800
-+++ Makefile 2014-07-01 01:06:16.800481843 +0800
-@@ -88,17 +88,16 @@
+--- Makefile.orig 2014-11-16 15:43:09 UTC
++++ Makefile
+@@ -1,5 +1,5 @@
+ # List of files of dh_* commands. Sorted for debhelper man page.
+-COMMANDS=$(shell find . -maxdepth 1 -type f -perm /100 -name "dh_*" -printf "%f\n" | sort)
++COMMANDS=$(shell find . -maxdepth 1 -type f -perm +a+x -name "dh_*" -print | cut -c3- | sort)
+
+ # Find deprecated commands by looking at their synopsis.
+ DEPRECATED=$(shell egrep -l '^dh_.* - .*deprecated' $(COMMANDS))
+@@ -88,17 +88,16 @@ endif
done;
install:
diff --git a/sysutils/debhelper/files/patch-dh_fixperms b/sysutils/debhelper/files/patch-dh_fixperms
new file mode 100644
index 000000000000..27d901194676
--- /dev/null
+++ b/sysutils/debhelper/files/patch-dh_fixperms
@@ -0,0 +1,14 @@
+--- dh_fixperms.orig 2015-09-19 09:06:22 UTC
++++ dh_fixperms
+@@ -57,8 +57,10 @@ foreach my $package (@{$dh{DOPACKAGES}})
+ }
+
+ # General permissions fixing.
++ #complex_doit("find $tmp $find_options -print0",
++ # "2>/dev/null | xargs -0r chown --no-dereference 0:0");
+ complex_doit("find $tmp $find_options -print0",
+- "2>/dev/null | xargs -0r chown --no-dereference 0:0");
++ "2>/dev/null | xargs -0r chown 0:0");
+ complex_doit("find $tmp ! -type l $find_options -print0",
+ "2>/dev/null | xargs -0r chmod go=rX,u+rw,a-s");
+
diff --git a/sysutils/debhelper/files/patch-dh_installman b/sysutils/debhelper/files/patch-dh_installman
new file mode 100644
index 000000000000..666fad64911d
--- /dev/null
+++ b/sysutils/debhelper/files/patch-dh_installman
@@ -0,0 +1,12 @@
+--- dh_installman.orig 2015-09-19 09:06:22 UTC
++++ dh_installman
+@@ -201,7 +201,8 @@ foreach my $package (@{$dh{DOPACKAGES}})
+ }
+
+ # Now utf-8 conversion.
+- if (defined `man --version`) {
++ my $man_version = `man --version 2> /dev/null`;
++ if (defined $man_version && length($man_version)) {
+ foreach my $dir (qw{usr/share/man}) {
+ next unless -e "$tmp/$dir";
+ find(sub {
diff --git a/sysutils/debhelper/files/patch-dh_perl b/sysutils/debhelper/files/patch-dh_perl
new file mode 100644
index 000000000000..28f6aeee69a2
--- /dev/null
+++ b/sysutils/debhelper/files/patch-dh_perl
@@ -0,0 +1,13 @@
+--- dh_perl.orig 2015-09-19 09:06:22 UTC
++++ dh_perl
+@@ -143,8 +143,8 @@ foreach my $package (@{$dh{DOPACKAGES}})
+ # only one directory is installed into.
+ foreach my $dir ("$tmp/$vendorlib", "$tmp/$vendorarch") {
+ if (-d $dir) {
+- doit("rmdir", "--ignore-fail-on-non-empty", "--parents",
+- "$dir");
++ # doit("rmdir", "--ignore-fail-on-non-empty", "--parents", "$dir");
++ doit_noerror("rmdir", "$dir");
+ }
+ }
+ }
diff --git a/sysutils/debhelper/pkg-plist b/sysutils/debhelper/pkg-plist
index 4c273c392f6b..48b35c1d1f00 100644
--- a/sysutils/debhelper/pkg-plist
+++ b/sysutils/debhelper/pkg-plist
@@ -1,4 +1,61 @@
bin/dh
+bin/dh_auto_build
+bin/dh_auto_clean
+bin/dh_auto_configure
+bin/dh_auto_install
+bin/dh_auto_test
+bin/dh_bugfiles
+bin/dh_builddeb
+bin/dh_clean
+bin/dh_compress
+bin/dh_desktop
+bin/dh_fixperms
+bin/dh_gconf
+bin/dh_gencontrol
+bin/dh_icons
+bin/dh_install
+bin/dh_installcatalogs
+bin/dh_installchangelogs
+bin/dh_installcron
+bin/dh_installdeb
+bin/dh_installdebconf
+bin/dh_installdirs
+bin/dh_installdocs
+bin/dh_installemacsen
+bin/dh_installexamples
+bin/dh_installgsettings
+bin/dh_installifupdown
+bin/dh_installinfo
+bin/dh_installinit
+bin/dh_installlogcheck
+bin/dh_installlogrotate
+bin/dh_installman
+bin/dh_installmanpages
+bin/dh_installmenu
+bin/dh_installmime
+bin/dh_installmodules
+bin/dh_installpam
+bin/dh_installppp
+bin/dh_installudev
+bin/dh_installwm
+bin/dh_installxfonts
+bin/dh_link
+bin/dh_lintian
+bin/dh_listpackages
+bin/dh_makeshlibs
+bin/dh_md5sums
+bin/dh_movefiles
+bin/dh_perl
+bin/dh_prep
+bin/dh_scrollkeeper
+bin/dh_shlibdeps
+bin/dh_strip
+bin/dh_suidregister
+bin/dh_testdir
+bin/dh_testroot
+bin/dh_ucf
+bin/dh_undocumented
+bin/dh_usrlocal
bin/maintscript-helper
bin/postinst-emacsen
bin/postinst-icons