aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2015-11-18 23:51:21 +0800
committerwg <wg@FreeBSD.org>2015-11-18 23:51:21 +0800
commit4f61d22ad56f9560059b033a225d2be1247ef012 (patch)
treef96207c3d54628971ad43c1387e53512f0736ef9 /sysutils
parentc6f9fd99900c76c9d4a44316324631cdad3119fb (diff)
downloadfreebsd-ports-gnome-4f61d22ad56f9560059b033a225d2be1247ef012.tar.gz
freebsd-ports-gnome-4f61d22ad56f9560059b033a225d2be1247ef012.tar.zst
freebsd-ports-gnome-4f61d22ad56f9560059b033a225d2be1247ef012.zip
devel/py-freenas.cli: FreeNAS Command Line Interface
WWW: https://github.com/freenas/middleware
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-freenas.cli/Makefile26
-rw-r--r--sysutils/py-freenas.cli/distinfo2
-rw-r--r--sysutils/py-freenas.cli/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 82bad0261e91..f9b46a6707e2 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -776,6 +776,7 @@
SUBDIR += py-execnet
SUBDIR += py-ezjailremote
SUBDIR += py-filelike
+ SUBDIR += py-freenas.cli
SUBDIR += py-glances
SUBDIR += py-halite
SUBDIR += py-honcho
diff --git a/sysutils/py-freenas.cli/Makefile b/sysutils/py-freenas.cli/Makefile
new file mode 100644
index 000000000000..9139e7168073
--- /dev/null
+++ b/sysutils/py-freenas.cli/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= freenas.cli
+PORTVERSION= 10.2a4
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= FreeNAS Command Line Interface
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}freenas.utils>0:${PORTSDIR}/devel/py-freenas.utils
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}columnize>0:${PORTSDIR}/devel/py-columnize \
+ ${PYTHON_PKGNAMEPREFIX}icu>0:${PORTSDIR}/devel/py-icu \
+ ${PYTHON_PKGNAMEPREFIX}natural>0:${PORTSDIR}/devel/py-natural \
+ ${PYTHON_PKGNAMEPREFIX}ply>0:${PORTSDIR}/devel/py-ply \
+ ${PYTHON_PKGNAMEPREFIX}termcolor>0:${PORTSDIR}/devel/py-termcolor \
+ ${PYTHON_PKGNAMEPREFIX}texttable>0:${PORTSDIR}/textproc/py-texttable \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}freenas.utils>0:${PORTSDIR}/devel/py-freenas.utils \
+ ${PYTHON_PKGNAMEPREFIX}freenas.dispatcher>0:${PORTSDIR}/devel/py-freenas.dispatcher
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-freenas.cli/distinfo b/sysutils/py-freenas.cli/distinfo
new file mode 100644
index 000000000000..19074c1a8581
--- /dev/null
+++ b/sysutils/py-freenas.cli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (freenas.cli-10.2a4.tar.gz) = 3f37eb12c2f488aeee27a81e61c30d2ef1da0468493379529e5cb734131ee2f8
+SIZE (freenas.cli-10.2a4.tar.gz) = 53179
diff --git a/sysutils/py-freenas.cli/pkg-descr b/sysutils/py-freenas.cli/pkg-descr
new file mode 100644
index 000000000000..4b8da319ceb6
--- /dev/null
+++ b/sysutils/py-freenas.cli/pkg-descr
@@ -0,0 +1,3 @@
+FreeNAS Command Line Interface for managing a box remotely.
+
+WWW: https://github.com/freenas/middleware