aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-04 22:25:52 +0800
committerpav <pav@FreeBSD.org>2005-05-04 22:25:52 +0800
commit57a79e496b4f2a753e11a8e142cf1657b89c7281 (patch)
treeb2dd5c711331ca06a3b0befd4a278e19bff43979 /sysutils
parent4a8d6a3e637330e2b62a45cf40d59338c5993356 (diff)
downloadfreebsd-ports-gnome-57a79e496b4f2a753e11a8e142cf1657b89c7281.tar.gz
freebsd-ports-gnome-57a79e496b4f2a753e11a8e142cf1657b89c7281.tar.zst
freebsd-ports-gnome-57a79e496b4f2a753e11a8e142cf1657b89c7281.zip
- Don't abort installation when we fail to make device
PR: ports/80592 Submitted by: Frank W. Josellis <frank@dynamical-systems.org> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pcfclock/Makefile9
-rw-r--r--sysutils/pcfclock/pkg-install15
2 files changed, 23 insertions, 1 deletions
diff --git a/sysutils/pcfclock/Makefile b/sysutils/pcfclock/Makefile
index cc61a7c49565..8b6ebff235cd 100644
--- a/sysutils/pcfclock/Makefile
+++ b/sysutils/pcfclock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pcfclock
PORTVERSION= 0.44
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www-stud.ims.uni-stuttgart.de/~voegelas/pcfclock/
@@ -21,6 +22,14 @@ PLIST_FILES= sbin/pcfdate
.include <bsd.port.pre.mk>
+.if ${ARCH} == "alpha"
+IGNORE= Not supported for architecture ${ARCH}
+.endif
+
+.if ${OSVERSION} < 400000
+IGNORE= Not supported for versions prior to FreeBSD 4.0
+.endif
+
post-install:
.if ${OSVERSION} < 500000
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/sysutils/pcfclock/pkg-install b/sysutils/pcfclock/pkg-install
index 5042c4f80682..c9dee1bc1ddd 100644
--- a/sysutils/pcfclock/pkg-install
+++ b/sysutils/pcfclock/pkg-install
@@ -2,6 +2,19 @@
case $2 in
POST-INSTALL)
- [ -c /dev/pcfclock0 ] || ( cd /dev && ./MAKEDEV pcfclock0 )
+ if [ ! -c /dev/pcfclock0 ]; then
+ rv=1
+ if [ -x /dev/MAKEDEV ]; then
+ ( cd /dev && ./MAKEDEV pcfclock0 )
+ rv=$?
+ fi
+
+ if [ ${rv} = 0 ]; then
+ echo "$2: Device special file /dev/pcfclock0 created"
+ else
+ echo "$2: Unexpected failure creating /dev/pcfclock0"
+ echo "$2: Try 'cd /dev ; mknod pcfclock0 c 140 0 root:wheel'"
+ fi
+ fi
;;
esac