aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-12-09 01:41:56 +0800
committertobik <tobik@FreeBSD.org>2017-12-09 01:41:56 +0800
commit66d8ee76c7f4c4a3fe192f2c832c666ff4484b05 (patch)
tree0497be06235db51a7d7e69df0e9832cf8d995a8d /sysutils
parente305c0590914c07334c845987ccb514b38937214 (diff)
downloadfreebsd-ports-gnome-66d8ee76c7f4c4a3fe192f2c832c666ff4484b05.tar.gz
freebsd-ports-gnome-66d8ee76c7f4c4a3fe192f2c832c666ff4484b05.tar.zst
freebsd-ports-gnome-66d8ee76c7f4c4a3fe192f2c832c666ff4484b05.zip
New port: sysutils/nq
These small utilities allow creating very lightweight job queue systems which require no setup, maintenance, supervision, or any long-running processes. The intended purpose is ad-hoc queuing of command lines (e.g. for building several targets of a Makefile, downloading multiple files one at a time, running benchmarks in several configurations, or simply as a glorified nohup), but as any good Unix tool, it can be abused for whatever you like. WWW: https://github.com/chneukirchen/nq
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/nq/Makefile27
-rw-r--r--sysutils/nq/distinfo3
-rw-r--r--sysutils/nq/pkg-descr11
-rw-r--r--sysutils/nq/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index a6600b3f262a..9c58da37d22c 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -696,6 +696,7 @@
SUBDIR += node_exporter
SUBDIR += nomad
SUBDIR += npadmin
+ SUBDIR += nq
SUBDIR += nrg2iso
SUBDIR += nut
SUBDIR += nvclock
diff --git a/sysutils/nq/Makefile b/sysutils/nq/Makefile
new file mode 100644
index 000000000000..47e407840b6e
--- /dev/null
+++ b/sysutils/nq/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= nq
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.1
+CATEGORIES= sysutils
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Unix command line queue utility
+
+LICENSE= CC0-1.0
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= perl5
+USE_GITHUB= yes
+GH_ACCOUNT= chneukirchen
+USE_PERL5= test
+
+MAKE_ARGS= PREFIX="${PREFIX}" MANDIR="${PREFIX}/man"
+TEST_TARGET= check
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fq ${STAGEDIR}${PREFIX}/bin/nq
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/_nq ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_nq
+
+.include <bsd.port.mk>
diff --git a/sysutils/nq/distinfo b/sysutils/nq/distinfo
new file mode 100644
index 000000000000..6c27b8436f2f
--- /dev/null
+++ b/sysutils/nq/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512754132
+SHA256 (chneukirchen-nq-v0.2.1_GH0.tar.gz) = 1773290791cce646e5e54e935118498a95948ca39ff5d58ac6dc65135275d3fc
+SIZE (chneukirchen-nq-v0.2.1_GH0.tar.gz) = 10456
diff --git a/sysutils/nq/pkg-descr b/sysutils/nq/pkg-descr
new file mode 100644
index 000000000000..314d3f5c173e
--- /dev/null
+++ b/sysutils/nq/pkg-descr
@@ -0,0 +1,11 @@
+These small utilities allow creating very lightweight job queue
+systems which require no setup, maintenance, supervision, or any
+long-running processes.
+
+The intended purpose is ad-hoc queuing of command lines (e.g. for
+building several targets of a Makefile, downloading multiple files one
+at a time, running benchmarks in several configurations, or simply as
+a glorified nohup), but as any good Unix tool, it can be abused for
+whatever you like.
+
+WWW: https://github.com/chneukirchen/nq
diff --git a/sysutils/nq/pkg-plist b/sysutils/nq/pkg-plist
new file mode 100644
index 000000000000..3d855121ef8f
--- /dev/null
+++ b/sysutils/nq/pkg-plist
@@ -0,0 +1,7 @@
+bin/fq
+bin/nq
+bin/tq
+man/man1/fq.1.gz
+man/man1/nq.1.gz
+man/man1/tq.1.gz
+share/zsh/site-functions/_nq