aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-08-30 04:52:34 +0800
committerpawel <pawel@FreeBSD.org>2013-08-30 04:52:34 +0800
commit679b472c5c80ddaa92134b44eefe615b1e4f7141 (patch)
tree9f0a6fd70e6192077de704b9dda6b9e0c13f3377 /sysutils
parent3a68b788b9d64f074eae4d8c2c8ceac70b85c820 (diff)
downloadfreebsd-ports-gnome-679b472c5c80ddaa92134b44eefe615b1e4f7141.tar.gz
freebsd-ports-gnome-679b472c5c80ddaa92134b44eefe615b1e4f7141.tar.zst
freebsd-ports-gnome-679b472c5c80ddaa92134b44eefe615b1e4f7141.zip
Update to version 3.2
qjail-3.2 change log 1. Added IPv6 support to "create" and "config" commands. 2. Changed the way jail status is determined. Now use "jls -j jailname jid" command instead of carring internal jid field in jail definition record. This fixed jail status problem when users used the "halt or reboot" command on the host instead of the "shutdown now" command. 3. Changed qjail-bootime script to nolonger populate internal jid field in jail definition record. 4. Corrected coding of conflicts_install parameter in the port Makefile so it functions as wanted. Also inserted message info block about upgrade procedure and CONFLICT resolution. 5. Removed all references to qjail.conf file from all man pages. 6. Corrected examples in qjail man for "qjail create" command using new -4 option for IPv4 IP addresses. qjail-3.1 change log http://www.freebsd.org/cgi/query-pr.cgi?pr=179769 1. sharefs/usr/src and sharefs/usr/ports were missing links. Design was to have sharedfs share those directories with all jails. Added code to mkdir src and port on sharedfs and link to template. 2. For update -b, archive sharedfs, restore sharedfs and install commands, replaced the logic of rolling through the qjail.local directory opening each definition file to check if jail was running which left the last opened jail variables populated, with logic based on using jls command to list the running jails and then checking jls list to qjail.global directory content of qjail owned jails to determine if jail was running. 3. For archive of image jail, removed qjail prefix from variable name. 4. For "update -b" host binaries have noschg set on a few files, added chflags -R noschg "${sharedfs}/${dir}" chflags -R nosunlink "${sharedfs}/${dir}" commands to remove said status on all files. 5. Add "mount.devfs=1" parameters to build_def function of qjail script and qjail-bootime script. This enables ps and top commands to work inside of jail. This is a work around for /dev bug in jail(8). 6. "qjail create -a img20 -i 25 img25 10.0.10.20" Using a image archive caused cpio to complain when copying the template to populate the img file. Replaced cpio with "cp -R dir/" command, also made the same change to the dup image logic. The cpio command has problems working with sparse files. 7. Added "qjail config -h" option. This option provides a way to enable "SSH" on a jail. Same option as -c of the "qjail create" command. 8. Updated "man qjail" with instructions on using the "mv" command to give jails access to the hosts "/usr/ports" or "/usr/src" directories. 9. Added new function to "config" command call -m for manual start jails, -m to enable and -M to disable. 10. Changed the "config" command call -r [run, norun] option to -r to enable and -R to disable. qjail-3.0 change log http://www.freebsd.org/cgi/query-pr.cgi?pr=179184 1. This version of qjail has been converted from using the legacy rc.d-method as used in all previous versions of qjail, to using the jail(8) jail.conf-method available in RELEASE-9.1. This upgrade provides the ability to enable the following new options on a per-jail basis. exec.fib, allow.raw_sockets, allow.quotas, allow.mount.nullfs, allow.mount.zfs, cpuset.id, securelevel, vnet.interface, and vnet. The vnet option gives a jail its own network stack using the experimental vimage software with or with out ipfw firewall and using if_bridge/epair or netgraph for its network. This qjail version is not functional for RELEASES older than RELEASE-9.1. 2. The basejail has been renamed to sharedfs and newjail has been renamed to template. 3. The archive function now uses the tar utility to bkup the jailname filesystem with it's internal qjail admin files. 4. The restore function now uses the tar utility to restore the jailname filesystem with it's internal qjail admin files. 5. The -a option of the create command now uses the tar utility to restore the jailname filesystem. 6. The qjail man page up-dated to reflect all changes to qjail. 7. The qjail.conf file has been deprecated and removed. 8. Added logic to the "config" command to enable and disable the jail(8) selected extended options. PR: ports/180773 Submitted by: Joe Barbish <qjail@a1poweruser.com> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/qjail/Makefile9
-rw-r--r--sysutils/qjail/distinfo4
-rw-r--r--sysutils/qjail/files/pkg-message.in (renamed from sysutils/qjail/pkg-message)12
-rw-r--r--sysutils/qjail/pkg-plist2
4 files changed, 19 insertions, 8 deletions
diff --git a/sysutils/qjail/Makefile b/sysutils/qjail/Makefile
index ca224dd4103d..7db9d86ee4b6 100644
--- a/sysutils/qjail/Makefile
+++ b/sysutils/qjail/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qjail
-PORTVERSION= 3.1
+PORTVERSION= 3.2
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}
@@ -11,11 +11,10 @@ COMMENT= Utility to quickly deploy and manage jails
USE_BZIP2= yes
NO_BUILD= yes
+SUB_FILES= pkg-message
MAN8= qjail.8 qjail-intro.8 qjail-howto.8
-CONFLICTS_INSTALL= qjail-1.* qjail-2.*
-
post-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} \
-e 's|/usr/local|${PREFIX}|'
@@ -35,9 +34,9 @@ do-install:
@(cd ${WRKSRC}/examples/ \
&& ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+# Note: Has to be done this way or package version will not contain any
+# comments added with @${ECHO_MSG} command.
post-install:
- @${ECHO_MSG} "#"
@${CAT} ${PKGMESSAGE}
- @${ECHO_MSG} "#"
.include <bsd.port.mk>
diff --git a/sysutils/qjail/distinfo b/sysutils/qjail/distinfo
index 816e6b689805..89c193aa8237 100644
--- a/sysutils/qjail/distinfo
+++ b/sysutils/qjail/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qjail-3.1.tar.bz2) = bee2c505ca735aa5de1e8b88680ee5d61bf42e505c5d4d28c899bb5caaaf3ac8
-SIZE (qjail-3.1.tar.bz2) = 119940
+SHA256 (qjail-3.2.tar.bz2) = 3088c1946e720ddc3fb6f78254f8616951de3a90f0e6e0dfbd4d49c16febe697
+SIZE (qjail-3.2.tar.bz2) = 121560
diff --git a/sysutils/qjail/pkg-message b/sysutils/qjail/files/pkg-message.in
index dfdfe11bb684..71a42e4cc3f5 100644
--- a/sysutils/qjail/pkg-message
+++ b/sysutils/qjail/files/pkg-message.in
@@ -1,6 +1,18 @@
+
+########################################################################
+
Use the qjail utility to deploy small or large numbers of jails quickly.
First issue "rehash" command to enable the qjail command (if using csh).
Then issue "man qjail-intro" to read the qjail introduction.
After reading that do "man qjail" for the usage details.
For the BIG PICTURE issue "man qjail-howto".
+
+########################################################################
+
+
+For instructions on upgrading jail filesystems
+Read %%EXAMPLESDIR%%/upgrade-info.txt
+
+
+
diff --git a/sysutils/qjail/pkg-plist b/sysutils/qjail/pkg-plist
index d06c16bc15c2..ba6ad4adc035 100644
--- a/sysutils/qjail/pkg-plist
+++ b/sysutils/qjail/pkg-plist
@@ -3,9 +3,9 @@ bin/qjail.vnet.be
bin/qjail.vnet.ng
etc/qjail.portsnap.conf
etc/rc.d/qjail.bootime
+%%EXAMPLESDIR%%/upgrade-info.txt
%%EXAMPLESDIR%%/vnet/jail.amd64
%%EXAMPLESDIR%%/vnet/jail.i386
-%%EXAMPLESDIR%%/vnet/nullfs.diff
%%EXAMPLESDIR%%/vnet/ipfw.rules.host
%%EXAMPLESDIR%%/vnet/ipfw.rules.vnet
%%EXAMPLESDIR%%/vnet/ipf.rules.host