aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-09 16:51:33 +0800
committertobik <tobik@FreeBSD.org>2018-09-09 16:51:33 +0800
commit67b2e092ce083fe66916d06977350dad0b7476ed (patch)
treef8956b4ad8b1e755b092c675f8536223c9a36b95 /sysutils
parente6d11de37683972d97c09b99b6eea7f17b3fb725 (diff)
downloadfreebsd-ports-gnome-67b2e092ce083fe66916d06977350dad0b7476ed.tar.gz
freebsd-ports-gnome-67b2e092ce083fe66916d06977350dad0b7476ed.tar.zst
freebsd-ports-gnome-67b2e092ce083fe66916d06977350dad0b7476ed.zip
New port: sysutils/yank
The yank utility reads input from stdin and display a selection interface that allows a field to be selected and copied to the clipboard. Fields are either recognized by a regular expression or by splitting the input on a delimiter sequence. WWW: https://github.com/mptre/yank
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/yank/Makefile20
-rw-r--r--sysutils/yank/distinfo3
-rw-r--r--sysutils/yank/files/patch-Makefile14
-rw-r--r--sysutils/yank/pkg-descr6
5 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4c7adb9213f1..12905b0ab735 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1468,6 +1468,7 @@
SUBDIR += xsysstats
SUBDIR += xvidcap
SUBDIR += yadm
+ SUBDIR += yank
SUBDIR += yum
SUBDIR += zap
SUBDIR += zbackup
diff --git a/sysutils/yank/Makefile b/sysutils/yank/Makefile
new file mode 100644
index 000000000000..6591be2388c4
--- /dev/null
+++ b/sysutils/yank/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= yank
+DISTVERSION= 1.0.0
+CATEGORIES= sysutils
+MASTER_SITES= https://github.com/mptre/yank/releases/download/v${DISTVERSION}/
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Yank terminal output to clipboard
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= xsel-conrad>=0:x11/xsel-conrad
+
+MAKE_ARGS= MANPREFIX=${PREFIX}/man
+PLIST_FILES= bin/yank \
+ man/man1/yank.1.gz
+
+.include <bsd.port.mk>
diff --git a/sysutils/yank/distinfo b/sysutils/yank/distinfo
new file mode 100644
index 000000000000..f0997f4861e8
--- /dev/null
+++ b/sysutils/yank/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536480383
+SHA256 (yank-1.0.0.tar.gz) = 20ba1b01a7514f2f670702e83846f42429e2e90491dc1f679c8319a45a0382de
+SIZE (yank-1.0.0.tar.gz) = 8364
diff --git a/sysutils/yank/files/patch-Makefile b/sysutils/yank/files/patch-Makefile
new file mode 100644
index 000000000000..41962fc08b9b
--- /dev/null
+++ b/sysutils/yank/files/patch-Makefile
@@ -0,0 +1,14 @@
+https://github.com/mptre/yank/pull/43
+
+--- Makefile.orig 2018-09-09 07:45:36 UTC
++++ Makefile
+@@ -23,6 +23,9 @@ DISTFILES= CHANGELOG.md \
+
+ all: ${PROG}
+
++.c.o:
++ ${CC} ${CPPFLAGS} ${CFLAGS} -c ${<}
++
+ ${PROG}: ${OBJS}
+ ${CC} -o ${PROG} ${OBJS} ${LDFLAGS}
+
diff --git a/sysutils/yank/pkg-descr b/sysutils/yank/pkg-descr
new file mode 100644
index 000000000000..aed92bf08990
--- /dev/null
+++ b/sysutils/yank/pkg-descr
@@ -0,0 +1,6 @@
+The yank utility reads input from stdin and display a selection
+interface that allows a field to be selected and copied to the
+clipboard. Fields are either recognized by a regular expression
+or by splitting the input on a delimiter sequence.
+
+WWW: https://github.com/mptre/yank