aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2014-05-25 00:03:58 +0800
committerolgeni <olgeni@FreeBSD.org>2014-05-25 00:03:58 +0800
commit695d0a0b759ed14859c186c3ffc5b09928e94317 (patch)
tree733d481161712ddc6457c38fc4a87d85804c9fb1 /sysutils
parent138c58efe515bed47cfa3bbe7e8701a8b5fdb131 (diff)
downloadfreebsd-ports-gnome-695d0a0b759ed14859c186c3ffc5b09928e94317.tar.gz
freebsd-ports-gnome-695d0a0b759ed14859c186c3ffc5b09928e94317.tar.zst
freebsd-ports-gnome-695d0a0b759ed14859c186c3ffc5b09928e94317.zip
A couple of fixes:
- Remove some generic Linux configuration files containing the '*' character: they are interpreted as shell globs in the plist and cause poudriere's staging tests to fail. - Do not let the setup script change file owners and permissions.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/webmin/Makefile5
-rw-r--r--sysutils/webmin/files/patch-aa26
-rw-r--r--sysutils/webmin/pkg-plist7
3 files changed, 22 insertions, 16 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index e61d51fd9c3c..85bb25485f90 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webmin
PORTVERSION= 1.690
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://download.webmin.com/updates/:up \
SF/webadmin/${PORTNAME}/${PORTVERSION}:sf \
@@ -56,6 +57,10 @@ post-patch:
@${FIND} ${WRKSRC} -name "*.bak" -delete
@${FIND} ${WRKSRC} -name "*.pyc" -delete
+.for module in ldap-server ldap-client ldap-useradmin logrotate status time webalizer
+ @${RM} ${WRKSRC}/${module}/config-\*-linux
+.endfor
+
@${PRINTF} "g/^FreeBSD/m0\nwq\n" | ex ${WRKSRC}/os_list.txt
do-build:
diff --git a/sysutils/webmin/files/patch-aa b/sysutils/webmin/files/patch-aa
index 92d5509242cb..7040aca38b72 100644
--- a/sysutils/webmin/files/patch-aa
+++ b/sysutils/webmin/files/patch-aa
@@ -3,7 +3,7 @@ $FreeBSD$
--- setup.sh.orig
+++ setup.sh
-@@ -15,16 +15,8 @@
+@@ -17,16 +17,8 @@
srcdir=$wadir
ver=`cat "$wadir/version"`
@@ -22,7 +22,7 @@ $FreeBSD$
echo "***********************************************************************"
echo "* Welcome to the Webmin setup script, version $ver *"
-@@ -95,19 +87,7 @@
+@@ -97,19 +89,7 @@
echo "Unless you want to run multiple versions of Webmin at the same time"
echo "you can just accept the defaults."
echo ""
@@ -43,7 +43,7 @@ $FreeBSD$
if [ ! -d $config_dir ]; then
mkdir $config_dir;
if [ $? != 0 ]; then
-@@ -207,12 +187,12 @@
+@@ -209,12 +189,12 @@
fi
# Ask for log directory
@@ -58,7 +58,7 @@ $FreeBSD$
fi
abspath=`echo $var_dir | grep "^/"`
if [ "$abspath" = "" ]; then
-@@ -240,7 +220,9 @@
+@@ -242,7 +222,9 @@
echo "Webmin is written entirely in Perl. Please enter the full path to the"
echo "Perl 5 interpreter on your system."
echo ""
@@ -69,7 +69,7 @@ $FreeBSD$
perldef=/usr/bin/perl
elif [ -x /usr/local/bin/perl ]; then
perldef=/usr/local/bin/perl
-@@ -439,22 +421,6 @@
+@@ -441,22 +423,6 @@
fi
fi
@@ -92,7 +92,7 @@ $FreeBSD$
# Copy files to target directory
echo "***********************************************************************"
if [ "$wadir" != "$srcdir" ]; then
-@@ -576,6 +542,7 @@
+@@ -578,6 +544,7 @@
fi
fi
@@ -100,7 +100,7 @@ $FreeBSD$
if [ "$noperlpath" = "" ]; then
echo "Inserting path to perl into scripts.."
(find "$wadir" -name '*.cgi' -print ; find "$wadir" -name '*.pl' -print) | $perl "$wadir/perlpath.pl" $perl -
-@@ -586,7 +553,6 @@
+@@ -588,7 +555,6 @@
echo "Creating start and stop scripts.."
rm -f $config_dir/stop $config_dir/start $config_dir/restart $config_dir/reload
echo "#!/bin/sh" >>$config_dir/start
@@ -108,7 +108,7 @@ $FreeBSD$
echo "trap '' 1" >>$config_dir/start
echo "LANG=" >>$config_dir/start
echo "export LANG" >>$config_dir/start
-@@ -734,6 +700,7 @@
+@@ -724,6 +690,7 @@
echo passdelay=1 >> $config_dir/miniserv.conf
fi
@@ -116,7 +116,15 @@ $FreeBSD$
if [ "$nouninstall" = "" ]; then
echo "Creating uninstall script $config_dir/uninstall.sh .."
cat >$config_dir/uninstall.sh <<EOF
-@@ -823,6 +790,7 @@
+@@ -761,6 +728,7 @@
+ chmod -R og-rw $config_dir/$f
+ done
+ chmod +r $config_dir/version
++nochown="yes"
+ if [ "$nochown" = "" ]; then
+ # Make program directory non-world-writable, but executable
+ chown -R root "$wadir"
+@@ -813,6 +781,7 @@
. "$srcdir/setup-post.sh"
fi
diff --git a/sysutils/webmin/pkg-plist b/sysutils/webmin/pkg-plist
index 9965f36f9702..088879a7b11e 100644
--- a/sysutils/webmin/pkg-plist
+++ b/sysutils/webmin/pkg-plist
@@ -10049,7 +10049,6 @@ lib/webmin/lang_list.txt
lib/webmin/ldap-client/CHANGELOG
lib/webmin/ldap-client/browser.cgi
lib/webmin/ldap-client/check.cgi
-lib/webmin/ldap-client/config-*-linux
lib/webmin/ldap-client/config-debian-linux-3.1
lib/webmin/ldap-client/config-debian-linux-4.0-5.9
lib/webmin/ldap-client/config-debian-linux-6.0-6.9
@@ -10148,7 +10147,6 @@ lib/webmin/ldap-server/backup_config.pl
lib/webmin/ldap-server/bootup.cgi
lib/webmin/ldap-server/cgi_args.pl
lib/webmin/ldap-server/config
-lib/webmin/ldap-server/config-*-linux
lib/webmin/ldap-server/config-Redhat-Enterprise-Linux-6.0-*
lib/webmin/ldap-server/config-Scientific-Linux-6.0-*
lib/webmin/ldap-server/config-Ubuntu-Linux-8.10-*
@@ -10274,7 +10272,6 @@ lib/webmin/ldap-useradmin/batch_exec.cgi
lib/webmin/ldap-useradmin/batch_form.cgi
lib/webmin/ldap-useradmin/cgi_args.pl
lib/webmin/ldap-useradmin/config
-lib/webmin/ldap-useradmin/config-*-linux
lib/webmin/ldap-useradmin/config-coherent-linux
lib/webmin/ldap-useradmin/config-debian-linux
lib/webmin/ldap-useradmin/config-debian-linux-3.1
@@ -10452,7 +10449,6 @@ lib/webmin/logrotate/CHANGELOG
lib/webmin/logrotate/backup_config.pl
lib/webmin/logrotate/cgi_args.pl
lib/webmin/logrotate/config
-lib/webmin/logrotate/config-*-linux
lib/webmin/logrotate/config-debian-linux
lib/webmin/logrotate/config-freebsd
lib/webmin/logrotate/config-open-linux
@@ -20478,7 +20474,6 @@ lib/webmin/status/cfengine-monitor.pl
lib/webmin/status/cgi_args.pl
lib/webmin/status/change-monitor.pl
lib/webmin/status/config
-lib/webmin/status/config-*-linux
lib/webmin/status/config-debian-linux
lib/webmin/status/config-debian-linux-3.0
lib/webmin/status/config-debian-linux-3.1-*
@@ -21131,7 +21126,6 @@ lib/webmin/time/CHANGELOG
lib/webmin/time/acl_security.pl
lib/webmin/time/apply.cgi
lib/webmin/time/backup_config.pl
-lib/webmin/time/config-*-linux
lib/webmin/time/config-freebsd
lib/webmin/time/config-hpux
lib/webmin/time/config-irix
@@ -22629,7 +22623,6 @@ lib/webmin/webalizer/acl_security.pl
lib/webmin/webalizer/backup_config.pl
lib/webmin/webalizer/cgi_args.pl
lib/webmin/webalizer/config
-lib/webmin/webalizer/config-*-linux
lib/webmin/webalizer/config-debian-linux-4.0-*
lib/webmin/webalizer/config-freebsd
lib/webmin/webalizer/config-gentoo-linux