aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2012-04-25 09:33:04 +0800
committercy <cy@FreeBSD.org>2012-04-25 09:33:04 +0800
commit6e13c628bd8299a8f1f81d50c257da6313a5465b (patch)
tree389191b0a139572f333ad028b3ed06099ea10dbb /sysutils
parentf636d91519f2b578f442ffcec6044c473d7335eb (diff)
downloadfreebsd-ports-gnome-6e13c628bd8299a8f1f81d50c257da6313a5465b.tar.gz
freebsd-ports-gnome-6e13c628bd8299a8f1f81d50c257da6313a5465b.tar.zst
freebsd-ports-gnome-6e13c628bd8299a8f1f81d50c257da6313a5465b.zip
cfengine 3.2.3 is now -legacy.
PR: 167083 Discussed with: gjb
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cfengine3-legacy/Makefile66
-rw-r--r--sysutils/cfengine3-legacy/distinfo4
-rw-r--r--sysutils/cfengine3-legacy/pkg-plist32
3 files changed, 35 insertions, 67 deletions
diff --git a/sysutils/cfengine3-legacy/Makefile b/sysutils/cfengine3-legacy/Makefile
index 7212ce1c5f81..f8d5edf21cb3 100644
--- a/sysutils/cfengine3-legacy/Makefile
+++ b/sysutils/cfengine3-legacy/Makefile
@@ -1,4 +1,4 @@
-
+# New ports collection makefile for: cfengine v3
# Date created: February 2, 2009
# Whom: jrhett@netconsonance.com
#
@@ -6,74 +6,48 @@
#
PORTNAME= cfengine
-PORTVERSION= 3.3.0
+PORTVERSION= 3.2.3
+PORTREVISION= 1
+PORTEPOCH= 1
CATEGORIES= sysutils
MASTER_SITES= http://cfengine.com/source-code/download?file=
+PKGNAMESUFFIX= -legacy
MAINTAINER= cy@FreeBSD.org
COMMENT= A systems administration tool for networks
-LATEST_LINK= cfengine3
-FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
+LATEST_LINK= cfengine3-legacy
+FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
-CONFLICTS= cfengine-2*
+CONFLICTS= cfengine-[23]*
USE_RC_SUBR= cf-execd cf-serverd
-USE_LDCONFIG= yes
+WITH_BDB_VER?= 47
+USE_BDB= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
-DOCSDIR= ${PREFIX}/share/doc/cfengine
+DOCSDIR= ${PREFIX}/share/doc/cfengine3
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
--htmldir=${DOCSDIR}/html \
- --mandir=${PREFIX}/man \
- --with-pcre=${LOCALBASE} \
- --enable-fhs
-
-LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+ --with-berkeleydb=${LOCALBASE}
-OPTIONS= TOKYOCABINET "Enable TokyoCabinet support" on \
- QDBM "Enable QDBM support" off \
- PGSQL "Enable PostgreSQL connector" off \
- MYSQL "Enable MySQL connector" off
+CONFIGURE_ENV+= BERKELEY_DB_CFLAGS=-I${BDB_INCLUDE_DIR} \
+ BERKELEY_DB_LDFLAGS=-L${BDB_LIB_DIR} \
+ BERKELEY_DB_LIB=-l${BDB_LIB_NAME}
+OPTIONS= PCRE "Enable Perl-compatible regular expressions" on
.include <bsd.port.pre.mk>
-.if defined(WITH_TOKYOCABINET) && defined(WITH_QDBM)
-BROKEN= TOKYOCABINET and QDBM are mutuallly exclusive
-.endif
-
-.if !defined(WITH_TOKYOCABINET) && !defined(WITH_QDBM)
-BROKEN= TOKYOCABINET or QDBM must be defined
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
.endif
-.if defined(WITH_TOKYOCABINET)
-CONFIGURE_ARGS+= --with-tokyocabinet=${LOCALBASE}
-LIB_DEPENDS+= tokyocabinet.9:${PORTSDIR}/databases/tokyocabinet
-.endif
-
-.if defined(WITH_QDBM)
-CONFIGURE_ARGS+= --with-qdbm=${LOCALBASE}
-LIB_DEPENDS+= qdbm.14:${PORTSDIR}/databases/qdbm
-.endif
-
-.if defined(WITH_PGSQL)
-CONFIGURE_ARGS+= --with-postgresql=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --with-postgresql=no
-.endif
-
-.if defined(WITH_MYSQL)
-CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --with-mysql=no
-.endif
-
-
MAN8= cf-agent.8 cf-key.8 cf-monitord.8 \
cf-report.8 cf-serverd.8 cf-execd.8 \
cf-know.8 cf-promises.8 cf-runagent.8
+
post-patch:
@${REINPLACE_CMD} -e '/^htmldir/s!=.*!= @htmldir@!'\
diff --git a/sysutils/cfengine3-legacy/distinfo b/sysutils/cfengine3-legacy/distinfo
index dbede959d2cd..273366103b79 100644
--- a/sysutils/cfengine3-legacy/distinfo
+++ b/sysutils/cfengine3-legacy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cfengine-3.3.0.tar.gz) = 170a65cce35b9b333594543b9b3480e5d9c19c28e275431e6e58a3be9372c0a7
-SIZE (cfengine-3.3.0.tar.gz) = 1236769
+SHA256 (cfengine-3.2.3.tar.gz) = 20748f2d10ec4e3623138c2ae1cf7d78d147b8c5c15be42965c3155d0762792d
+SIZE (cfengine-3.2.3.tar.gz) = 1128462
diff --git a/sysutils/cfengine3-legacy/pkg-plist b/sysutils/cfengine3-legacy/pkg-plist
index 16fde280b479..a42b443c43bc 100644
--- a/sysutils/cfengine3-legacy/pkg-plist
+++ b/sysutils/cfengine3-legacy/pkg-plist
@@ -1,6 +1,6 @@
-libexec/cfengine/libpromises.la
-libexec/cfengine/libpromises.so
-libexec/cfengine/libpromises.so.1
+lib/libpromises.la
+lib/libpromises.so
+lib/libpromises.so.1
sbin/cf-agent
sbin/cf-execd
sbin/cf-key
@@ -10,9 +10,9 @@ sbin/cf-promises
sbin/cf-report
sbin/cf-runagent
sbin/cf-serverd
-share/cfengine/CoreBase/failsafe.cf
-share/cfengine/CoreBase/cfengine_stdlib.cf
-share/cfengine/CoreBase/promises.cf
+share/cfengine/masterfiles/cfengine_stdlib.cf
+share/cfengine/masterfiles/failsafe.cf
+share/cfengine/masterfiles/promises.cf
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/README
%%DOCSDIR%%/example_config/cfengine_stdlib.cf
@@ -22,8 +22,7 @@ share/cfengine/CoreBase/promises.cf
%%DOCSDIR%%/example_config/update.cf
%%DOCSDIR%%/examples/active_directory.cf
%%DOCSDIR%%/examples/app_baseline.cf
-%%DOCSDIR%%/examples/guest_environment_kvm.cf
-%%DOCSDIR%%/examples/hostswithclass.cf
+%%DOCSDIR%%/examples/cfengine_stdlib.cf
%%DOCSDIR%%/examples/promise_knowledge.cf
%%DOCSDIR%%/examples/unit_abort.cf
%%DOCSDIR%%/examples/unit_accessed_before.cf
@@ -81,6 +80,8 @@ share/cfengine/CoreBase/promises.cf
%%DOCSDIR%%/examples/unit_edit_setvar.cf
%%DOCSDIR%%/examples/unit_edit_triggerclass.cf
%%DOCSDIR%%/examples/unit_env.cf
+%%DOCSDIR%%/examples/unit_environment.cf
+%%DOCSDIR%%/examples/unit_environment_simple.cf
%%DOCSDIR%%/examples/unit_epimenides.cf
%%DOCSDIR%%/examples/unit_escape.cf
%%DOCSDIR%%/examples/unit_exec_args.cf
@@ -144,15 +145,12 @@ share/cfengine/CoreBase/promises.cf
%%DOCSDIR%%/examples/unit_log_private.cf
%%DOCSDIR%%/examples/unit_loops.cf
%%DOCSDIR%%/examples/unit_lsdir.cf
-%%DOCSDIR%%/examples/unit_maplist.cf
%%DOCSDIR%%/examples/unit_measure_log.cf
%%DOCSDIR%%/examples/unit_measurements.cf
%%DOCSDIR%%/examples/unit_menu.cf
%%DOCSDIR%%/examples/unit_method.cf
-%%DOCSDIR%%/examples/unit_method_polymorph.cf
%%DOCSDIR%%/examples/unit_method_validate.cf
%%DOCSDIR%%/examples/unit_method_var.cf
-%%DOCSDIR%%/examples/unit_method_var2.cf
%%DOCSDIR%%/examples/unit_module_exec.cf
%%DOCSDIR%%/examples/unit_module_exec_2.cf
%%DOCSDIR%%/examples/unit_monitord.cf
@@ -161,11 +159,10 @@ share/cfengine/CoreBase/promises.cf
%%DOCSDIR%%/examples/unit_neighbourhood_watch.cf
%%DOCSDIR%%/examples/unit_null_config.cf
%%DOCSDIR%%/examples/unit_occurrences.cf
-%%DOCSDIR%%/examples/unit_orchestration_hostlist.cf
%%DOCSDIR%%/examples/unit_ordering.cf
%%DOCSDIR%%/examples/unit_package_apt.cf
%%DOCSDIR%%/examples/unit_package_freebsd.cf
-%%DOCSDIR%%/examples/unit_package_latest.cf
+%%DOCSDIR%%/examples/unit_package_hash.cf
%%DOCSDIR%%/examples/unit_package_msi_file.cf
%%DOCSDIR%%/examples/unit_package_msi_version.cf
%%DOCSDIR%%/examples/unit_package_rpm.cf
@@ -185,6 +182,7 @@ share/cfengine/CoreBase/promises.cf
%%DOCSDIR%%/examples/unit_process_restart.cf
%%DOCSDIR%%/examples/unit_process_restart_basic.cf
%%DOCSDIR%%/examples/unit_process_signalling.cf
+%%DOCSDIR%%/examples/unit_services_win.cf
%%DOCSDIR%%/examples/unit_product.cf
%%DOCSDIR%%/examples/unit_promises.cf
%%DOCSDIR%%/examples/unit_readlist.cf
@@ -220,12 +218,9 @@ share/cfengine/CoreBase/promises.cf
%%DOCSDIR%%/examples/unit_server_flatcopy_localhost.cf
%%DOCSDIR%%/examples/unit_service_disable.cf
%%DOCSDIR%%/examples/unit_service_start.cf
-%%DOCSDIR%%/examples/unit_services_concept.cf
-%%DOCSDIR%%/examples/unit_services_win.cf
%%DOCSDIR%%/examples/unit_setuidlog.cf
%%DOCSDIR%%/examples/unit_setvar.cf
%%DOCSDIR%%/examples/unit_software_dist.cf
-%%DOCSDIR%%/examples/unit_software_update_version_yum.cf
%%DOCSDIR%%/examples/unit_splitstring.cf
%%DOCSDIR%%/examples/unit_sql.cf
%%DOCSDIR%%/examples/unit_storage.cf
@@ -250,13 +245,12 @@ share/cfengine/CoreBase/promises.cf
%%DOCSDIR%%/examples/unit_warnifline.cf
%%DOCSDIR%%/examples/unit_webserver.cf
%%DOCSDIR%%/examples/unit_zenoss.cf
-%%DOCSDIR%%/examples/win_dns_client.cf
%%DOCSDIR%%/examples/win_emergency.cf
%%DOCSDIR%%/examples/win_registry.cf
%%DOCSDIR%%/examples/win_schedule.cf
+%%DOCSDIR%%/examples/win_services.cf
@dirrm %%DOCSDIR%%/examples
@dirrm %%DOCSDIR%%/example_config
@dirrm %%DOCSDIR%%
-@dirrm share/cfengine/CoreBase
+@dirrm share/cfengine/masterfiles
@dirrm share/cfengine
-@dirrm libexec/cfengine