aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-10 12:25:21 +0800
committermarino <marino@FreeBSD.org>2016-09-10 12:25:21 +0800
commit6f192edb40026f5670785dcb16b7fe2f97ca101e (patch)
treee78f73bbbf24924ef7f8011931bbc12e7f240f77 /sysutils
parentfbcbc0498684050513f6aea36e124b9f1e2ebe86 (diff)
downloadfreebsd-ports-gnome-6f192edb40026f5670785dcb16b7fe2f97ca101e.tar.gz
freebsd-ports-gnome-6f192edb40026f5670785dcb16b7fe2f97ca101e.tar.zst
freebsd-ports-gnome-6f192edb40026f5670785dcb16b7fe2f97ca101e.zip
sysutils/cfengine3[2345]: document SSL requirement and set flags accordingly
Approved by: SSL blanket
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cfengine32/Makefile2
-rw-r--r--sysutils/cfengine33/Makefile5
-rw-r--r--sysutils/cfengine34/Makefile5
-rw-r--r--sysutils/cfengine35/Makefile5
4 files changed, 11 insertions, 6 deletions
diff --git a/sysutils/cfengine32/Makefile b/sysutils/cfengine32/Makefile
index 7728ecc808ef..ffbf6f4b204b 100644
--- a/sysutils/cfengine32/Makefile
+++ b/sysutils/cfengine32/Makefile
@@ -25,6 +25,8 @@ LIB_DEPENDS= libpcre.so:devel/pcre
USES= bdb cpe libtool ssl
GNU_CONFIGURE= yes
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
DOCSDIR= ${PREFIX}/share/doc/cfengine3
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
diff --git a/sysutils/cfengine33/Makefile b/sysutils/cfengine33/Makefile
index f03729cecd50..483e9a28268f 100644
--- a/sysutils/cfengine33/Makefile
+++ b/sysutils/cfengine33/Makefile
@@ -20,10 +20,11 @@ CONFLICTS= cfengine-2* cfengine-3.[24-9]* cfengine-devel-*
USE_RC_SUBR= cf-execd cf-serverd
-USES= cpe gmake libtool
+USES= cpe gmake libtool ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
DOCSDIR= ${PREFIX}/share/doc/cfengine
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
diff --git a/sysutils/cfengine34/Makefile b/sysutils/cfengine34/Makefile
index eab239aebcff..6cdeba76285e 100644
--- a/sysutils/cfengine34/Makefile
+++ b/sysutils/cfengine34/Makefile
@@ -23,10 +23,11 @@ CONFLICTS= cfengine-2* cfengine-3.[235-9]* cfengine-devel-*
USE_RC_SUBR= cf-execd cf-serverd
-USES= cpe libtool gmake
+USES= cpe gmake libtool ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
DOCSDIR= ${PREFIX}/share/doc/cfengine
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
diff --git a/sysutils/cfengine35/Makefile b/sysutils/cfengine35/Makefile
index e6224b8d3d90..416d2d68393d 100644
--- a/sysutils/cfengine35/Makefile
+++ b/sysutils/cfengine35/Makefile
@@ -28,11 +28,12 @@ CONFLICTS= cfengine-[2346-9]*
USE_RC_SUBR= cf-execd cf-serverd cf-monitord
-USES= cpe gmake libtool
+USES= cpe gmake libtool ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CFLAGS+= -Wno-return-type
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
DOCSDIR= ${PREFIX}/share/doc/cfengine
CONFIGURE_ARGS= --docdir=${DOCSDIR} \