aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-04 21:34:03 +0800
committertobik <tobik@FreeBSD.org>2018-09-04 21:34:03 +0800
commit70897ef270816097c717b33b815255e45ab966fb (patch)
tree90dff35fb52ecabb4219fecc0401b2f7ce9eb9e3 /sysutils
parent87ba815fec796e1f47b85bcd7d10b4cdaea3ad7f (diff)
downloadfreebsd-ports-gnome-70897ef270816097c717b33b815255e45ab966fb.tar.gz
freebsd-ports-gnome-70897ef270816097c717b33b815255e45ab966fb.tar.zst
freebsd-ports-gnome-70897ef270816097c717b33b815255e45ab966fb.zip
sysutils/npadmin: Fix build with Clang 6
npadmin.C:109:41: error: constant expression evaluates to 2147483648 which cannot be narrowed to type 'int' [-Wc++11-narrowing] {"covers", no_argument,&retval,COVER_FLAG}, ^~~~~~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p478648_s338416/logs/errors/npadmin-0.8.7_1.log
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/npadmin/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/sysutils/npadmin/Makefile b/sysutils/npadmin/Makefile
index 50255c95bdf9..7a93a85db567 100644
--- a/sysutils/npadmin/Makefile
+++ b/sysutils/npadmin/Makefile
@@ -10,8 +10,12 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= SNMP based command line network printer management tool
+USES= compiler
GNU_CONFIGURE= yes
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
+
PLIST_FILES= bin/npadmin man/man1/${PORTNAME}.1.gz
pre-configure: