aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlkoeller <lkoeller@FreeBSD.org>2004-07-03 22:57:20 +0800
committerlkoeller <lkoeller@FreeBSD.org>2004-07-03 22:57:20 +0800
commit750e47ea37aa71706506b9dbaa127927512e862c (patch)
tree0105e126b46571f65022ba1b7e3906964e36bed5 /sysutils
parent15df1b01ebbc7c6f0af0acdde24174be515729be (diff)
downloadfreebsd-ports-gnome-750e47ea37aa71706506b9dbaa127927512e862c.tar.gz
freebsd-ports-gnome-750e47ea37aa71706506b9dbaa127927512e862c.tar.zst
freebsd-ports-gnome-750e47ea37aa71706506b9dbaa127927512e862c.zip
o) Fix wx-console compile problem.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bacula-server/Makefile2
-rw-r--r--sysutils/bacula-server/files/patch-src-wx-console31
-rw-r--r--sysutils/bacula/Makefile2
-rw-r--r--sysutils/bacula/files/patch-src-wx-console31
4 files changed, 64 insertions, 2 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index 95a6fe086a0f..584c0f6054b9 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bacula
PORTVERSION= 1.34.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
diff --git a/sysutils/bacula-server/files/patch-src-wx-console b/sysutils/bacula-server/files/patch-src-wx-console
new file mode 100644
index 000000000000..6f388bef45e5
--- /dev/null
+++ b/sysutils/bacula-server/files/patch-src-wx-console
@@ -0,0 +1,31 @@
+*** src/wx-console/wxbconfigpanel.cpp.orig Mon May 31 18:30:40 2004
+--- src/wx-console/wxbconfigpanel.cpp Sat Jul 3 16:37:15 2004
+***************
+*** 88,100 ****
+ wxString wxbConfigParam::GetValue() {
+ switch (type) {
+ case text:
+! return (statictext) ? statictext->GetLabel() : "";
+ break;
+ case modifiableText:
+! return (textctrl) ? textctrl->GetValue() : "";
+ break;
+ case choice:
+! return (choicectrl) ? choicectrl->GetStringSelection() : "";
+ break;
+ }
+ return "";
+--- 88,100 ----
+ wxString wxbConfigParam::GetValue() {
+ switch (type) {
+ case text:
+! return (statictext != NULL) ? statictext->GetLabel() : wxString("");
+ break;
+ case modifiableText:
+! return (textctrl != NULL) ? textctrl->GetValue() : wxString("");
+ break;
+ case choice:
+! return (choicectrl != NULL) ? choicectrl->GetStringSelection() : wxString("");
+ break;
+ }
+ return "";
diff --git a/sysutils/bacula/Makefile b/sysutils/bacula/Makefile
index 95a6fe086a0f..584c0f6054b9 100644
--- a/sysutils/bacula/Makefile
+++ b/sysutils/bacula/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bacula
PORTVERSION= 1.34.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
diff --git a/sysutils/bacula/files/patch-src-wx-console b/sysutils/bacula/files/patch-src-wx-console
new file mode 100644
index 000000000000..6f388bef45e5
--- /dev/null
+++ b/sysutils/bacula/files/patch-src-wx-console
@@ -0,0 +1,31 @@
+*** src/wx-console/wxbconfigpanel.cpp.orig Mon May 31 18:30:40 2004
+--- src/wx-console/wxbconfigpanel.cpp Sat Jul 3 16:37:15 2004
+***************
+*** 88,100 ****
+ wxString wxbConfigParam::GetValue() {
+ switch (type) {
+ case text:
+! return (statictext) ? statictext->GetLabel() : "";
+ break;
+ case modifiableText:
+! return (textctrl) ? textctrl->GetValue() : "";
+ break;
+ case choice:
+! return (choicectrl) ? choicectrl->GetStringSelection() : "";
+ break;
+ }
+ return "";
+--- 88,100 ----
+ wxString wxbConfigParam::GetValue() {
+ switch (type) {
+ case text:
+! return (statictext != NULL) ? statictext->GetLabel() : wxString("");
+ break;
+ case modifiableText:
+! return (textctrl != NULL) ? textctrl->GetValue() : wxString("");
+ break;
+ case choice:
+! return (choicectrl != NULL) ? choicectrl->GetStringSelection() : wxString("");
+ break;
+ }
+ return "";