aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-04-13 03:35:30 +0800
committerfjoe <fjoe@FreeBSD.org>2003-04-13 03:35:30 +0800
commit754eff1abebf529b8ec04cf390b6ec3e9742e10f (patch)
tree3beb0e458a586e64957008485ef91efcacd447f6 /sysutils
parentaecaf8a05c9cbe3c99d815c46cb6aa90f5b682ea (diff)
downloadfreebsd-ports-gnome-754eff1abebf529b8ec04cf390b6ec3e9742e10f.tar.gz
freebsd-ports-gnome-754eff1abebf529b8ec04cf390b6ec3e9742e10f.tar.zst
freebsd-ports-gnome-754eff1abebf529b8ec04cf390b6ec3e9742e10f.zip
New port: acidlaunch
Acidlaunch is a small, light-weight dockable app launcher with a simple XML-based configuration syntax. It's great as a small, simple app launcher, and it can optionally run in a withdrawn mode for embedding in the BlackBox slit. Submitted by: Alexey Dokuchaev
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/acidlaunch/Makefile31
-rw-r--r--sysutils/acidlaunch/distinfo1
-rw-r--r--sysutils/acidlaunch/files/patch-configure20
-rw-r--r--sysutils/acidlaunch/files/patch-src::Makefile.in11
-rw-r--r--sysutils/acidlaunch/pkg-descr7
-rw-r--r--sysutils/acidlaunch/pkg-plist4
7 files changed, 75 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9862aa233d88..04426e027b70 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -6,6 +6,7 @@
SUBDIR += LPRngTool
SUBDIR += Tee
SUBDIR += abck
+ SUBDIR += acidlaunch
SUBDIR += afio
SUBDIR += ah-tty
SUBDIR += and
diff --git a/sysutils/acidlaunch/Makefile b/sysutils/acidlaunch/Makefile
new file mode 100644
index 000000000000..74f6fb2c3eb1
--- /dev/null
+++ b/sysutils/acidlaunch/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: acidlaunch
+# Date created: 11 Apr 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= acidlaunch
+PORTVERSION= 0.5
+CATEGORIES= sysutils windowmaker
+MASTER_SITES= http://linuxgamers.net/download/
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= An application launcher with simple XML-based configuration syntax
+
+HAS_CONFIGURE= yes
+USE_GNOME= gtk12 gdkpixbuf libxml2
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+MAN1= ${PORTNAME}.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+.for file in config.xml default.png
+ ${INSTALL_DATA} ${WRKSRC}/prefs/${file} ${PREFIX}/share/${PORTNAME}
+.endfor
+ @${INSTALL_MAN} ${WRKSRC}/docs/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/acidlaunch/distinfo b/sysutils/acidlaunch/distinfo
new file mode 100644
index 000000000000..716efbed2fb2
--- /dev/null
+++ b/sysutils/acidlaunch/distinfo
@@ -0,0 +1 @@
+MD5 (acidlaunch-0.5.tar.gz) = 7c90e429d5883b9f109a52e024597fab
diff --git a/sysutils/acidlaunch/files/patch-configure b/sysutils/acidlaunch/files/patch-configure
new file mode 100644
index 000000000000..813be33d5e1e
--- /dev/null
+++ b/sysutils/acidlaunch/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Fri Feb 22 04:45:04 2002
++++ configure Fri Apr 11 20:25:11 2003
+@@ -1044,7 +1044,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+-#include <xmlversion.h>
++#include <libxml/xmlversion.h>
+
+ int
+ main()
+@@ -1155,7 +1155,7 @@
+ #line 1156 "configure"
+ #include "confdefs.h"
+
+-#include <xmlversion.h>
++#include <libxml/xmlversion.h>
+ #include <stdio.h>
+
+ int main() {
diff --git a/sysutils/acidlaunch/files/patch-src::Makefile.in b/sysutils/acidlaunch/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..1da0db8ffbd9
--- /dev/null
+++ b/sysutils/acidlaunch/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Fri Apr 11 20:41:42 2003
++++ src/Makefile.in Fri Apr 11 20:42:11 2003
+@@ -72,7 +72,7 @@
+ XML_CONFIG = @XML_CONFIG@
+ XML_LIBS = @XML_LIBS@
+
+-CPPFLAGS = -DPREFIX=\"@prefix@\"
++CPPFLAGS = -DPREFIX=\"${X11BASE}\"
+
+ bin_PROGRAMS = acidlaunch
+
diff --git a/sysutils/acidlaunch/pkg-descr b/sysutils/acidlaunch/pkg-descr
new file mode 100644
index 000000000000..b7870243d313
--- /dev/null
+++ b/sysutils/acidlaunch/pkg-descr
@@ -0,0 +1,7 @@
+Acidlaunch is a small, light-weight dockable app launcher with a simple
+XML-based configuration syntax. It's written in C++ using gtk,
+gdk-pixbuf and libxml2. It's great as a small, simple app launcher, and
+it can optionally run in a withdrawn mode for embedding in the BlackBox
+slit.
+
+WWW: http://linuxgamers.net/infoPage.php?page=acidlaunch
diff --git a/sysutils/acidlaunch/pkg-plist b/sysutils/acidlaunch/pkg-plist
new file mode 100644
index 000000000000..8f810de30ce7
--- /dev/null
+++ b/sysutils/acidlaunch/pkg-plist
@@ -0,0 +1,4 @@
+bin/acidlaunch
+share/acidlaunch/config.xml
+share/acidlaunch/default.png
+@dirrm share/acidlaunch