aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-02 13:41:50 +0800
committerbsam <bsam@FreeBSD.org>2013-09-02 13:41:50 +0800
commit76068bedb30bd66dfe3e9cc6d7d202042d4f871c (patch)
tree329b9860cec2b8bc443912ad4a52d7732ffc9db3 /sysutils
parentc2ec996ddec2412e5140b829f58ba8dd3bb0a038 (diff)
downloadfreebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.tar.gz
freebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.tar.zst
freebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.zip
1. Introduce using iconv with arguments:
. lib (default, implicit); . build, . patch. The default is the same, all existing ports stay valid. 2. Introduce variable ICONV_CMD with default to ${LOCALBASE}/bin/iconv. It is intended to get the value of /usr/bin/iconv at recent 10.x. 3. Adopt all ports to using USES+= icomv:build and iconv:patch and change iconv (executable) at Makefile commands to ${ICONV_CMD} at those ports. Submitted by: bsam (me, via e-mail) Approved by: portmgr (bapt)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/djmount/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/sysutils/djmount/Makefile b/sysutils/djmount/Makefile
index ef863863aaaa..65089d7763ce 100644
--- a/sysutils/djmount/Makefile
+++ b/sysutils/djmount/Makefile
@@ -11,11 +11,10 @@ MAINTAINER= eric@camachat.org
COMMENT= Mount UPnP A/V Media
LIB_DEPENDS= upnp.9:${PORTSDIR}/devel/upnp
-BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
PLIST_FILES= bin/${PORTNAME}
GNU_CONFIGURE= yes
-USES= fuse pkgconfig
+USES= fuse iconv:build pkgconfig
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
--with-fuse-prefix=${LOCALBASE} \
--with-external-libupnp --with-libupnp-prefix=${LOCALBASE}