aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2021-03-13 19:23:02 +0800
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2021-03-13 19:23:02 +0800
commit79ccf74870712a420d1ba856fa11a612f7e88236 (patch)
tree5c8e38d89684f13aff00e463fcd0873e11458c9a /sysutils
parent42f6839045fd74317e9e843ef5f6587953821082 (diff)
downloadfreebsd-ports-gnome-79ccf74870712a420d1ba856fa11a612f7e88236.tar.gz
freebsd-ports-gnome-79ccf74870712a420d1ba856fa11a612f7e88236.tar.zst
freebsd-ports-gnome-79ccf74870712a420d1ba856fa11a612f7e88236.zip
sysutils/debootstrap: make it work without --no-check-gpg
Reviewed by: emaste Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D29231
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/debootstrap/Makefile14
-rw-r--r--sysutils/debootstrap/pkg-message4
2 files changed, 13 insertions, 5 deletions
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index ae3a6fa1963d..d46e3e5d18ef 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -3,9 +3,9 @@
PORTNAME= debootstrap
PORTVERSION= 1.0.123
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
-MASTER_SITES= DEBIAN/pool/main/d/${PORTNAME}
+MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= trasz@FreeBSD.org
@@ -15,7 +15,9 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/debian/copyright
RUN_DEPENDS= wget:ftp/wget \
- bash:shells/bash
+ bash:shells/bash \
+ gpgv2:security/gnupg \
+ ${LOCALBASE}/share/keyrings/ubuntu-archive-keyring.gpg:security/ubuntu-keyring
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
@@ -33,6 +35,12 @@ post-patch:
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
${WRKSRC}/Makefile \
${WRKSRC}/debootstrap
+ @${REINPLACE_CMD} -e 's,gpgv,gpgv2,g' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/debootstrap \
+ ${WRKSRC}/functions
+ @${FIND} ${WRKSRC}/scripts -type f | \
+ ${XARGS} ${REINPLACE_CMD} -e 's,/usr/share/keyrings,${LOCALBASE}/share/keyrings,g'
post-install:
${INSTALL_MAN} ${WRKSRC}/debootstrap.8 \
diff --git a/sysutils/debootstrap/pkg-message b/sysutils/debootstrap/pkg-message
index 0c39abe95a8c..451331f7d2fe 100644
--- a/sysutils/debootstrap/pkg-message
+++ b/sysutils/debootstrap/pkg-message
@@ -6,9 +6,9 @@ debootstrap requires the following kernel modules to be loaded:
linux64 fdescfs linprocfs linsysfs tmpfs
-To install Ubuntu Bionic into /compat/ubuntu, use:
+To install Ubuntu 18.04 LTS (Bionic Beaver) into /compat/ubuntu, run as root:
-debootstrap --no-check-gpg bionic /compat/ubuntu
+debootstrap bionic /compat/ubuntu
EOM
}
]