aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-22 04:47:34 +0800
committerpav <pav@FreeBSD.org>2004-08-22 04:47:34 +0800
commit7ac6cd0e7beee608efa2ac37828b931e964eb752 (patch)
treee1b5e1d88dce6abfec30fd50cd342e47c1e67d54 /sysutils
parent64941bd141b0027979aa93050e928c1d9acfa600 (diff)
downloadfreebsd-ports-gnome-7ac6cd0e7beee608efa2ac37828b931e964eb752.tar.gz
freebsd-ports-gnome-7ac6cd0e7beee608efa2ac37828b931e964eb752.tar.zst
freebsd-ports-gnome-7ac6cd0e7beee608efa2ac37828b931e964eb752.zip
- Fix case while /usr/ports is symlink to somewhere else.
PR: ports/70800 Reported by: Alex Varju <alex@varju.ca> Submitted by: Radim Kolar <hsn@netmag.cz> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/portindex/Makefile1
-rw-r--r--sysutils/portindex/files/patch-varju14
2 files changed, 15 insertions, 0 deletions
diff --git a/sysutils/portindex/Makefile b/sysutils/portindex/Makefile
index 8198f3718e55..6af862d68f1d 100644
--- a/sysutils/portindex/Makefile
+++ b/sysutils/portindex/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portindex
PORTVERSION= 18
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://people.tecnik93.com/~radim/distfiles/
DISTNAME= bsdportsutils-${PORTVERSION}
diff --git a/sysutils/portindex/files/patch-varju b/sysutils/portindex/files/patch-varju
new file mode 100644
index 000000000000..242dd74426f5
--- /dev/null
+++ b/sysutils/portindex/files/patch-varju
@@ -0,0 +1,14 @@
+--- freebsdports.py.orig Wed Jul 28 14:03:59 2004
++++ freebsdports.py Sat Aug 21 22:45:41 2004
+@@ -117,9 +117,9 @@
+ print 'Output of make describe has',len(spl),'fields.'
+ return False
+ if this.path!=spl[1]:
+- print "Port path is",this.path,"but Makefile reports",spl[1]
++ print "Warning: port path is",this.path,"but Makefile reports",spl[1]
+ this.name=spl[0]
+- this.path=spl[1]
++ #this.path=spl[1]
+ this.prefix=spl[2]
+ this.comment=sre.sub(r'\s{2,}',' ',spl[3].strip())
+ this.dfile=spl[4]