aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-18 02:07:12 +0800
committerbapt <bapt@FreeBSD.org>2014-01-18 02:07:12 +0800
commit7c0f05129da6806a7a795fc94d7d6d2fafcde757 (patch)
treefb1a1ba174bc1e15031a68d09afaf87ef7338b43 /sysutils
parenta143fbdaa516817128b0b1ea033b8e6c40c5c0f4 (diff)
downloadfreebsd-ports-gnome-7c0f05129da6806a7a795fc94d7d6d2fafcde757.tar.gz
freebsd-ports-gnome-7c0f05129da6806a7a795fc94d7d6d2fafcde757.tar.zst
freebsd-ports-gnome-7c0f05129da6806a7a795fc94d7d6d2fafcde757.zip
Support stage
Use options helpers drop support for NOPORTDATA
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/loganalyzer/Makefile63
-rw-r--r--sysutils/loganalyzer/pkg-plist6
2 files changed, 19 insertions, 50 deletions
diff --git a/sysutils/loganalyzer/Makefile b/sysutils/loganalyzer/Makefile
index 1f7fe6ee5f17..93126a921fcc 100644
--- a/sysutils/loganalyzer/Makefile
+++ b/sysutils/loganalyzer/Makefile
@@ -27,56 +27,25 @@ USE_PHP= session pdo gd xml zlib
WANT_PHP_WEB= YES
DEFAULT_PHP_VER=5
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPHP_MYSQL}
-USE_PHP+= mysql
-.endif
-
-.if ${PORT_OPTIONS:MPDO_DBLIB}
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php5-pdo_dblib
-.endif
-
-.if ${PORT_OPTIONS:MPDO_FIREBIRD}
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_firebird.so:${PORTSDIR}/databases/php5-pdo_firebird
-.endif
-
-.if ${PORT_OPTIONS:MPDO_MYSQL}
-USE_PHP+= pdo_mysql
-.endif
-
-.if ${PORT_OPTIONS:MPDO_ODBC}
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php5-pdo_odbc
-.endif
-
-.if ${PORT_OPTIONS:MPDO_PGSQL}
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
-.endif
-
-.if ${PORT_OPTIONS:MPDO_SQLITE}
-USE_PHP+= pdo_sqlite
-.endif
-
-.include <bsd.port.pre.mk>
+PHP_MYSQL_USE= php=mysql
+PDO_DBLIB_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php5-pdo_dblib
+PDO_FIREBIRD_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_firebird.so:${PORTSDIR}/databases/php5-pdo_firebird
+PDO_MYSQL_USE= php=pgo_mysql
+PDO_ODBC_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php5-pdo_odbc
+PDO_PGSQL_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
+PDO_SQLITE_USE= php=pdo_sqlite
pre-everything::
@${ECHO_CMD} "# you can customize the installation directory"
@${ECHO_CMD} "# by setting ANALYZERDIR in /etc/make.conf"
do-install:
- ${MKDIR} ${PREFIX}/${ANALYZERDIR}
- cd ${WRKSRC}/src/ && ${COPYTREE_SHARE} \* ${PREFIX}/${ANALYZERDIR}/
- ${INSTALL_DATA} ${WRKSRC}/src/.htaccess ${PREFIX}/${ANALYZERDIR}/
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/* ${DOCSDIR}
-.endif
-.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/* ${DATADIR}
-.endif
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${ANALYZERDIR}
+ cd ${WRKSRC}/src/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/${ANALYZERDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/src/.htaccess ${STAGEDIR}${PREFIX}/${ANALYZERDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/* ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/loganalyzer/pkg-plist b/sysutils/loganalyzer/pkg-plist
index 83dcd196bf5c..cd70672aef9c 100644
--- a/sysutils/loganalyzer/pkg-plist
+++ b/sysutils/loganalyzer/pkg-plist
@@ -8,8 +8,8 @@
%%PORTDOCS%%%%DOCSDIR%%/textfiles.html
%%PORTDOCS%%%%DOCSDIR%%/troubleshoot.html
%%PORTDOCS%%%%DOCSDIR%%/windowsevent.html
-%%PORTDATA%%%%DATADIR%%/configure.sh
-%%PORTDATA%%%%DATADIR%%/secure.sh
+%%DATADIR%%/configure.sh
+%%DATADIR%%/secure.sh
%%ANALYZERDIR%%/.htaccess
%%ANALYZERDIR%%/BitstreamVeraFonts/COPYRIGHT.TXT
%%ANALYZERDIR%%/BitstreamVeraFonts/README.TXT
@@ -413,5 +413,5 @@
@dirrm %%ANALYZERDIR%%/admin
@dirrm %%ANALYZERDIR%%/BitstreamVeraFonts
@dirrmtry %%ANALYZERDIR%%
-%%PORTDATA%%@dirrm %%DATADIR%%
+@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%