aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-06-26 06:51:23 +0800
committerlinimon <linimon@FreeBSD.org>2017-06-26 06:51:23 +0800
commit85ce88778129fb36eada990b6106cb058f25cf10 (patch)
treeb73954776b07d97f920b8c523766dde32200caed /sysutils
parent721112cfb22cc9a3bd3fce92ee4f3f4f5200f606 (diff)
downloadfreebsd-ports-gnome-85ce88778129fb36eada990b6106cb058f25cf10.tar.gz
freebsd-ports-gnome-85ce88778129fb36eada990b6106cb058f25cf10.tar.zst
freebsd-ports-gnome-85ce88778129fb36eada990b6106cb058f25cf10.zip
Add u-boot-chip, uboot port customized for the CHIP $9 computer.
PR: 213251 Submitted by: manu
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/u-boot-chip/Makefile14
-rw-r--r--sysutils/u-boot-chip/pkg-descr19
3 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ab56d5d32363..2202189adb00 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1169,6 +1169,7 @@
SUBDIR += u-boot-bananapi
SUBDIR += u-boot-bananapim2
SUBDIR += u-boot-beaglebone
+ SUBDIR += u-boot-chip
SUBDIR += u-boot-cubieboard
SUBDIR += u-boot-cubieboard2
SUBDIR += u-boot-cubox-hummingboard
diff --git a/sysutils/u-boot-chip/Makefile b/sysutils/u-boot-chip/Makefile
new file mode 100644
index 000000000000..f8439d8d881d
--- /dev/null
+++ b/sysutils/u-boot-chip/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -chip
+
+COMMENT= Cross-build U-Boot loader for NextThingCo CHIP
+
+LICENSE= GPLv2
+
+MASTERDIR= ${.CURDIR}/../u-boot-olimex-a20-som-evb
+DESCR= ${.CURDIR}/pkg-descr
+MODEL= sun5i-r8-chip
+BOARD_CONFIG= CHIP_defconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-chip/pkg-descr b/sysutils/u-boot-chip/pkg-descr
new file mode 100644
index 000000000000..f2436e976395
--- /dev/null
+++ b/sysutils/u-boot-chip/pkg-descr
@@ -0,0 +1,19 @@
+U-Boot loader for NextThingCo CHIP.
+
+To install this bootloader on an sdcard just do :
+dd if=/usr/local/share/u-boot/u-boot-chip/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=notrunc,sync
+
+This version is patched so that:
+ * ELF and API features are enabled.
+ * The default environment is trimmed to just what's needed to boot.
+ * The saveenv command writes to the file u-boot.env on the FAT partition.
+ * The DTB file name is chosen based on the board model and passed to ubldr.bin
+ using the fdtfile env variable. ubldr.bin loads the DTB from /boot/dtb/ on
+ the FreeBSD partition.
+ * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition
+ to address 0x42000000, and launches it.
+
+For information about running FreeBSD on Allwinner boards, see
+ https://wiki.freebsd.org/FreeBSD/arm/Allwinner
+
+For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot