aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-09-05 22:37:06 +0800
committergarga <garga@FreeBSD.org>2005-09-05 22:37:06 +0800
commit869782a422d5ab81db62afce5175fd1dfee665bc (patch)
tree25725112fa3942b6e358b7bdadb8903ffefbd545 /sysutils
parentafca95f2a675a77e11ddb110448e8916f2945fc8 (diff)
downloadfreebsd-ports-gnome-869782a422d5ab81db62afce5175fd1dfee665bc.tar.gz
freebsd-ports-gnome-869782a422d5ab81db62afce5175fd1dfee665bc.tar.zst
freebsd-ports-gnome-869782a422d5ab81db62afce5175fd1dfee665bc.zip
Add managepkg 1.1, script for maintining ports.
PR: ports/85732 Submitted by: Andreas Fehlner <fehlner@gmx.de>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/managepkg/Makefile28
-rw-r--r--sysutils/managepkg/distinfo2
-rw-r--r--sysutils/managepkg/pkg-descr17
4 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 2932c63f2be9..d759255c5701 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -284,6 +284,7 @@
SUBDIR += magicrescue
SUBDIR += maint
SUBDIR += makefs
+ SUBDIR += managepkg
SUBDIR += manck
SUBDIR += mapchan
SUBDIR += mcron
diff --git a/sysutils/managepkg/Makefile b/sysutils/managepkg/Makefile
new file mode 100644
index 000000000000..19618a51cd5f
--- /dev/null
+++ b/sysutils/managepkg/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: managepkg
+# Date created: 2005-09-04
+# Whom: Andreas Fehlner <fehlner@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= managepkg
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.cul.de/data/\
+ http://home.arcor.de/fehlner/download/\
+ http://home.arcor.de/teambushido/download/
+EXTRACT_SUFX= .gz
+
+MAINTAINER= fehlner@gmx.de
+COMMENT= Script for maintining ports
+# Any ideas for a better comment?
+
+EXTRACT_AFTER_ARGS= ${DISTDIR}/${DISTFILES} > ${WRKSRC}/${PORTNAME}
+WRKSRC= ${WRKDIR}
+NO_BUILD= yes
+PLIST_FILES= sbin/managepkg
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin/
+
+.include <bsd.port.mk>
diff --git a/sysutils/managepkg/distinfo b/sysutils/managepkg/distinfo
new file mode 100644
index 000000000000..1a86f87e5ad8
--- /dev/null
+++ b/sysutils/managepkg/distinfo
@@ -0,0 +1,2 @@
+MD5 (managepkg-1.1.gz) = 7e698db45723cb0a933363cc5a6cb718
+SIZE (managepkg-1.1.gz) = 2497
diff --git a/sysutils/managepkg/pkg-descr b/sysutils/managepkg/pkg-descr
new file mode 100644
index 000000000000..568903156d13
--- /dev/null
+++ b/sysutils/managepkg/pkg-descr
@@ -0,0 +1,17 @@
+This script runs though the complete ports tree without stopping after a make
+error occured.
+If you call make with any parameter in one of the directories of the ports tree
+in FreeBSD the run will stop if make returns with a code bigger than zero. That
+means, that it is (in opposite to NetBSD or OpenBSD impossible to run a echo
+complete build with \"make\" in FreeBSD.
+
+Warning: The run of the script may last days (but you may stop it any time).
+
+Call the script with the parameter you want to give to make, for instance fetch,
+build, install, or package.
+
+
+WWW: http://www.cul.de/data/
+
+-Andreas Fehlner
+fehlner@gmx.de