aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-11-07 06:54:52 +0800
committersergei <sergei@FreeBSD.org>2004-11-07 06:54:52 +0800
commit880b7cbf423f1f450db3f2cb5ff5d57f603b6ab2 (patch)
treec9e97f48cf9c19baa48f85f23dab48c93b2a6f53 /sysutils
parent4d4b6ce5cf32207993f0b41755096c5b082ec8df (diff)
downloadfreebsd-ports-gnome-880b7cbf423f1f450db3f2cb5ff5d57f603b6ab2.tar.gz
freebsd-ports-gnome-880b7cbf423f1f450db3f2cb5ff5d57f603b6ab2.tar.zst
freebsd-ports-gnome-880b7cbf423f1f450db3f2cb5ff5d57f603b6ab2.zip
Add sysutils/graft:
Symlink manager for installing multiple versions of software packages under a common hierarchy. Simplifies installation/deinstallation and PATH management. WWW: http://www.gormand.com.au/peters/tools/graft/graft.html PR: ports/70516 Submitted by: Michael Handler <handler@grendel.net>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/graft/Makefile61
-rw-r--r--sysutils/graft/distinfo2
-rw-r--r--sysutils/graft/files/patch-Makefile.dist53
-rw-r--r--sysutils/graft/pkg-descr5
5 files changed, 122 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 938af8355859..118262016898 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -174,6 +174,7 @@
SUBDIR += gnomesystemtools
SUBDIR += gpart
SUBDIR += gpkgdep
+ SUBDIR += graft
SUBDIR += growspd
SUBDIR += grub
SUBDIR += gstopd
diff --git a/sysutils/graft/Makefile b/sysutils/graft/Makefile
new file mode 100644
index 000000000000..1b20ccbbab50
--- /dev/null
+++ b/sysutils/graft/Makefile
@@ -0,0 +1,61 @@
+# Ports collection makefile for: graft
+# Date created: 2004-08-15
+# Whom: Michael Handler <handler@grendel.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graft
+PORTVERSION= 2.4
+CATEGORIES= sysutils
+MASTER_SITES= http://www.gormand.com.au/peters/tools/graft/
+
+MAINTAINER= handler@grendel.net
+COMMENT= Manage symlinks to multiple software packages under a single hierarchy
+
+USE_PERL5_RUN= true
+
+PLIST_FILES= bin/graft
+
+INSTALL_TARGET= bin manuals
+MAN1= graft.1
+
+.if !defined(NOPORTDOCS)
+EXTRAPORTDOCS= CHANGES README THOUGHTS
+PORTDOCS= graft.html graft.pdf graft.ps graft.txt ${EXTRAPORTDOCS}
+INSTALL_TARGET+= docs
+.endif
+
+GRAFT_PACKAGEDIR?= /local/pkg
+GRAFT_TARGETDIR?= /local
+GRAFT_LOGFILE?= /var/log/graft
+
+MAKEFILE_SUB= PREFIX=${PREFIX} MANPREFIX=${MANPREFIX} \
+ DOCSDIR=${DOCSDIR} PERL=${PERL} \
+ GRAFT_PACKAGEDIR=${GRAFT_PACKAGEDIR} \
+ GRAFT_TARGETDIR=${GRAFT_TARGETDIR} \
+ GRAFT_LOGFILE=${GRAFT_LOGFILE}
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ @${ECHO_CMD}
+ @${ECHO_CMD} "You may use the following build options:"
+ @${ECHO_CMD}
+ @${ECHO_CMD} "GRAFT_PACKAGEDIR=/directory (default: ${GRAFT_PACKAGEDIR})"
+ @${ECHO_CMD} "GRAFT_TARGETDIR=/directory (default: ${GRAFT_TARGETDIR})"
+ @${ECHO_CMD} "GRAFT_LOGFILE=/directory/file (default: ${GRAFT_LOGFILE})"
+ @${ECHO_CMD}
+
+post-patch:
+ @${SED} ${MAKEFILE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${WRKSRC}/Makefile.dist > ${WRKSRC}/Makefile
+
+.if !defined(NOPORTDOCS)
+post-install:
+.for i in ${EXTRAPORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/graft/distinfo b/sysutils/graft/distinfo
new file mode 100644
index 000000000000..0f5a58eefbb0
--- /dev/null
+++ b/sysutils/graft/distinfo
@@ -0,0 +1,2 @@
+MD5 (graft-2.4.tar.gz) = d91677b273ab812aeaac1a79037e097b
+SIZE (graft-2.4.tar.gz) = 148709
diff --git a/sysutils/graft/files/patch-Makefile.dist b/sysutils/graft/files/patch-Makefile.dist
new file mode 100644
index 000000000000..b8e65a1d2726
--- /dev/null
+++ b/sysutils/graft/files/patch-Makefile.dist
@@ -0,0 +1,53 @@
+--- Makefile.dist.orig Sun Aug 15 15:54:30 2004
++++ Makefile.dist Sun Aug 15 16:09:04 2004
+@@ -30,8 +30,8 @@
+ # number of ways. See the man page and the documentation in
+ # doc/graft.{html,pdf,ps,txt}.
+
+-PACKAGEDIR = /pkgs
+-TARGETDIR = /pkgs
++PACKAGEDIR = %%GRAFT_PACKAGEDIR%%
++TARGETDIR = %%GRAFT_TARGETDIR%%
+
+ # You should only need to change the value of TOP to reflect the
+ # installation directory for graft if it is different from your default
+@@ -40,10 +40,10 @@
+ # these values, you may be confused about what graft is for. Please
+ # re-read the documentation in doc/graft.{html,pdf,ps,txt}.
+
+-TOP = $(PACKAGEDIR)/graft-$(VERSION)
++TOP = %%PREFIX%%
+ BIN = $(TOP)/bin
+-MAN = $(TOP)/man
+-DOC = $(TOP)/doc
++MAN = %%MANPREFIX%%/man
++DOC = %%DOCSDIR%%
+
+ # The final grafted location of perl. See the bootstrap section in
+ # the documentation in doc/graft.{html,pdf,ps,txt}. This value will be
+@@ -55,7 +55,7 @@
+ #
+ # #!/usr/bin/perl -w
+
+-PERL = /pkgs/bin/perl
++PERL = %%PERL%%
+
+ # The location of the perl executable used to build the graft
+ # executable. You'll need to change this only if you do not have a fixed
+@@ -68,7 +68,7 @@
+ # The graft log file. All of graft's actions will be logged in this file.
+ # If you don't want any logging, set this to /dev/null.
+
+-LOGFILE = /var/log/graft
++LOGFILE = %%GRAFT_LOGFILE%%
+
+ # The names of the special graft control files. GRAFT-IGNORE controls
+ # the exclusion of subdirectories, GRAFT-EXCLUDE controls the exclusion
+@@ -206,7 +206,6 @@
+ mkdir -p $(DOC); \
+ cp doc/$$i $(DOC); \
+ chmod 644 $(DOC)/$$i; \
+- touch $(DOC)/$(GRAFT-IGNORE); \
+ done
+
+ bin: all
diff --git a/sysutils/graft/pkg-descr b/sysutils/graft/pkg-descr
new file mode 100644
index 000000000000..c9b97ea02197
--- /dev/null
+++ b/sysutils/graft/pkg-descr
@@ -0,0 +1,5 @@
+Symlink manager for installing multiple versions of software packages
+under a common hierarchy. Simplifies installation/deinstallation and
+PATH management.
+
+WWW: http://www.gormand.com.au/peters/tools/graft/graft.html