aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-03-31 03:35:57 +0800
committergarga <garga@FreeBSD.org>2006-03-31 03:35:57 +0800
commit8af756787dc8c483eb8e04792c99bb3399aec576 (patch)
tree1f643489836f0154b4a135033b7ef2892f65ef69 /sysutils
parentc2e41cf56fcf812c917252096d010b1a7a97cffc (diff)
downloadfreebsd-ports-gnome-8af756787dc8c483eb8e04792c99bb3399aec576.tar.gz
freebsd-ports-gnome-8af756787dc8c483eb8e04792c99bb3399aec576.tar.zst
freebsd-ports-gnome-8af756787dc8c483eb8e04792c99bb3399aec576.zip
- Update to 1.38.6
PR: ports/94832 Submitted by: maintainer
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bacula-client-devel/Makefile1
-rw-r--r--sysutils/bacula-server-devel/Makefile79
-rw-r--r--sysutils/bacula-server-devel/distinfo5
-rw-r--r--sysutils/bacula-server-devel/files/chio-bacula4
-rw-r--r--sysutils/bacula-server-devel/files/patch-scripts-Makefile.in38
-rw-r--r--sysutils/bacula-server-devel/files/z-bacula-dir.sh.in30
-rw-r--r--sysutils/bacula-server-devel/files/z-bacula-fd.sh.in30
-rw-r--r--sysutils/bacula-server-devel/files/z-bacula-sd.sh.in30
-rw-r--r--sysutils/bacula-server-devel/pkg-install6
-rw-r--r--sysutils/bacula-server-devel/pkg-message6
-rw-r--r--sysutils/bacula-server-devel/pkg-plist4
-rw-r--r--sysutils/bacula-server-devel/pkg-plist.client2
12 files changed, 176 insertions, 59 deletions
diff --git a/sysutils/bacula-client-devel/Makefile b/sysutils/bacula-client-devel/Makefile
index 0189cc3bf6dd..48039fae7548 100644
--- a/sysutils/bacula-client-devel/Makefile
+++ b/sysutils/bacula-client-devel/Makefile
@@ -15,5 +15,6 @@ COMMENT= The network backup solution (client) - DEVELOPMENT Version
PLIST= ${PKGDIR}/pkg-plist.client
WITH_CLIENT_ONLY= yes
+USE_RC_SUBR= z-bacula-fd.sh
.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/bacula-server-devel/Makefile b/sysutils/bacula-server-devel/Makefile
index f2400f26b3c3..36459ffa7dea 100644
--- a/sysutils/bacula-server-devel/Makefile
+++ b/sysutils/bacula-server-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bacula
-DISTVERSION= 1.38.6-beta3-20060304
+DISTVERSION= 1.38.6
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
@@ -17,6 +17,10 @@ COMMENT?= The network backup solution (server) - DEVELOPMENT Version
CONFLICTS= bacula-server-[0-9]* bacula-client-[0-9]*
+UNIQUENAME?=${PORTNAME}${PKGNAMESUFFIX}
+
+USE_RC_SUBR?= z-bacula-dir.sh z-bacula-sd.sh
+
# The user/group IDs below are registered, see
# http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/book.html#DADS-UID
#
@@ -28,21 +32,25 @@ CONFIGURE_ARGS= --with-tcp-wrappers=/usr/lib \
--with-working-dir=${BACULA_DIR} \
--with-scriptdir=${PREFIX}/share/${PORTNAME} \
--mandir=${PREFIX}/man \
- --with-fd-user=root \
- --with-fd-group=wheel \
- --with-dir-user=bacula \
- --with-dir-group=bacula \
- --with-sd-user=bacula \
- --with-sd-group=operator \
--with-readline=yes \
--disable-conio
+.if defined(WITH_CLIENT_ONLY)
+CONFIGURE_ARGS+= --with-fd-user=root \
+ --with-fd-group=wheel
+.else
+CONFIGURE_ARGS+=--with-dir-user=bacula \
+ --with-dir-group=bacula \
+ --with-sd-user=bacula \
+ --with-sd-group=operator
+.endif
+
CONFIGURE_ENV+= CPPFLAGS="-I/usr/include/readline -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-ALL_OPTIONS= CLIENT_ONLY WXCONSOLE GNOMECONSOLE SQLITE3 MYSQL POSTGRESQL MTX OPENSSL
+ALL_OPTIONS= CLIENT_ONLY WXCONSOLE GNOMECONSOLE SQLITE3 MYSQL POSTGRESQL MTX OPENSSL DOCS
.for opt in ${ALL_OPTIONS}
.if defined(WITH_${opt})
@@ -57,6 +65,7 @@ IS_INTERACTIVE= yes
.if defined(WITH_CLIENT_ONLY)
OPTIONS+= WXCONSOLE "Build with wxGTK based GUI console" off
OPTIONS+= GNOMECONSOLE "Build with GNOME based GUI console" off
+OPTIONS+= DOCS "Install documention" off
.else
OPTIONS= SQLITE3 "Use SqLite-3 database instead of SqLite-2" off
OPTIONS+= MYSQL "Use MySQL database instead of SqLite" off
@@ -79,6 +88,15 @@ MAN8= bacula.8
.include <bsd.port.pre.mk>
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz
+.if defined(WITH_DOCS)
+DISTFILES+= ${PORTNAME}-docs-${PORTVERSION}.tar.gz
+.endif
+
+.if defined(WITH_DOCS)
+PORTDOCS= ReleaseNotes bacula.pdf developers.pdf kernstodo manual bacula-web
+.endif
+
# Client only or full server version
.if defined(WITH_CLIENT_ONLY)
CONFFILES= fd
@@ -163,6 +181,8 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "The default DB is SQLite-2!"
.endif
+ @${ECHO_MSG} " WITH_DOCS=yes if you want the documentation installed."
+ @${ECHO_MSG} " WITH_OPENSSL=yes Enable OpenSSL for encrypted communication."
@${ECHO_MSG} ""
@${ECHO_MSG} "===> Using ${DBTYPE} as the bacula database."
@${ECHO_MSG} ""
@@ -175,7 +195,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|./bconsole.conf|${PREFIX}/etc/bconsole.conf|g' ${WRKSRC}/src/console/console.c
.if defined(WITH_CLIENT_ONLY)
# In client port only install startup script out of script dir (see below post-install)
-# Dont mkdir ${PREFIX}/share/bacule cause it's empty
+# Dont mkdir ${PREFIX}/share/bacula cause it's empty
@${REINPLACE_CMD} -e 's|^\(fd_subdirs = .*\)scripts\(.*\)|\1\2|g' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's|\(.*$$(MKDIR) $$(DESTDIR)$$(scriptdir)\)|#\1|g' ${WRKSRC}/Makefile.in
.else
@@ -183,17 +203,22 @@ post-patch:
@${REINPLACE_CMD} -e 's|^all_subdirs = .*|all_subdirs = scripts src\/lib src\/findlib $${subdirs}|g' ${WRKSRC}/Makefile.in
.endif
-post-install:
-# Migration: move existing bacula.sh to z-bacula.sh to start bacula AFTER DB start
- if [ -f ${PREFIX}/etc/rc.d/bacula.sh ]; then \
- ${MV} ${PREFIX}/etc/rc.d/bacula.sh ${PREFIX}/etc/rc.d/z-bacula.sh; \
- fi
- if [ -f ${PREFIX}/etc/rc.d/bacula.sh.sample ]; then \
- ${MV} ${PREFIX}/etc/rc.d/bacula.sh.sample ${PREFIX}/etc/rc.d/z-bacula.sh.sample; \
+pre-install:
+ if [ ! -d "${BACULA_DIR}" ]; then \
+ ${ECHO_CMD} "creating ${BACULA_DIR}" ; \
+ ${MKDIR} ${BACULA_DIR}; \
+ else \
+ ${ECHO_CMD} "${BACULA_DIR} already exists"; \
fi
+
+.if !defined(WITH_CLIENT_ONLY)
+# Extend /etc/services and install UID/GID
+ @ ${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+.endif
+
+post-install:
.if defined(WITH_CLIENT_ONLY)
-# Install start script
- ${INSTALL_SCRIPT} ${WRKSRC}/scripts/bacula ${PREFIX}/etc/rc.d/z-bacula.sh.sample
# Extend only /etc/services
@ ${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PORTNAME}
@@ -221,14 +246,24 @@ post-install:
fi
.endif
-# @${CHMOD} a+x ${WRKSRC}/scripts/bacula.man
.if defined(WITH_CLIENT_ONLY)
${INSTALL_MAN} ${WRKSRC}/scripts/bacula.man ${PREFIX}/man/man8/bacula.8
.endif
+
+# Documentation is only installed in -client port
+.if defined(WITH_DOCS)
+ for na in manual bacula-web; do \
+ ${MKDIR} ${DOCSDIR}/$$na ;\
+ cd ${WRKDIR}/${PORTNAME}-docs-${PORTVERSION} && ${FIND} $$na | \
+ ${CPIO} -pdm -L -R root:wheel ${DOCSDIR}; \
+ done
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/ReleaseNotes ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-docs-${PORTVERSION}/manual/bacula.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-docs-${PORTVERSION}/developers/developers.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/kernstodo ${DOCSDIR}
+.endif
+
.else
-# Extend /etc/services and install UID/GID
- @ ${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
# Install config files and preserve existing ones
${INSTALL_SCRIPT} ${FILESDIR}/chio-bacula ${PREFIX}/sbin
if [ -f ${PREFIX}/etc/bacula-barcodes ]; then \
diff --git a/sysutils/bacula-server-devel/distinfo b/sysutils/bacula-server-devel/distinfo
index 293c267f3d6d..3cf10d72d607 100644
--- a/sysutils/bacula-server-devel/distinfo
+++ b/sysutils/bacula-server-devel/distinfo
@@ -1,2 +1,3 @@
-MD5 (bacula-1.38.6-beta3-20060304.tar.gz) = 307153832c052779dc48f31c2d057fe3
-SIZE (bacula-1.38.6-beta3-20060304.tar.gz) = 1927972
+MD5 (bacula-1.38.6.tar.gz) = 219382ae85671c8ff13f375b6d9aa079
+SHA256 (bacula-1.38.6.tar.gz) = e671f3ff20c97e8392908920ae9ca38f814359c5b85b89625d43df9ad7349ed3
+SIZE (bacula-1.38.6.tar.gz) = 1952827
diff --git a/sysutils/bacula-server-devel/files/chio-bacula b/sysutils/bacula-server-devel/files/chio-bacula
index cc5999c73e1a..ca7ec4931581 100644
--- a/sysutils/bacula-server-devel/files/chio-bacula
+++ b/sysutils/bacula-server-devel/files/chio-bacula
@@ -2,7 +2,7 @@
#
# Bacula interface to FreeBSD chio autoloader command with
# multiple drive support
-# (By Lars K.ller, lars+bacula@koellers.net, 2004)
+# (By Lars Köller, lars+bacula@koellers.net, 2004)
#
# If you set in your Device resource
#
@@ -90,7 +90,7 @@ fi
# The slot number
if [ ! -z "$3" ]; then
SLOT=$3
- # btape fill says "... slot 1 drive 0" :-(
+ # btape fill says "... slot 1 drive 0" :-(
if [ "$SLOT" = "slot" ]; then
shift
SLOT=$3
diff --git a/sysutils/bacula-server-devel/files/patch-scripts-Makefile.in b/sysutils/bacula-server-devel/files/patch-scripts-Makefile.in
index 9100d3a2c091..eeb841f253db 100644
--- a/sysutils/bacula-server-devel/files/patch-scripts-Makefile.in
+++ b/sysutils/bacula-server-devel/files/patch-scripts-Makefile.in
@@ -1,23 +1,21 @@
---- scripts/Makefile.in.org Thu Feb 23 14:56:12 2006
-+++ scripts/Makefile.in Mon Mar 6 11:20:05 2006
-@@ -33,11 +33,11 @@
+--- scripts/Makefile.in.orig Sat Mar 25 10:37:41 2006
++++ scripts/Makefile.in Thu Mar 30 13:01:21 2006
+@@ -33,14 +33,6 @@
$(MKDIR) $(DESTDIR)$(mandir)
-
+
install: installdirs
- $(INSTALL_SCRIPT) startmysql $(DESTDIR)$(scriptdir)/startmysql
- $(INSTALL_SCRIPT) stopmysql $(DESTDIR)$(scriptdir)/stopmysql
- $(INSTALL_SCRIPT) bconsole $(DESTDIR)$(scriptdir)/bconsole
- $(INSTALL_SCRIPT) gconsole $(DESTDIR)$(scriptdir)/gconsole
- $(INSTALL_SCRIPT) bacula $(DESTDIR)$(scriptdir)/bacula
-+# $(INSTALL_SCRIPT) startmysql $(DESTDIR)$(scriptdir)/startmysql
-+# $(INSTALL_SCRIPT) stopmysql $(DESTDIR)$(scriptdir)/stopmysql
-+# $(INSTALL_SCRIPT) bconsole $(DESTDIR)$(scriptdir)/bconsole
-+# $(INSTALL_SCRIPT) gconsole $(DESTDIR)$(scriptdir)/gconsole
-+ $(INSTALL_SCRIPT) bacula $(DESTDIR)$(sysconfdir)/rc.d/z-bacula.sh.sample
+- $(INSTALL_SCRIPT) bacula-ctl-dir $(DESTDIR)$(scriptdir)/bacula-ctl-dir
+- $(INSTALL_SCRIPT) bacula-ctl-fd $(DESTDIR)$(scriptdir)/bacula-ctl-fd
+- $(INSTALL_SCRIPT) bacula-ctl-sd $(DESTDIR)$(scriptdir)/bacula-ctl-sd
@if test -f ${DESTDIR}${scriptdir}/mtx-changer; then \
echo " ==> Saving existing mtx-changer to mtx-changer.old"; \
$(MV) -f ${DESTDIR}${scriptdir}/mtx-changer ${DESTDIR}${scriptdir}/mtx-changer.old; \
-@@ -53,14 +53,14 @@
+@@ -56,14 +48,7 @@
$(MV) -f ${DESTDIR}${scriptdir}/dvd-handler ${DESTDIR}${scriptdir}/dvd-handler.old; \
fi
$(INSTALL_SCRIPT) dvd-handler $(DESTDIR)$(scriptdir)/dvd-handler
@@ -29,23 +27,7 @@
- gzip <bacula.man >bacula.8.gz
- $(INSTALL_DATA) bacula.8.gz $(DESTDIR)$(mandir)/bacula.8.gz
- @rm -f bacula.8.gz
-+# $(INSTALL_DATA) btraceback.gdb $(DESTDIR)$(scriptdir)/btraceback.gdb
-+# $(INSTALL_DATA) btraceback.dbx $(DESTDIR)$(scriptdir)/btraceback.dbx
-+# chmod 0644 $(DESTDIR)$(scriptdir)/btraceback.gdb \
-+# $(DESTDIR)$(scriptdir)/btraceback.dbx
-+# $(INSTALL_SCRIPT) btraceback $(DESTDIR)$(sbindir)/btraceback
-+# gzip <bacula.man >bacula.8.gz
+ $(INSTALL_DATA) bacula.man $(DESTDIR)$(mandir)/bacula.8
-+# @rm -f bacula.8.gz
-
-
+
+
uninstall:
-@@ -68,7 +68,7 @@
- (cd $(DESTDIR)$(scriptdir); $(RMF) stopmysql)
- (cd $(DESTDIR)$(scriptdir); $(RMF) bconsole)
- (cd $(DESTDIR)$(scriptdir); $(RMF) gconsole)
-- (cd $(DESTDIR)$(scriptdir); $(RMF) bacula)
-+ (cd $(DESTDIR)$(scriptdir); $(RMF) z-bacula.sh)
- (cd $(DESTDIR)$(scriptdir); $(RMF) fd)
- (cd $(DESTDIR)$(scriptdir); $(RMF) mtx-changer)
- (cd $(DESTDIR)$(scriptdir); $(RMF) disk-changer)
diff --git a/sysutils/bacula-server-devel/files/z-bacula-dir.sh.in b/sysutils/bacula-server-devel/files/z-bacula-dir.sh.in
new file mode 100644
index 000000000000..360153ea6b70
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/z-bacula-dir.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: utility
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bacula_dir_enable (bool): Set to NO by default.
+# Set it to YES to enable bacula_dir.
+# bacula_dir_flags (params): Set params used to start bacula_dir.
+#
+
+. %%RC_SUBR%%
+
+name="bacula_dir"
+rcvar=${name}_enable
+command=%%PREFIX%%/sbin/bacula-dir
+pidfile="${bacula_dir_pidfile}"
+
+load_rc_config $name
+
+: ${bacula_dir_enable="NO"}
+: ${bacula_dir_flags=" -u bacula -g bacula -v -c %%PREFIX%%/etc/bacula-dir.conf"}
+: ${bacula_dir_pidfile="/var/run/bacula-dir.9101.pid"}
+
+run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/files/z-bacula-fd.sh.in b/sysutils/bacula-server-devel/files/z-bacula-fd.sh.in
new file mode 100644
index 000000000000..5cf5fcf38f0f
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/z-bacula-fd.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: utility
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bacula_fd_enable (bool): Set to NO by default.
+# Set it to YES to enable bacula_fd.
+# bacula_fd_flags (params): Set params used to start bacula_fd.
+#
+
+. %%RC_SUBR%%
+
+name="bacula_fd"
+rcvar=${name}_enable
+command=/usr/local/sbin/bacula-fd
+pidfile="${bacula_fd_pidfile}"
+
+load_rc_config $name
+
+: ${bacula_fd_enable="NO"}
+: ${bacula_fd_flags=" -u root -g wheel -v -c /usr/local/etc/bacula-fd.conf"}
+: ${bacula_fd_pidfile="/var/run/bacula-fd.9102.pid"}
+
+run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/files/z-bacula-sd.sh.in b/sysutils/bacula-server-devel/files/z-bacula-sd.sh.in
new file mode 100644
index 000000000000..fc98f30f4f38
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/z-bacula-sd.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: utility
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bacula_sd_enable (bool): Set to NO by default.
+# Set it to YES to enable bacula_sd.
+# bacula_sd_flags (params): Set params used to start bacula_sd.
+#
+
+. %%RC_SUBR%%
+
+name="bacula_sd"
+rcvar=`set_rcvar`
+command=/usr/local/sbin/bacula-sd
+pidfile="${bacula_sd_pidfile}"
+
+load_rc_config $name
+
+: ${bacula_sd_enable="NO"}
+: ${bacula_sd_flags=" -u bacula -g bacula -v -c /usr/local/etc/bacula-sd.conf"}
+: ${bacula_sd_pidfile="/var/run/bacula-sd.9103.pid"}
+
+run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/pkg-install b/sysutils/bacula-server-devel/pkg-install
index 460b57fbfd6a..1dc3d8613ada 100644
--- a/sysutils/bacula-server-devel/pkg-install
+++ b/sysutils/bacula-server-devel/pkg-install
@@ -16,13 +16,17 @@ bacula-sd 9103/tcp #Bacula storage daemon
fi
case $2 in
-POST-INSTALL)
+PRE-INSTALL)
# Install UID/GID
USER=bacula
GROUP=${USER}
UID=910
GID=${UID}
+ if [ ! -d ${BACULA_DIR} ]; then
+ mkdir -p ${BACULA_DIR}
+ fi
+
if pw group show "${GROUP}" 2>/dev/null; then
echo "You already have a group \"${GROUP}\", so I will use it."
else
diff --git a/sysutils/bacula-server-devel/pkg-message b/sysutils/bacula-server-devel/pkg-message
index 05bf55fb416a..f0f0db388945 100644
--- a/sysutils/bacula-server-devel/pkg-message
+++ b/sysutils/bacula-server-devel/pkg-message
@@ -7,7 +7,11 @@
IF YOU IGNORE THIS you may !! LOSE DATA !!
- For USB support read the manual. It could be necessary
+ For USB support read the manual. It could be necessary
to configure/compile a new kernel!
+ Please note that bacula-server-devel no longer installs the client
+ and that the documentation could be optional installed with the
+ client port (see port sysutils/bacula-client-devel)!
+
################################################################################
diff --git a/sysutils/bacula-server-devel/pkg-plist b/sysutils/bacula-server-devel/pkg-plist
index 1c9682153532..79fbcd5f96c8 100644
--- a/sysutils/bacula-server-devel/pkg-plist
+++ b/sysutils/bacula-server-devel/pkg-plist
@@ -1,5 +1,4 @@
%%DATADIR%%/query.sql
-etc/rc.d/z-bacula.sh.sample
sbin/chio-bacula
sbin/bacula-dir
sbin/bacula-sd
@@ -33,6 +32,7 @@ sbin/bsmtp
%%DATADIR%%/disk-changer
@dirrm %%DATADIR%%
-@unexec /usr/bin/killall badula-sd > /dev/null 2>&1 || true
+@unexec /usr/bin/killall bacula-sd > /dev/null 2>&1 || true
@unexec /usr/bin/killall bacula-dir > /dev/null 2>&1 || true
@exec mkdir -p %%BACULA_DIR%%
+@dirrmtry %%BACULA_DIR%%
diff --git a/sysutils/bacula-server-devel/pkg-plist.client b/sysutils/bacula-server-devel/pkg-plist.client
index 41c7f6cffdd5..8e0a85d7c7f3 100644
--- a/sysutils/bacula-server-devel/pkg-plist.client
+++ b/sysutils/bacula-server-devel/pkg-plist.client
@@ -1,7 +1,7 @@
-etc/rc.d/z-bacula.sh.sample
sbin/bacula-fd
sbin/bconsole
%%GNOMECONS%%sbin/gnome-console
%%WXCONS%%sbin/wx-console
@unexec /usr/bin/killall badula-fd > /dev/null 2>&1 || true
@exec mkdir -p %%BACULA_DIR%%
+@dirrmtry %%BACULA_DIR%%