aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2004-08-08 20:43:40 +0800
committerjeh <jeh@FreeBSD.org>2004-08-08 20:43:40 +0800
commit95249075011520ffa48dca1da416aac577bbbe8d (patch)
tree342d445e60624a63a9960a88b41ec8db7edc070b /sysutils
parent9b343b5d79a7ab209c6d1ee508a2f516213a003b (diff)
downloadfreebsd-ports-gnome-95249075011520ffa48dca1da416aac577bbbe8d.tar.gz
freebsd-ports-gnome-95249075011520ffa48dca1da416aac577bbbe8d.tar.zst
freebsd-ports-gnome-95249075011520ffa48dca1da416aac577bbbe8d.zip
* Fix rc.subr use so the it works properly with both 4.x and 5.x
* Fix a potential buffer overflow while reading the config file. But, since the config file is owned by root this is the least of your worries. * Enlarge the size of the _warn and _fail command strings - Overflow noticed by Pete <shipley@dis.org>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/healthd/Makefile9
-rw-r--r--sysutils/healthd/distinfo4
-rw-r--r--sysutils/healthd/files/healthd.sh-50003811
3 files changed, 5 insertions, 19 deletions
diff --git a/sysutils/healthd/Makefile b/sysutils/healthd/Makefile
index 86df6cd0510c..9d386f1dec56 100644
--- a/sysutils/healthd/Makefile
+++ b/sysutils/healthd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= healthd
-PORTVERSION= 0.7.7
+PORTVERSION= 0.7.8
CATEGORIES= sysutils ipv6
MASTER_SITES= http://healthd.thehousleys.net/ \
http://healthd1.thehousleys.net/
@@ -16,6 +16,7 @@ COMMENT= A daemon to monitor vital motherboard parameters
ONLY_FOR_ARCHS= i386
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
#
@@ -35,14 +36,10 @@ HDDOCDIR= ${PREFIX}/share/doc/healthd
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if ${OSVERSION} >= 500038
-RC_SUBR?= /etc/rc.subr
-EXTRA_PATCHES= files/healthd.sh-500038
-.else
USE_RC_SUBR= yes
-.endif
post-install:
+ @${REINPLACE_CMD} -e 's|/usr/local/etc/rc.subr|${RC_SUBR}|' ${WRKSRC}/healthd.sh
${INSTALL_SCRIPT} -m 751 ${WRKSRC}/healthd.sh ${PREFIX}/etc/rc.d/healthd.sh
@if [ ! -f ${PREFIX}/etc/healthd.conf ]; then \
${ECHO} "Installing ${PREFIX}/etc/healthd.conf configuration file."; \
diff --git a/sysutils/healthd/distinfo b/sysutils/healthd/distinfo
index 4b84e60f82ab..0bfb2b9f7642 100644
--- a/sysutils/healthd/distinfo
+++ b/sysutils/healthd/distinfo
@@ -1,2 +1,2 @@
-MD5 (healthd-0.7.7.tar.gz) = e7d4bbc4ee4f2df70f28ff0b539aae73
-SIZE (healthd-0.7.7.tar.gz) = 67263
+MD5 (healthd-0.7.8.tar.gz) = 79f152000731b480a02265e9d8f08e1c
+SIZE (healthd-0.7.8.tar.gz) = 67452
diff --git a/sysutils/healthd/files/healthd.sh-500038 b/sysutils/healthd/files/healthd.sh-500038
deleted file mode 100644
index a5178f15e18f..000000000000
--- a/sysutils/healthd/files/healthd.sh-500038
+++ /dev/null
@@ -1,11 +0,0 @@
---- healthd.sh.orig Fri Apr 16 10:03:37 2004
-+++ healthd.sh Fri Apr 16 10:04:17 2004
-@@ -13,7 +13,7 @@
- #healthd_enable="YES"
- #
-
--. /usr/local/etc/rc.subr
-+. /etc/rc.subr
-
- name=healthd
- rcvar=`set_rcvar`