aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-03-28 17:35:19 +0800
committerjhale <jhale@FreeBSD.org>2014-03-28 17:35:19 +0800
commit9a655ba47da54511b89a9753035709872020dd47 (patch)
tree956c183a1a6a7bdf41c2a2415bfe0f7b7eec3256 /sysutils
parentb2a592306a8da9afccf9b91416b561ee388a575e (diff)
downloadfreebsd-ports-gnome-9a655ba47da54511b89a9753035709872020dd47.tar.gz
freebsd-ports-gnome-9a655ba47da54511b89a9753035709872020dd47.tar.zst
freebsd-ports-gnome-9a655ba47da54511b89a9753035709872020dd47.zip
- Add patch to fix diskio memory leak
- Bump PORTREVISION While here: - Convert USE_BZIP2 -> USES PR: ports/181040 Submitted by: Ken DEGUCHI <kdeguchi@sz.tokoha-u.ac.jp> Approved by: maintainer timeout (~8 months)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/conky/Makefile5
-rw-r--r--sysutils/conky/files/patch-src-freebsd.c13
2 files changed, 13 insertions, 5 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 28a9e8f6da5a..cc2deb2e3fab 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -3,7 +3,7 @@
PORTNAME= conky
PORTVERSION= 1.9.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= SF
@@ -13,8 +13,7 @@ COMMENT?= Advanced, highly configurable system monitor for X11
CONFLICTS?= conky-awesome-[0-9]*
SLAVEDIRS= sysutils/conky-awesome
-USES= gmake iconv pkgconfig
-USE_BZIP2= yes
+USES= gmake iconv pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-portmon \
--disable-hddtemp \
diff --git a/sysutils/conky/files/patch-src-freebsd.c b/sysutils/conky/files/patch-src-freebsd.c
index df98d29a3b9f..2fe950a07466 100644
--- a/sysutils/conky/files/patch-src-freebsd.c
+++ b/sysutils/conky/files/patch-src-freebsd.c
@@ -1,5 +1,5 @@
---- src/freebsd.c.orig 2012-05-04 00:08:27.000000000 +0300
-+++ src/freebsd.c 2012-12-04 11:09:20.000000000 +0200
+--- src/freebsd.c.orig 2012-05-04 06:08:27.000000000 +0900
++++ src/freebsd.c 2013-08-05 09:02:37.000000000 +0900
@@ -38,6 +38,11 @@
#include <sys/types.h>
#include <sys/user.h>
@@ -53,3 +53,12 @@
if (!global_cpu) {
malloc_cpu_size = (info.cpu_count + 1) * sizeof(struct cpu_info);
+@@ -702,7 +706,7 @@
+ free(dev_select);
+ }
+
+- free(statinfo_cur.dinfo);
++ free(statinfo_cur.dinfo->mem_ptr);
+ return 0;
+ }
+