aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-12 06:26:32 +0800
committermiwi <miwi@FreeBSD.org>2009-04-12 06:26:32 +0800
commitaa17bc9377752bc2d078eeab77d4ae1baa95f912 (patch)
tree96dc94a6ef6320ee1da2d76c230a8f1ab3266f1b /sysutils
parent657fbabdac80c8b65f155af6c031752d71ddea74 (diff)
downloadfreebsd-ports-gnome-aa17bc9377752bc2d078eeab77d4ae1baa95f912.tar.gz
freebsd-ports-gnome-aa17bc9377752bc2d078eeab77d4ae1baa95f912.tar.zst
freebsd-ports-gnome-aa17bc9377752bc2d078eeab77d4ae1baa95f912.zip
FUSE-based file system backed by Amazon S3. Mount a bucket as a local
file system read/write. Store files/folders natively and transparently. WWW: http://code.google.com/p/s3fs/ PR: ports/133607 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-s3fs/Makefile34
-rw-r--r--sysutils/fusefs-s3fs/distinfo3
-rw-r--r--sysutils/fusefs-s3fs/pkg-descr5
-rw-r--r--sysutils/fusefs-s3fs/pkg-message1
5 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ca23562019b8..22f4566de735 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -252,6 +252,7 @@
SUBDIR += fusefs-libs
SUBDIR += fusefs-ntfs
SUBDIR += fusefs-pod
+ SUBDIR += fusefs-s3fs
SUBDIR += fusefs-smbnetfs
SUBDIR += fusefs-sqlfs
SUBDIR += fusefs-sshfs
diff --git a/sysutils/fusefs-s3fs/Makefile b/sysutils/fusefs-s3fs/Makefile
new file mode 100644
index 000000000000..ca2ca271cab4
--- /dev/null
+++ b/sysutils/fusefs-s3fs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fusefs-s3fs
+# Date created: 2009-04-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= s3fs
+DISTVERSION= r177
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= fusefs-
+DISTFILES= ${PORTNAME}-${DISTVERSION}-source${EXTRACT_SUFX}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= FUSE-based file system backed by Amazon S3
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ fuse:${PORTSDIR}/sysutils/fusefs-libs \
+ iconv:${PORTSDIR}/converters/iconv \
+ xml2:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+PLIST_FILES= sbin/s3fs
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/s3fs ${PREFIX}/sbin
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-s3fs/distinfo b/sysutils/fusefs-s3fs/distinfo
new file mode 100644
index 000000000000..3e56a79aaa6a
--- /dev/null
+++ b/sysutils/fusefs-s3fs/distinfo
@@ -0,0 +1,3 @@
+MD5 (s3fs-r177-source.tar.gz) = b6b0bcfe2f731b5370b53bf6f93f295f
+SHA256 (s3fs-r177-source.tar.gz) = fbbaa0de79fa8bfbda5345ff9873fa8bfe773b13e7f8a3926b8a11447e3ff255
+SIZE (s3fs-r177-source.tar.gz) = 18145
diff --git a/sysutils/fusefs-s3fs/pkg-descr b/sysutils/fusefs-s3fs/pkg-descr
new file mode 100644
index 000000000000..fb2f762c9817
--- /dev/null
+++ b/sysutils/fusefs-s3fs/pkg-descr
@@ -0,0 +1,5 @@
+FUSE-based file system backed by Amazon S3. Mount a bucket as a local
+file system read/write. Store files/folders natively and
+transparently.
+
+WWW: http://code.google.com/p/s3fs/
diff --git a/sysutils/fusefs-s3fs/pkg-message b/sysutils/fusefs-s3fs/pkg-message
new file mode 100644
index 000000000000..062705179678
--- /dev/null
+++ b/sysutils/fusefs-s3fs/pkg-message
@@ -0,0 +1 @@
+The usage of s3fs can be found at http://code.google.com/p/s3fs/wiki/FuseOverAmazon if you want to understand it.