aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2016-09-11 02:53:56 +0800
committermandree <mandree@FreeBSD.org>2016-09-11 02:53:56 +0800
commitb0b339d01f912dfdaccb97f53d370b885c1ec135 (patch)
tree677a0cda7a2f9d5cba1ef0318fcddd5fa3484c0c /sysutils
parent675aa570d47f1569397cb676ed365771979f3a76 (diff)
downloadfreebsd-ports-gnome-b0b339d01f912dfdaccb97f53d370b885c1ec135.tar.gz
freebsd-ports-gnome-b0b339d01f912dfdaccb97f53d370b885c1ec135.tar.zst
freebsd-ports-gnome-b0b339d01f912dfdaccb97f53d370b885c1ec135.zip
Ignore SIGINFO during self-tests.
In the FreeBSD-specific patch, when the environment variable e2fsprogs_inhibit_SIGINFO exists (whatever its content, even if empty), do NOT install the SIGINFO handler. Leverage this when running the self-tests. This is to avoid false negatives during the self-tests due to interspersed SIGINFO output redirected from stderr to the log files. Bump PORTREVISION because this changes the e2fsck utility.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile4
-rw-r--r--sysutils/e2fsprogs/files/patch-e2fsck__unix.c6
2 files changed, 6 insertions, 4 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 11b23d6476ba..c31f6365fd8b 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.43.3
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
@@ -195,7 +195,7 @@ post-build:
@${ECHO_CMD} '===> Running e2fsprogs self-test suite'
# do not add -j options unconditionally to ${MAKE_CMD} below, this might break
# due to excessive disk space use.
- cd ${WRKSRC}/tests && ulimit -t 60 && ${MKDIR} ${WRKDIR}/tmp && ${MAKE_CMD} check ${_CHECK_JOBS} ${_checkaddargs} \
+ cd ${WRKSRC}/tests && ulimit -t 60 && ${MKDIR} ${WRKDIR}/tmp && ${SETENV} e2fsprogs_inhibit_SIGINFO=1 ${MAKE_CMD} check ${_CHECK_JOBS} ${_checkaddargs} \
|| { head -n30000 ${WRKSRC}/tests/*.failed 2>/dev/null ; exit 1 ; }
.else
@${ECHO_CMD} '===> SKIPPING e2fsprogs self-test suite (DISCOURAGED!)'
diff --git a/sysutils/e2fsprogs/files/patch-e2fsck__unix.c b/sysutils/e2fsprogs/files/patch-e2fsck__unix.c
index c59cbd8880f9..ad2a0eb87ed8 100644
--- a/sysutils/e2fsprogs/files/patch-e2fsck__unix.c
+++ b/sysutils/e2fsprogs/files/patch-e2fsck__unix.c
@@ -61,12 +61,14 @@
static void signal_progress_off(int sig EXT2FS_ATTR((unused)))
{
e2fsck_t ctx = e2fsck_global_ctx;
-@@ -1062,6 +1089,8 @@ static errcode_t PRS(int argc, char *arg
+@@ -1062,6 +1089,10 @@ static errcode_t PRS(int argc, char *arg
sigaction(SIGUSR1, &sa, 0);
sa.sa_handler = signal_progress_off;
sigaction(SIGUSR2, &sa, 0);
+ sa.sa_handler = signal_progress_now;
-+ sigaction(SIGINFO, &sa, 0);
++ if (!getenv("e2fsprogs_inhibit_SIGINFO")) {
++ sigaction(SIGINFO, &sa, 0);
++ }
#endif
/* Update our PATH to include /sbin if we need to run badblocks */