aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-12-30 02:06:31 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-12-30 02:06:31 +0800
commitbda0e08691e0e5a5e5886fbed131ee9c68194b56 (patch)
treef2fc86549d6c5ce4f303494f0896b1f6a566403f /sysutils
parenta14ffda048e6e9276942c43b27184ecd4dc36451 (diff)
downloadfreebsd-ports-gnome-bda0e08691e0e5a5e5886fbed131ee9c68194b56.tar.gz
freebsd-ports-gnome-bda0e08691e0e5a5e5886fbed131ee9c68194b56.tar.zst
freebsd-ports-gnome-bda0e08691e0e5a5e5886fbed131ee9c68194b56.zip
Burp is a backup and restore program.
It uses librsync in order to save on the amount of space that is used by each backup. It also uses VSS (Volume Shadow Copy Service) to make snapshots when backing up Windows computers. WWW: http://burp.grke.org/ PR: 204267 Submitted by: loic-freebsd@loicp.eu
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/burp/Makefile42
-rw-r--r--sysutils/burp/distinfo2
-rw-r--r--sysutils/burp/files/burp.in32
-rw-r--r--sysutils/burp/pkg-descr6
-rw-r--r--sysutils/burp/pkg-plist24
6 files changed, 107 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 49fc0e7b7123..608f079c5878 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -104,6 +104,7 @@
SUBDIR += bsdstats
SUBDIR += btsixad
SUBDIR += bulk_extractor
+ SUBDIR += burp
SUBDIR += busybox
SUBDIR += byobu
SUBDIR += cbsd
diff --git a/sysutils/burp/Makefile b/sysutils/burp/Makefile
new file mode 100644
index 000000000000..b7ef70773868
--- /dev/null
+++ b/sysutils/burp/Makefile
@@ -0,0 +1,42 @@
+# Created by: Loic Pefferkorn <loic-freebsd@loicp.eu>
+# $FreeBSD$
+
+PORTNAME= burp
+PORTVERSION= 1.4.40
+CATEGORIES= sysutils
+
+MAINTAINER= loic-freebsd@loicp.eu
+COMMENT= Network backup and restore program
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:${PORTSDIR}/devel/uthash
+LIB_DEPENDS= librsync.so:${PORTSDIR}/net/librsync1
+
+USE_GITHUB= yes
+GH_ACCOUNT= grke
+
+USE_RC_SUBR= burp
+GNU_CONFIGURE= yes
+USES= gmake localbase
+
+CONFIGURE_ARGS= --sbindir="${PREFIX}/sbin" \
+ --sysconfdir=${ETCDIR} \
+
+CONFIG_FILES= configs/server/burp.conf \
+ configs/client/burp.conf \
+ configs/certs/CA/CA.cnf
+
+post-patch:
+.for f in ${CONFIG_FILES}
+ @${REINPLACE_CMD} -e 's,/etc/burp,${PREFIX}/etc/burp,g' ${WRKSRC}/${f}
+ @${REINPLACE_CMD} -e 's,/usr/sbin,${PREFIX}/sbin,g' ${WRKSRC}/${f}
+.endfor
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/bedup
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/vss_strip
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/burp
+
+.include <bsd.port.mk>
diff --git a/sysutils/burp/distinfo b/sysutils/burp/distinfo
new file mode 100644
index 000000000000..e7c3e815867b
--- /dev/null
+++ b/sysutils/burp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (grke-burp-1.4.40_GH0.tar.gz) = 2e6a9a28453a11f3e36d0beefa185e72e7781a8718b55d3101144c9900752d6f
+SIZE (grke-burp-1.4.40_GH0.tar.gz) = 858049
diff --git a/sysutils/burp/files/burp.in b/sysutils/burp/files/burp.in
new file mode 100644
index 000000000000..e6f4c14000e2
--- /dev/null
+++ b/sysutils/burp/files/burp.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: burp
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# burp_enable (bool): Set to NO by default.
+# Set it to YES to enable burp.
+# burp_config (path): Set to %%PREFIX%%/etc/burp/burp.cf
+# by default.
+
+. /etc/rc.subr
+
+name=burp
+rcvar=burp_enable
+
+load_rc_config $name
+
+: ${burp_enable:="NO"}
+: ${burp_config="%%PREFIX%%/etc/burp/burp-server.conf"}
+
+command=%%PREFIX%%/sbin/${name}
+pidfile=/var/run/${name}.server.pid
+
+command_args="-c $burp_config"
+
+run_rc_command "$1"
diff --git a/sysutils/burp/pkg-descr b/sysutils/burp/pkg-descr
new file mode 100644
index 000000000000..add96e0a3463
--- /dev/null
+++ b/sysutils/burp/pkg-descr
@@ -0,0 +1,6 @@
+Burp is a backup and restore program.
+It uses librsync in order to save on the amount of space that is used
+by each backup. It also uses VSS (Volume Shadow Copy Service)
+to make snapshots when backing up Windows computers.
+
+WWW: http://burp.grke.org/
diff --git a/sysutils/burp/pkg-plist b/sysutils/burp/pkg-plist
new file mode 100644
index 000000000000..b5a29a9a7a3c
--- /dev/null
+++ b/sysutils/burp/pkg-plist
@@ -0,0 +1,24 @@
+%%ETCDIR%%/autoupgrade/server/win32/script
+%%ETCDIR%%/autoupgrade/server/win64/script
+%%ETCDIR%%/burp-server.conf
+%%ETCDIR%%/burp.conf
+%%ETCDIR%%/clientconfdir/incexc/example
+%%ETCDIR%%/clientconfdir/testclient
+%%ETCDIR%%/notify_script
+%%ETCDIR%%/ssl_extra_checks_script
+%%ETCDIR%%/summary_script
+%%ETCDIR%%/timer_script
+%%ETCDIR%%/CA.cnf
+man/man8/bedup.8.gz
+man/man8/burp.8.gz
+man/man8/burp_ca.8.gz
+man/man8/vss_strip.8.gz
+sbin/bedup
+sbin/burp
+sbin/burp_ca
+sbin/vss_strip
+@dir %%ETCDIR%%/CA-client
+@dir %%ETCDIR%%/autoupgrade/client
+@dir %%ETCDIR%%/autoupgrade/server/win32/1.4.40
+@dir %%ETCDIR%%/autoupgrade/server/win64/1.4.40
+@dir /var/spool/burp