aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2019-07-07 18:59:44 +0800
committerMatthew Seaman <matthew@FreeBSD.org>2019-07-07 18:59:44 +0800
commitbdebb4b74683d536a9fb088bacdc6a087772e1c1 (patch)
treec010d357ce24dbea8dd7dde858a5bf5fcc4a1e97 /sysutils
parentd65a07013b74c3bf96d63a7a7a0b5bd12ebbd1cf (diff)
downloadfreebsd-ports-gnome-bdebb4b74683d536a9fb088bacdc6a087772e1c1.tar.gz
freebsd-ports-gnome-bdebb4b74683d536a9fb088bacdc6a087772e1c1.tar.zst
freebsd-ports-gnome-bdebb4b74683d536a9fb088bacdc6a087772e1c1.zip
Use the autoconf caching mechanism to set two variables thus
preventing configure from finding libinotify even if it is present. This will have no effect on packages built in a clean environment, but it will make it easier to just build ad-hoc out of the ports tree. Submitted by: koobs Reported by: atari83 Differential Revision: https://reviews.freebsd.org/D20815
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/rsyslog8/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/sysutils/rsyslog8/Makefile b/sysutils/rsyslog8/Makefile
index 973a73c926fa..91f34e5b9f2d 100644
--- a/sysutils/rsyslog8/Makefile
+++ b/sysutils/rsyslog8/Makefile
@@ -19,13 +19,10 @@ LIB_DEPENDS= libee.so:devel/libee \
libcurl.so:ftp/curl
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils@${PY_FLAVOR}
-PORTSCOUT= limit:^8\.
-
USES= libtool pkgconfig autoreconf python:env
-
USE_LDCONFIG= yes
-CONFLICTS_BUILD= libinotify-*
+PORTSCOUT= limit:^8\.
OPTIONS_DEFINE= DBI DOCS ELASTIC GCRYPT GSSAPI HTTP JSONPARSE KAFKA \
MYSQL NORMALIZE PGSQL RABBITMQ RELP SNMP
@@ -72,7 +69,7 @@ JSONPARSE_PLIST_FILES= lib/rsyslog/mmjsonparse.so
KAFKA_DESC= Kafka input/output module for rsyslog
KAFKA_LIB_DEPENDS= librdkafka.so:net/librdkafka
-KAFKA_CONFIGURE_ENABLE= imkafka omkafka
+KAFKA_CONFIGURE_ENABLE= imkafka omkafka
KAFKA_PLIST_FILES= lib/rsyslog/imkafka.so \
lib/rsyslog/omkafka.so
@@ -147,7 +144,8 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+= --enable-imdiag --enable-imfile --enable-impstats \
--enable-mail --enable-omprog --enable-omstdout \
- --enable-omuxsock --enable-rfc3195 --disable-testbench
+ --enable-omuxsock --enable-rfc3195 --disable-testbench \
+ ac_cv_func_inotify_init=no ac_cv_header_sys_inotify_h=no
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200061
CONFIGURE_ARGS+= --enable-imuxsock-rfc5424