aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-07-08 18:08:43 +0800
committerkoobs <koobs@FreeBSD.org>2014-07-08 18:08:43 +0800
commitc5cabb9de9d2fceaef970a6aaa7829dcc37ace2c (patch)
treef189df2d8e2a44ba09f610f143f071e4e5bdb62e /sysutils
parent1a879155506c23a21d3384a33a8051c09cbb16eb (diff)
downloadfreebsd-ports-gnome-c5cabb9de9d2fceaef970a6aaa7829dcc37ace2c.tar.gz
freebsd-ports-gnome-c5cabb9de9d2fceaef970a6aaa7829dcc37ace2c.tar.zst
freebsd-ports-gnome-c5cabb9de9d2fceaef970a6aaa7829dcc37ace2c.zip
[NEW] sysutils/py-ploy_ec2: Ploy plugin to provision Amazon EC2 instances
A plugin for ploy providing integration with Amazon EC2. WWW: https://github.com/ployground/ploy_ec2
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-ploy_ec2/Makefile25
-rw-r--r--sysutils/py-ploy_ec2/distinfo2
-rw-r--r--sysutils/py-ploy_ec2/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 1599237144cb..0bc1501059c4 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -735,6 +735,7 @@
SUBDIR += py-nagiosplugin
SUBDIR += py-ploy
SUBDIR += py-ploy_ansible
+ SUBDIR += py-ploy_ec2
SUBDIR += py-ploy_ezjail
SUBDIR += py-ploy_fabric
SUBDIR += py-plumbum
diff --git a/sysutils/py-ploy_ec2/Makefile b/sysutils/py-ploy_ec2/Makefile
new file mode 100644
index 000000000000..de06a05b6104
--- /dev/null
+++ b/sysutils/py-ploy_ec2/Makefile
@@ -0,0 +1,25 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ploy_ec2
+DISTVERSION= 1.0b3
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Ploy plugin to provision Amazon EC2 instances
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ploy>=1.0.r9:${PORTSDIR}/sysutils/py-ploy \
+ ${PYTHON_PKGNAMEPREFIX}boto>=2.0:${PORTSDIR}/devel/py-boto \
+ ${PYTHON_PKGNAMEPREFIX}lazy>0:${PORTSDIR}/devel/py-lazy
+
+USES= zip
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-ploy_ec2/distinfo b/sysutils/py-ploy_ec2/distinfo
new file mode 100644
index 000000000000..b096ead21e3d
--- /dev/null
+++ b/sysutils/py-ploy_ec2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ploy_ec2-1.0b3.zip) = e827eaa9cc60cb14151d0534be645a27f3f204eb7828cbb1979c0eafd8de0aec
+SIZE (ploy_ec2-1.0b3.zip) = 13602
diff --git a/sysutils/py-ploy_ec2/pkg-descr b/sysutils/py-ploy_ec2/pkg-descr
new file mode 100644
index 000000000000..4b7ccfdb44f0
--- /dev/null
+++ b/sysutils/py-ploy_ec2/pkg-descr
@@ -0,0 +1,3 @@
+A plugin for ploy providing integration with Amazon EC2.
+
+WWW: https://github.com/ployground/ploy_ec2