aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2014-09-03 14:19:08 +0800
committermartymac <martymac@FreeBSD.org>2014-09-03 14:19:08 +0800
commitc6aa2c4fbcbb397ec9def447610aea3466393689 (patch)
tree888f6f064045c1c8b1e2f437107fee44284cc3b5 /sysutils
parent0dae3e155d12ce65bc839c6f721c29753524ef04 (diff)
downloadfreebsd-ports-gnome-c6aa2c4fbcbb397ec9def447610aea3466393689.tar.gz
freebsd-ports-gnome-c6aa2c4fbcbb397ec9def447610aea3466393689.tar.zst
freebsd-ports-gnome-c6aa2c4fbcbb397ec9def447610aea3466393689.zip
Switch to USES=python for my ports
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/brebis/Makefile5
-rw-r--r--sysutils/dvdvideo/Makefile4
2 files changed, 4 insertions, 5 deletions
diff --git a/sysutils/brebis/Makefile b/sysutils/brebis/Makefile
index 0fdb7091965f..726dbd8fab81 100644
--- a/sysutils/brebis/Makefile
+++ b/sysutils/brebis/Makefile
@@ -12,15 +12,14 @@ COMMENT= Fully automated backup checker
LICENSE= GPLv3
-USE_PYTHON= 3.3+
-USE_PYDISTUTILS= yes
+USES= python:3.3+
+USE_PYTHON= distutils noegginfo
# XXX Handle UTF-8 '(c)' character within setup.py's header
MAKE_ENV+= LC_ALL=en_US.UTF-8
PLIST_SUB+= PYTHON_SUFFIX=${PYTHON_SUFFIX} \
PYDISTUTILS_EGGINFO=${PYDISTUTILS_EGGINFO}
-PYDISTUTILS_NOEGGINFO= yes
PORTDOCS= README
diff --git a/sysutils/dvdvideo/Makefile b/sysutils/dvdvideo/Makefile
index c5dc5872462b..f57940ce255d 100644
--- a/sysutils/dvdvideo/Makefile
+++ b/sysutils/dvdvideo/Makefile
@@ -15,8 +15,8 @@ COMMENT= Video DVD backup tool
LICENSE= GPLv3
-USE_PYTHON= 3
-USE_PYDISTUTILS= yes
+USES= python:3
+USE_PYTHON= distutils
PYDISTUTILS_EGGINFO= python_dvdvideo-0.${PORTVERSION}-py${PYTHON_VER}.egg-info
PLIST_SUB+= PYTHON_SUFFIX=${PYTHON_SUFFIX}