aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2019-09-02 05:01:04 +0800
committeradridg <adridg@FreeBSD.org>2019-09-02 05:01:04 +0800
commitc94a3b00721cf479479c56ad55fd9b1501bcc95f (patch)
treebbb881af25b928755788c576a7812422f436d5fd /sysutils
parent53f7b1b29c50a5734dcebed2fa9f8a102808c49d (diff)
downloadfreebsd-ports-gnome-c94a3b00721cf479479c56ad55fd9b1501bcc95f.tar.gz
freebsd-ports-gnome-c94a3b00721cf479479c56ad55fd9b1501bcc95f.tar.zst
freebsd-ports-gnome-c94a3b00721cf479479c56ad55fd9b1501bcc95f.zip
Unbreak sysutils/pc-networkmanager
This is part of the TrueOS tools, and it was marked BROKEN about a year ago; a fix appeared upstream only days later, but there's been no udpate to the port. The same kind of fix probably applies to sysutils/pcbsd-utils-qt5 but I don't feel like chasing it. PR listed below is for that port, pinging maintainer(s). (All this is because we're chasing fallout for the Qt 5.13 update) PR: 231682
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pc-networkmanager/Makefile5
-rw-r--r--sysutils/pc-networkmanager/files/patch-git-b812350a16
2 files changed, 17 insertions, 4 deletions
diff --git a/sysutils/pc-networkmanager/Makefile b/sysutils/pc-networkmanager/Makefile
index bb1b8d043af6..aaba0d815ff3 100644
--- a/sysutils/pc-networkmanager/Makefile
+++ b/sysutils/pc-networkmanager/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pc-networkmanager
PORTVERSION= 201710031301
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MAINTAINER= jt@ixsystems.com
@@ -10,15 +10,12 @@ COMMENT= TrueOS Qt based network manager
LICENSE= BSD2CLAUSE
-BROKEN_FreeBSD_12= use of undeclared identifiers 'IFM_FDDI' and 'IFM_TOKEN'
-BROKEN_FreeBSD_13= use of undeclared identifiers 'IFM_FDDI' and 'IFM_TOKEN'
ONLY_FOR_ARCHS= amd64
LIB_DEPENDS= libtrueos-ui.so:sysutils/trueos-libqt5
MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
-CONFLICTS= pcbsd-utils*
MAKE_JOBS_UNSAFE= yes
USES= qmake qt:5 shebangfix tar:xz
diff --git a/sysutils/pc-networkmanager/files/patch-git-b812350a b/sysutils/pc-networkmanager/files/patch-git-b812350a
new file mode 100644
index 000000000000..8a5a5b53507c
--- /dev/null
+++ b/sysutils/pc-networkmanager/files/patch-git-b812350a
@@ -0,0 +1,16 @@
+diff --git src/backend/NetDevice.cpp src/backend/NetDevice.cpp
+index bb3a047..eb1f320 100644
+--- src/backend/NetDevice.cpp
++++ src/backend/NetDevice.cpp
+@@ -169,11 +169,6 @@ QString NetDevice::mediaStatusAsString(){
+ QString status;
+
+ switch (IFM_TYPE(ifm.ifm_active)){
+- case IFM_FDDI:
+- case IFM_TOKEN:
+- if (ifm.ifm_status & IFM_ACTIVE) status = "inserted";
+- else status = "no ring";
+- break;
+ case IFM_IEEE80211:
+ if (ifm.ifm_status & IFM_ACTIVE) status = "associated";
+ else status = "no carrier";