aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2010-09-30 22:34:47 +0800
committerkmoore <kmoore@FreeBSD.org>2010-09-30 22:34:47 +0800
commitcbb78f496502a22540f1c80c3d3588246af7dc6b (patch)
tree001a64a950714a10edee66d40402f6b3f13caa35 /sysutils
parent45679f966d06d2a9f8343c995454f13edff2a153 (diff)
downloadfreebsd-ports-gnome-cbb78f496502a22540f1c80c3d3588246af7dc6b.tar.gz
freebsd-ports-gnome-cbb78f496502a22540f1c80c3d3588246af7dc6b.tar.zst
freebsd-ports-gnome-cbb78f496502a22540f1c80c3d3588246af7dc6b.zip
Add sysutils/lxinput.
LXInput is a small program used to configure keyboard and mouse for LXDE.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/lxinput/Makefile35
-rw-r--r--sysutils/lxinput/distinfo3
-rw-r--r--sysutils/lxinput/pkg-descr3
-rw-r--r--sysutils/lxinput/pkg-plist75
5 files changed, 117 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9fafb4d55d2f..0b5ead94e9ce 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -470,6 +470,7 @@
SUBDIR += ltrace
SUBDIR += luckybackup
SUBDIR += luma
+ SUBDIR += lxinput
SUBDIR += lxsplit
SUBDIR += lxtask
SUBDIR += magicrescue
diff --git a/sysutils/lxinput/Makefile b/sysutils/lxinput/Makefile
new file mode 100644
index 000000000000..48ecff6bbf8b
--- /dev/null
+++ b/sysutils/lxinput/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lxinput
+# Date created: 2010/09/24
+# Whom: Kris Moore <kmoore@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lxinput
+PORTVERSION= 0.3.0
+CATEGORIES= sysutils
+MASTER_SITES= SF/lxde/LXInput%20%28Kbd%20and%20amp_%20mouse%20config%29/LXInput%200.3
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= A keyboard and mouse config tool from the LXDE project
+
+USE_GNOME= gtk20 intlhack
+USE_GMAKE= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+MAN1= lxinput.1
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/lxinput/distinfo b/sysutils/lxinput/distinfo
new file mode 100644
index 000000000000..0f6a22aa7b05
--- /dev/null
+++ b/sysutils/lxinput/distinfo
@@ -0,0 +1,3 @@
+MD5 (lxinput-0.3.0.tar.gz) = 34e8d557d76ad45141b8f42b62e7a0e1
+SHA256 (lxinput-0.3.0.tar.gz) = 14d2af22b00a6c3da366a0db798f4a92373737571306586703c9e16cf48d3c11
+SIZE (lxinput-0.3.0.tar.gz) = 233059
diff --git a/sysutils/lxinput/pkg-descr b/sysutils/lxinput/pkg-descr
new file mode 100644
index 000000000000..41d52824ee5f
--- /dev/null
+++ b/sysutils/lxinput/pkg-descr
@@ -0,0 +1,3 @@
+LXInput is a small program used to configure keyboard and mouse for LXDE.
+
+WWW: http://lxde.sourceforge.net/
diff --git a/sysutils/lxinput/pkg-plist b/sysutils/lxinput/pkg-plist
new file mode 100644
index 000000000000..d4eff941b6f0
--- /dev/null
+++ b/sysutils/lxinput/pkg-plist
@@ -0,0 +1,75 @@
+bin/lxinput
+%%NLS%%share/locale/af/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/bn/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/da/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/de/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/el/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/es/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/es_VE/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/et/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/fo/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/frp/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/he/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/id/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/it/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ps/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/th/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/lxinput.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/lxinput.mo
+share/applications/lxinput.desktop
+share/lxinput/lxinput.ui
+share/lxinput/input-mouse.png
+share/lxinput/input-keyboard.png
+@dirrm share/lxinput
+@dirrmtry share/applications
+%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ast
+%%NLS%%@dirrmtry share/locale/es_VE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_VE
+%%NLS%%@dirrmtry share/locale/fo/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fo
+%%NLS%%@dirrmtry share/locale/frp/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/frp
+%%NLS%%@dirrmtry share/locale/nb_NO/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nb_NO
+%%NLS%%@dirrmtry share/locale/sr@latin/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sr@latin
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK