aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-09-23 20:31:14 +0800
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-09-23 20:31:14 +0800
commitcbc524cc28598c665a1c561d75492a537780b88f (patch)
treea5950ef2067cabbd1596c87bd42f2b3a1771195e /sysutils
parent099b780fcaf556c283edd4fd868bb7fa0db9c33b (diff)
downloadfreebsd-ports-gnome-cbc524cc28598c665a1c561d75492a537780b88f.tar.gz
freebsd-ports-gnome-cbc524cc28598c665a1c561d75492a537780b88f.tar.zst
freebsd-ports-gnome-cbc524cc28598c665a1c561d75492a537780b88f.zip
sysutils/reggae: Update to 0.1.16
From ChangeLog: https://github.com/cbsd/reggae/releases/tag/0.1.16 * Add PF helper script * Pass SYSPKG to test script * Add deployment helpers * Allow target override * Firewall configuration improvements * Pass IPv6 ICMP in PF * Devel depends on init PR: 249517 Submitted by: meka@tilda.center
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/reggae/Makefile7
-rw-r--r--sysutils/reggae/distinfo6
-rw-r--r--sysutils/reggae/files/reggae_pf.in39
-rw-r--r--sysutils/reggae/pkg-plist3
4 files changed, 49 insertions, 6 deletions
diff --git a/sysutils/reggae/Makefile b/sysutils/reggae/Makefile
index 05b60d04fe79..4452076cb99b 100644
--- a/sysutils/reggae/Makefile
+++ b/sysutils/reggae/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= reggae
-PORTVERSION= 0.1.15
+PORTVERSION= 0.1.16
CATEGORIES= sysutils
MAINTAINER= meka@tilda.center
@@ -13,9 +13,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${LOCALBASE}/bin/cbsd:sysutils/cbsd \
sudo:security/sudo
-NO_ARCH= yes
-
USE_GITHUB= yes
GH_ACCOUNT= cbsd
+USE_RC_SUBR= reggae_pf
+
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/sysutils/reggae/distinfo b/sysutils/reggae/distinfo
index ec59403fded6..fa746081bcdd 100644
--- a/sysutils/reggae/distinfo
+++ b/sysutils/reggae/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594990836
-SHA256 (cbsd-reggae-0.1.15_GH0.tar.gz) = 3f417d20c2996edb59eab4656afe78726a33d17e112308283c6e008a9cc0b400
-SIZE (cbsd-reggae-0.1.15_GH0.tar.gz) = 45510
+TIMESTAMP = 1600723946
+SHA256 (cbsd-reggae-0.1.16_GH0.tar.gz) = 63c5bd29a2592e87a7290601d0010d40af41faa706331cd348a6866a38d20d82
+SIZE (cbsd-reggae-0.1.16_GH0.tar.gz) = 46136
diff --git a/sysutils/reggae/files/reggae_pf.in b/sysutils/reggae/files/reggae_pf.in
new file mode 100644
index 000000000000..287903270427
--- /dev/null
+++ b/sysutils/reggae/files/reggae_pf.in
@@ -0,0 +1,39 @@
+#!/bin/sh
+# $FreeBSD$
+#
+# PROVIDE: reggae_pf
+# REQUIRE: pf
+# AFTER: NETWORKING local_unbound named nsd unbound
+
+# Add the following lines to /etc/rc.conf.local, /etc/rc.conf or
+# /etc/rc.conf.d/reggae_pf to enable this service:
+#
+# reggae_pf_enable (bool): Set to NO by default.
+# Set it to "YES" to enable virtual_oss.
+# reggae_pf_directory (string): Directory containing PF anchor files
+# Default is "/etc/pf.d"
+
+. /etc/rc.subr
+
+name=reggae_pf
+desc="Reggae helper to load PF anchors"
+rcvar=${name}_enable
+start_precmd="${name}_precmd"
+
+load_rc_config $name
+
+: ${reggae_pf_enable:="NO"}
+: ${reggae_pf_directory:="/etc/pf.d"}
+
+command="%%PREFIX%%/bin/reggae"
+command_args="pf ${reggae_pf_directory}"
+
+reggae_pf_precmd()
+{
+ if [ ! -d "${reggae_pf_directory}" ]; then
+ echo "${reggae_pf_directory} is not directory" >&2
+ exit 1
+ fi
+}
+
+run_rc_command $*
diff --git a/sysutils/reggae/pkg-plist b/sysutils/reggae/pkg-plist
index a2da77db9bc4..a21bb34ca4eb 100644
--- a/sysutils/reggae/pkg-plist
+++ b/sysutils/reggae/pkg-plist
@@ -65,15 +65,18 @@ man/man1/reggae.1.gz
%%DATADIR%%/scripts/cbsd-init.sh
%%DATADIR%%/scripts/chef-provision.sh
%%DATADIR%%/scripts/default.conf
+%%DATADIR%%/scripts/expect-run.sh
%%DATADIR%%/scripts/get-config.sh
%%DATADIR%%/scripts/get-ip.sh
%%DATADIR%%/scripts/import.sh
%%DATADIR%%/scripts/init.sh
%%DATADIR%%/scripts/master-init.sh
%%DATADIR%%/scripts/network-init.sh
+%%DATADIR%%/scripts/pf.sh
%%DATADIR%%/scripts/pkg-upgrade.sh
%%DATADIR%%/scripts/project-init.sh
%%DATADIR%%/scripts/puppet-provision.sh
+%%DATADIR%%/scripts/read-pass.sh
%%DATADIR%%/scripts/register.sh
%%DATADIR%%/scripts/salt-provision.sh
%%DATADIR%%/scripts/scp.sh