aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-02-20 16:26:20 +0800
committerjbeich <jbeich@FreeBSD.org>2015-02-20 16:26:20 +0800
commitcd3c67c669e4d4b946498701ead5563e53b54589 (patch)
tree913242cbe4cc9a4a26e09d343efcd158069fff61 /sysutils
parent72d88336098f94d8f016fd524dbd49ec181d4f28 (diff)
downloadfreebsd-ports-gnome-cd3c67c669e4d4b946498701ead5563e53b54589.tar.gz
freebsd-ports-gnome-cd3c67c669e4d4b946498701ead5563e53b54589.tar.zst
freebsd-ports-gnome-cd3c67c669e4d4b946498701ead5563e53b54589.zip
Pass "automounted" mount option to mount_fusefs(8)
This only addresses libfuse rejecting unknown option. mount_fusefs(8) still needs to be fixed separately. PR: 192852
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-libs/Makefile2
-rw-r--r--sysutils/fusefs-libs/files/patch-lib_mount_bsd.c8
2 files changed, 9 insertions, 1 deletions
diff --git a/sysutils/fusefs-libs/Makefile b/sysutils/fusefs-libs/Makefile
index fb011e96e7b2..02bacdb6bf86 100644
--- a/sysutils/fusefs-libs/Makefile
+++ b/sysutils/fusefs-libs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fusefs
PORTVERSION= 2.9.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= SF/fuse/fuse-2.X/${PORTVERSION}
PKGNAMESUFFIX= -libs
diff --git a/sysutils/fusefs-libs/files/patch-lib_mount_bsd.c b/sysutils/fusefs-libs/files/patch-lib_mount_bsd.c
index 27efee490db4..281d585fb50b 100644
--- a/sysutils/fusefs-libs/files/patch-lib_mount_bsd.c
+++ b/sysutils/fusefs-libs/files/patch-lib_mount_bsd.c
@@ -9,6 +9,14 @@
#include <sys/stat.h>
#include <sys/wait.h>
#include <sys/sysctl.h>
+@@ -78,6 +80,7 @@ static const struct fuse_opt fuse_mount_
+ FUSE_DUAL_OPT_KEY("ro", KEY_KERN),
+ FUSE_DUAL_OPT_KEY("rw", KEY_KERN),
+ FUSE_DUAL_OPT_KEY("auto", KEY_KERN),
++ FUSE_DUAL_OPT_KEY("automounted", KEY_KERN),
+ /* options supported under both Linux and FBSD */
+ FUSE_DUAL_OPT_KEY("allow_other", KEY_KERN),
+ FUSE_DUAL_OPT_KEY("default_permissions",KEY_KERN),
@@ -192,56 +194,12 @@
free(umount_cmd);
}