aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-05-22 21:15:13 +0800
committermat <mat@FreeBSD.org>2018-05-22 21:15:13 +0800
commitcff6da1b7fcbd896785c044bbdfe462c9fb1a74c (patch)
treec832b87b776a5db072088687b910601d961726da /sysutils
parent9304895709a6f8eba3df00bc5410b6f5dbe8382f (diff)
downloadfreebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.tar.gz
freebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.tar.zst
freebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.zip
Add PY_FLAVOR to Python module dependencies.
Sponsored by: Absolight
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/openipmi/Makefile2
-rw-r--r--sysutils/osquery/Makefile2
-rw-r--r--sysutils/pcbsd-utils-qt5/Makefile10
-rw-r--r--sysutils/py-superlance/Makefile2
-rw-r--r--sysutils/rubygem-smart_proxy_salt/Makefile2
-rw-r--r--sysutils/tuptime/Makefile2
6 files changed, 10 insertions, 10 deletions
diff --git a/sysutils/openipmi/Makefile b/sysutils/openipmi/Makefile
index d5588a45357c..e06fc7b1b173 100644
--- a/sysutils/openipmi/Makefile
+++ b/sysutils/openipmi/Makefile
@@ -60,7 +60,7 @@ CONFIGURE_ARGS+= --with-openssl=no
.if ${PORT_OPTIONS:MTKINTER}
USES+= python
WITH_PYTHON= yes
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter \
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
${LOCALBASE}/lib/Tix8.4.3/Tix.tcl:x11-toolkits/tix
CONFIGURE_ARGS+= --with-tkinter
PLIST_SUB+= TKINTER=""
diff --git a/sysutils/osquery/Makefile b/sysutils/osquery/Makefile
index 8050062de887..dc9874e79f39 100644
--- a/sysutils/osquery/Makefile
+++ b/sysutils/osquery/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= thrift>=0.11.0:devel/thrift \
bash>0:shells/bash \
linenoise-ng>0:devel/linenoise-ng \
rapidjson>0:devel/rapidjson \
- ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR}
LIB_DEPENDS= libaugeas.so:textproc/augeas \
libboost_regex.so:devel/boost-libs \
libgflags.so:devel/gflags \
diff --git a/sysutils/pcbsd-utils-qt5/Makefile b/sysutils/pcbsd-utils-qt5/Makefile
index bcd78b964822..2ab23901bdbb 100644
--- a/sysutils/pcbsd-utils-qt5/Makefile
+++ b/sysutils/pcbsd-utils-qt5/Makefile
@@ -12,14 +12,14 @@ COMMENT= PC-BSD Qt5 Utilities
LICENSE= BSD3CLAUSE
BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
- ${PYTHON_PKGNAMEPREFIX}sphinx-intl>=0:textproc/py-sphinx-intl \
- ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-httpdomain>=0:textproc/py-sphinxcontrib-httpdomain \
- ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>=0:textproc/py-sphinx_rtd_theme \
- ${PYTHON_PKGNAMEPREFIX}alabaster>=0:textproc/py-alabaster \
+ ${PYTHON_PKGNAMEPREFIX}sphinx-intl>=0:textproc/py-sphinx-intl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-httpdomain>=0:textproc/py-sphinxcontrib-httpdomain@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>=0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}alabaster>=0:textproc/py-alabaster@${PY_FLAVOR} \
tex-formats>=0:print/tex-formats \
tex-dvipsk>=0:print/tex-dvipsk
RUN_DEPENDS= pc-updatemanager:sysutils/pcbsd-utils \
- ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus \
+ ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
cdda2wav:sysutils/cdrtools
LIB_DEPENDS= libcurl.so:ftp/curl \
libpoppler-qt5.so:graphics/poppler-qt5
diff --git a/sysutils/py-superlance/Makefile b/sysutils/py-superlance/Makefile
index 30ef0ec9c4cd..72236c4004df 100644
--- a/sysutils/py-superlance/Makefile
+++ b/sysutils/py-superlance/Makefile
@@ -24,7 +24,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300
-TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
.endif
do-test:
diff --git a/sysutils/rubygem-smart_proxy_salt/Makefile b/sysutils/rubygem-smart_proxy_salt/Makefile
index d4626373dd7c..bcd09845f6d1 100644
--- a/sysutils/rubygem-smart_proxy_salt/Makefile
+++ b/sysutils/rubygem-smart_proxy_salt/Makefile
@@ -12,7 +12,7 @@ COMMENT= SaltStack Plug-In for Foreman's Smart Proxy
LICENSE= GPLv3
RUN_DEPENDS= foreman-proxy>=1.8.0:net/foreman-proxy \
- ${PYTHON_PKGNAMEPREFIX}salt>0:sysutils/py-salt
+ ${PYTHON_PKGNAMEPREFIX}salt>0:sysutils/py-salt@${PY_FLAVOR}
NO_ARCH= yes
diff --git a/sysutils/tuptime/Makefile b/sysutils/tuptime/Makefile
index eb288b29df37..43e2141bd4d8 100644
--- a/sysutils/tuptime/Makefile
+++ b/sysutils/tuptime/Makefile
@@ -10,7 +10,7 @@ COMMENT= Historical and statistical system running time report tool
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7:databases/py-sqlite3
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7:databases/py-sqlite3@${PY_FLAVOR}
USES= python:run shebangfix
USE_GITHUB= yes