aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-26 05:42:01 +0800
committerPav Lucistnik <pav@FreeBSD.org>2004-10-26 05:42:01 +0800
commite339af876bbc7e8c3a61bb1b8d04fab6f385a028 (patch)
tree47c85fdf8ca58d5bc8520d2b8d55598fa7402d8c /sysutils
parentec4731bcdd7a8bc4776dbe66fd83be576892ec0e (diff)
downloadfreebsd-ports-gnome-e339af876bbc7e8c3a61bb1b8d04fab6f385a028.tar.gz
freebsd-ports-gnome-e339af876bbc7e8c3a61bb1b8d04fab6f385a028.tar.zst
freebsd-ports-gnome-e339af876bbc7e8c3a61bb1b8d04fab6f385a028.zip
- Fix acpitemp function by changing type from double to int (we get temp
in kelvins (int) and then convert it in celsius (double)). Reported by: Aurel Bodenmann PR: ports/73087 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/torsmo/Makefile2
-rw-r--r--sysutils/torsmo/files/freebsd.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/sysutils/torsmo/Makefile b/sysutils/torsmo/Makefile
index 930938e1a2d5..b9281dc2944b 100644
--- a/sysutils/torsmo/Makefile
+++ b/sysutils/torsmo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= torsmo
PORTVERSION= 0.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/sysutils/torsmo/files/freebsd.c b/sysutils/torsmo/files/freebsd.c
index cd5e9b00d8c2..19916df13dab 100644
--- a/sysutils/torsmo/files/freebsd.c
+++ b/sysutils/torsmo/files/freebsd.c
@@ -295,8 +295,8 @@ void get_load_average(double v[3]) {
}
double get_acpi_temperature(int fd) {
- double temp;
-
+ int temp;
+
if (GETSYSCTL("hw.acpi.thermal.tz0.temperature", temp)) {
(void)fprintf(stderr, "Cannot read sysctl \"hw.acpi.thermal.tz0.temperature\"\n");
temp = -1.0;