aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-02-20 04:39:02 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-02-20 04:39:02 +0800
commite3c8b537397a98cb8be059da9185817a06e68cc7 (patch)
tree87364927a757200c5ca8ae10c6f2e3e66baa3d6d /sysutils
parentf25c47790090895e525f6fb83182f861cade2cd1 (diff)
downloadfreebsd-ports-gnome-e3c8b537397a98cb8be059da9185817a06e68cc7.tar.gz
freebsd-ports-gnome-e3c8b537397a98cb8be059da9185817a06e68cc7.tar.zst
freebsd-ports-gnome-e3c8b537397a98cb8be059da9185817a06e68cc7.zip
- Fix build with clang
- Remove unrecognized CONFIGURE_ARGS - Remove PTHREAD_LIBS [1] Submitted by: gahr [1]
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/freeipmi/Makefile4
-rw-r--r--sysutils/freeipmi/files/patch-man-Makefile.in11
2 files changed, 12 insertions, 3 deletions
diff --git a/sysutils/freeipmi/Makefile b/sysutils/freeipmi/Makefile
index 036357d163aa..2954548adb5b 100644
--- a/sysutils/freeipmi/Makefile
+++ b/sysutils/freeipmi/Makefile
@@ -19,13 +19,11 @@ OPTIONS_DEFINE= DEBUG DOCS IOPERM
IOPERM_DESC= Use i386_set_ioperm (i386/amd64 only)
CONFIGURE_ARGS= --disable-init-scripts \
- --disable-logdir \
- --disable-logrotate-config \
--localstatedir=/var \
--sysconfdir=${CONF_DIR} \
--with-ipmi-monitoring-sdr-cache-dir=${CACHE_DIR}/ipmimonitoringsdrcache \
--with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig
-CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
+CONFIGURE_ENV= PTHREAD_LIBS=-pthread ac_cv_path_CPP=${CPP}
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/sysutils/freeipmi/files/patch-man-Makefile.in b/sysutils/freeipmi/files/patch-man-Makefile.in
new file mode 100644
index 000000000000..4ad374aaf68c
--- /dev/null
+++ b/sysutils/freeipmi/files/patch-man-Makefile.in
@@ -0,0 +1,11 @@
+--- man/Makefile.in.orig 2013-01-11 03:00:35.000000000 +0800
++++ man/Makefile.in 2013-02-02 03:18:42.250624916 +0800
+@@ -896,7 +896,7 @@
+
+
+ $(MANS_CPP): $(MANS_CPP:%=%.pre)
+- $(CPP) -w -C -P -I$(top_srcdir)/man $@.pre $@
++ $(CPP) -w -C -I$(top_srcdir)/man $@.pre | grep -v '^#' > $@
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.