aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-12-19 23:08:41 +0800
committerbapt <bapt@FreeBSD.org>2017-12-19 23:08:41 +0800
commite51f2ea5ad85ad1b41d1f362e5f0979557e672c2 (patch)
tree18b98c867c8871d94809b8f1f0b08a16f818792e /sysutils
parent733359453a9178de9cbf7afd50e004384db88f1b (diff)
downloadfreebsd-ports-gnome-e51f2ea5ad85ad1b41d1f362e5f0979557e672c2.tar.gz
freebsd-ports-gnome-e51f2ea5ad85ad1b41d1f362e5f0979557e672c2.tar.zst
freebsd-ports-gnome-e51f2ea5ad85ad1b41d1f362e5f0979557e672c2.zip
CLeanup u-boot-tools
- Do not overwrite do-build, it is not necessary - Ensure the env variables are respected during configure phase - Now that we use the regular do-build kernel we can pass gmake variables via arguments which allows to overwrites predefine ones without custom patches - Force verbose mode when building to see what command line is invoke, in in particular which compiler is called - Overwrite NOSTDINC_FLAGS because on freebsd we do actually want to use our regular standard include files - Register the dependency on libssl/libcrypto Approved by: manu Differential Revision: https://reviews.freebsd.org/D13543
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/u-boot-tools/Makefile12
-rw-r--r--sysutils/u-boot-tools/files/patch-Makefile20
-rw-r--r--sysutils/u-boot-tools/files/patch-scripts__Makefile.autoconf11
3 files changed, 7 insertions, 36 deletions
diff --git a/sysutils/u-boot-tools/Makefile b/sysutils/u-boot-tools/Makefile
index 4d09fdb780cb..256cf09d7ea5 100644
--- a/sysutils/u-boot-tools/Makefile
+++ b/sysutils/u-boot-tools/Makefile
@@ -12,17 +12,19 @@ COMMENT= U-boot related tools
LICENSE= GPLv2
-USES= tar:bzip2 gmake python:2.7,build
+USES= tar:bzip2 gmake python:2.7,build ssl
CONFLICT= uboot-mkimage
+ALL_TARGET= tools-only
+MAKE_ARGS= ARCH=sandbox \
+ CC="${CC}" \
+ KBUILD_VERBOSE=1 \
+ NOSTDINC_FLAGS="" \
PLIST_FILES= bin/mkimage bin/mkenvimage bin/dumpimage bin/fit_info
do-configure:
- (cd ${WRKSRC}/ && ${MAKE_CMD} sandbox_defconfig)
-
-do-build:
- (cd ${WRKSRC}/ && ${MAKE_CMD} ARCH=sandbox tools-only)
+ (cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} sandbox_defconfig)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tools/dumpimage ${STAGEDIR}${PREFIX}/bin
diff --git a/sysutils/u-boot-tools/files/patch-Makefile b/sysutils/u-boot-tools/files/patch-Makefile
deleted file mode 100644
index 0b157a1adfb9..000000000000
--- a/sysutils/u-boot-tools/files/patch-Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.orig 2017-09-11 18:10:40 UTC
-+++ Makefile
-@@ -338,7 +338,7 @@ LD = $(CROSS_COMPILE)ld.bfd
- else
- LD = $(CROSS_COMPILE)ld
- endif
--CC = $(CROSS_COMPILE)gcc
-+CC = $(CROSS_COMPILE)cc
- CPP = $(CC) -E
- AR = $(CROSS_COMPILE)ar
- NM = $(CROSS_COMPILE)nm
-@@ -633,7 +633,7 @@ UBOOTINCLUDE := \
- -I$(srctree)/arch/$(ARCH)/include \
- -include $(srctree)/include/linux/kconfig.h
-
--NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
-+NOSTDINC_FLAGS += -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS += $(NOSTDINC_FLAGS)
-
- # FIX ME
diff --git a/sysutils/u-boot-tools/files/patch-scripts__Makefile.autoconf b/sysutils/u-boot-tools/files/patch-scripts__Makefile.autoconf
deleted file mode 100644
index 5926ee57d773..000000000000
--- a/sysutils/u-boot-tools/files/patch-scripts__Makefile.autoconf
+++ /dev/null
@@ -1,11 +0,0 @@
---- scripts/Makefile.autoconf.orig 2017-09-11 18:10:40 UTC
-+++ scripts/Makefile.autoconf
-@@ -27,7 +27,7 @@ include scripts/Kbuild.include
- # Need to define CC and CPP again here in case the top Makefile did not
- # include config.mk. Some architectures expect CROSS_COMPILE to be defined
- # in arch/$(ARCH)/config.mk
--CC = $(CROSS_COMPILE)gcc
-+CC = $(CROSS_COMPILE)cc
- CPP = $(CC) -E
-
- include config.mk