aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-04-18 21:38:10 +0800
committerJoseph Mingrone <jrm@FreeBSD.org>2017-04-18 21:38:10 +0800
commitea3cacb3fb2d66a5532abddbb292f50aff1f3c9b (patch)
treeee2ba1bda4cd78ff47829764c8516ef998f42850 /sysutils
parent1b39ee44f977d2b3fa5e605347f44775189b112e (diff)
downloadfreebsd-ports-gnome-ea3cacb3fb2d66a5532abddbb292f50aff1f3c9b.tar.gz
freebsd-ports-gnome-ea3cacb3fb2d66a5532abddbb292f50aff1f3c9b.tar.zst
freebsd-ports-gnome-ea3cacb3fb2d66a5532abddbb292f50aff1f3c9b.zip
sysutils/slurm-wlm: Add support for the jobacct_gather/linux plugin
- The plugin requires linprocfs, so add an off-by-defult option knob to depend on linux. - Patch source files to point to /compat/linux/proc. Submitted by: Jason Bacon <bacon4000@gmail.com> Approved by: swills (mentor, implicit)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/slurm-wlm/Makefile30
1 files changed, 29 insertions, 1 deletions
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index 1d32904f5d01..cd5896915e67 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -34,7 +34,7 @@ USES= gmake libtool pkgconfig python:build readline shebangfix ssl \
USE_PERL5= configure
SHEBANG_FILES= doc/html/shtml2html.py doc/man/man2html.py
-OPTIONS_DEFINE= CURL DOCS GTK2 HDF5 HWLOC IPMI MYSQL RRD
+OPTIONS_DEFINE= CURL DOCS GTK2 HDF5 HWLOC IPMI MYSQL RRD LINUX
OPTIONS_DEFAULT=HDF5 HWLOC
OPTIONS_SUB= yes
@@ -44,6 +44,7 @@ HDF5_DESC= Job profiling using HDF5
HWLOC_DESC= Portable hardware locality
IPMI_DESC= IPMI engergy consumption accounting
RRD_DESC= RRD external sensor data collection
+LINUX_DESC= Support jobacct_gather/linux (requires linprocfs)
DOCS_BUILD_DEPENDS= man2html:textproc/man2html
@@ -75,6 +76,8 @@ MYSQL_CONFIGURE_OFF= --with-mysql_config=/nonexistent
RRD_LIB_DEPENDS= librrd.so:databases/rrdtool
RRD_CONFIGURE_WITH= rrdtool
+LINUX_USES= linux
+
CFLAGS+= -I${WRKSRC}/slurm -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lsysinfo -lkvm
@@ -100,6 +103,31 @@ post-patch:
-e 's|SlurmdSpoolDir=.*|SlurmdSpoolDir=/var/spool/slurmd|' \
-e 's|StateSaveLocation=.*|StateSaveLocation=/var/run/slurm|' \
${WRKSRC}/etc/slurm.conf.example
+ @${REINPLACE_CMD} -e 's|"/proc|"/compat/linux/proc|g' \
+ ${WRKSRC}/src/slurmd/slurmstepd/req.c \
+ ${WRKSRC}/src/slurmd/slurmstepd/pdebug.c \
+ ${WRKSRC}/src/slurmd/slurmd/get_mach_stat.c \
+ ${WRKSRC}/src/slurmd/slurmd/read_proc.c \
+ ${WRKSRC}/src/slurmd/common/xcpuinfo.c \
+ ${WRKSRC}/src/slurmd/common/xcgroup.c \
+ ${WRKSRC}/src/slurmd/common/set_oomadj.c \
+ ${WRKSRC}/src/slurmd/common/proctrack.c \
+ ${WRKSRC}/src/common/callerid.c \
+ ${WRKSRC}/src/plugins/task/affinity/affinity.c \
+ ${WRKSRC}/src/plugins/acct_gather_energy/rapl/acct_gather_energy_rapl.c \
+ ${WRKSRC}/src/plugins/jobacct_gather/cgroup/jobacct_gather_cgroup.c \
+ ${WRKSRC}/src/plugins/jobacct_gather/common/common_jag.c \
+ ${WRKSRC}/src/plugins/jobacct_gather/linux/jobacct_gather_linux.c \
+ ${WRKSRC}/src/plugins/jobacct_gather/aix/jobacct_gather_aix.c \
+ ${WRKSRC}/src/plugins/switch/cray/scaling.c \
+ ${WRKSRC}/src/plugins/proctrack/cray/proctrack_cray.c \
+ ${WRKSRC}/src/plugins/proctrack/cgroup/proctrack_cgroup.c \
+ ${WRKSRC}/src/plugins/proctrack/pgid/proctrack_pgid.c \
+ ${WRKSRC}/src/plugins/proctrack/linuxproc/kill_tree.c \
+ ${WRKSRC}/src/plugins/proctrack/lua/proctrack_lua.c \
+ ${WRKSRC}/src/plugins/acct_gather_filesystem/lustre/acct_gather_filesystem_lustre.c \
+ ${WRKSRC}/contribs/cray/pam_job.c \
+ ${WRKSRC}/contribs/lua/proctrack.lua
# Hack around nonfunctional --disable-gtktest flag
post-patch-GTK2-off: