aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2014-03-09 03:17:50 +0800
committerlev <lev@FreeBSD.org>2014-03-09 03:17:50 +0800
commiteba04564cea14888f8e0a7886b41618a466e9b08 (patch)
tree91fafab2c245f1405b47903a7fc43ec39139c30b /sysutils
parent030d1e7018d3294cea3500072a970d7b051daa33 (diff)
downloadfreebsd-ports-gnome-eba04564cea14888f8e0a7886b41618a466e9b08.tar.gz
freebsd-ports-gnome-eba04564cea14888f8e0a7886b41618a466e9b08.tar.zst
freebsd-ports-gnome-eba04564cea14888f8e0a7886b41618a466e9b08.zip
Update to version 1.3
Add support for 10 and 11 systems (versions prior this could cause crash on these). Add support for direct-dispatch as receiver (callee) only.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/graid5/Makefile29
-rw-r--r--sysutils/graid5/distinfo4
-rw-r--r--sysutils/graid5/pkg-descr5
-rw-r--r--sysutils/graid5/pkg-plist2
4 files changed, 20 insertions, 20 deletions
diff --git a/sysutils/graid5/Makefile b/sysutils/graid5/Makefile
index e82d46af1a85..86214a0579eb 100644
--- a/sysutils/graid5/Makefile
+++ b/sysutils/graid5/Makefile
@@ -3,44 +3,43 @@
PORTNAME= graid5
PORTVERSION= ${MAINVERSION}.${VERSIONDATE}
-PORTREVISION= 2
-CATEGORIES= sysutils kld
+CATEGORIES= sysutils
MASTER_SITES= http://lev.serebryakov.spb.ru/download/graid5/
MAINTAINER= lev@FreeBSD.org
COMMENT= RAID5 geom class
-SSP_UNSAFE= kernel module does not support ssp
+LICENSE= BSD
+
USE_BZIP2= yes
NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
-MAINVERSION=1.1
-VERSIONDATE=20130907.44
+MAINVERSION=1.3
+VERSIONDATE=20140308.50
KMODDIR?= /boot/modules
PLIST_SUB+= KMODDIR=${KMODDIR:C,^/,,}
-SUB_LIST= KMODDIR=${KMODDIR}
-SUB_FILES= pkg-deinstall
MAKE_ENV+= KMODDIR=${KMODDIR} SRC_BASE=${SRC_BASE}
-.if defined(SYSDIR)
-MAKE_ENV+= SYSDIR=${SYSDIR}
-.endif
+USES= kmod uidfix
+
+# It want to make hardlink from /sbin/geom
+NO_STAGE= yes
MANCOMPRESSED= yes
MAN8= ${PORTNAME}.8
-NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if !exists(${SRC_BASE}/sys/Makefile)
-IGNORE= requires kernel source files
-.elif !exists(${SRC_BASE}/sbin/geom/Makefile)
+.if !exists(${SRC_BASE}/sbin/geom/Makefile)
IGNORE= requires sbin source files
.endif
post-install:
- kldxref ${KMODDIR}
+ /usr/sbin/kldxref ${KMODDIR}
+
+post-deinstall:
+ /usr/sbin/kldxref ${KMODDIR}
.include <bsd.port.post.mk>
diff --git a/sysutils/graid5/distinfo b/sysutils/graid5/distinfo
index 51dde60729f7..38bec9f7cd17 100644
--- a/sysutils/graid5/distinfo
+++ b/sysutils/graid5/distinfo
@@ -1,2 +1,2 @@
-SHA256 (graid5-1.1.20130907.44.tar.bz2) = 5098157621cb9171b5478f491f14e53ef7ac41f21152bcb0f5e0a912d559df19
-SIZE (graid5-1.1.20130907.44.tar.bz2) = 27942
+SHA256 (graid5-1.3.20140308.50.tar.bz2) = 70445226525ca383c139f1d06d629f0aa06efe6b488f8b491b301607a896da8f
+SIZE (graid5-1.3.20140308.50.tar.bz2) = 28288
diff --git a/sysutils/graid5/pkg-descr b/sysutils/graid5/pkg-descr
index ea3a6f5f4f7c..bcfe6e4ffefc 100644
--- a/sysutils/graid5/pkg-descr
+++ b/sysutils/graid5/pkg-descr
@@ -1,5 +1,8 @@
FreeBSD GEOM class for RAID5.
-This is RAID5 geom class, originally written by Arne Worner <arne_woerner@yahoo.com>
+ This is RAID5 geom class, originally written by
+Arne Worner <arne_woerner@yahoo.com>.
+
+ Now maintained by Lev Serebryakov <lev@FreeBSD.org>
WWW: http://lev.serebryakov.spb.ru/download/graid5/
diff --git a/sysutils/graid5/pkg-plist b/sysutils/graid5/pkg-plist
index 19181cb22893..bc0b426c91c5 100644
--- a/sysutils/graid5/pkg-plist
+++ b/sysutils/graid5/pkg-plist
@@ -2,5 +2,3 @@
%%KMODDIR%%/geom_raid5.ko
lib/geom/geom_raid5.so
sbin/graid5
-@exec kldxref /%%KMODDIR%%
-@unexec kldxref /%%KMODDIR%%