aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-01-19 23:45:22 +0800
committermat <mat@FreeBSD.org>2017-01-19 23:45:22 +0800
commitf22d54093f16c264ab4ff86f1c772513cb3a8e0e (patch)
tree2a312a178868f214689a8875fbe2109a2c9e5058 /sysutils
parent55dd07bce317a6a87cb600c4eb5a7d67c3d9721b (diff)
downloadfreebsd-ports-gnome-f22d54093f16c264ab4ff86f1c772513cb3a8e0e.tar.gz
freebsd-ports-gnome-f22d54093f16c264ab4ff86f1c772513cb3a8e0e.tar.zst
freebsd-ports-gnome-f22d54093f16c264ab4ff86f1c772513cb3a8e0e.zip
Tell plugins they can use awk and do not need gawk.
While there, make ipmi_ plugins easier to use, and sort the plugins.conf file. Submitted by: bcr Sponsored by: Absolight
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/munin-common/files/patch-plugins_node.d_ipmi__.in11
-rw-r--r--sysutils/munin-common/files/patch-plugins_node.d_multips__memory.in11
-rw-r--r--sysutils/munin-node/Makefile1
-rw-r--r--sysutils/munin-node/files/plugins.conf.in21
4 files changed, 35 insertions, 9 deletions
diff --git a/sysutils/munin-common/files/patch-plugins_node.d_ipmi__.in b/sysutils/munin-common/files/patch-plugins_node.d_ipmi__.in
new file mode 100644
index 000000000000..f6e4562ef6cd
--- /dev/null
+++ b/sysutils/munin-common/files/patch-plugins_node.d_ipmi__.in
@@ -0,0 +1,11 @@
+--- plugins/node.d/ipmi_.in.orig 2017-01-18 20:25:20 UTC
++++ plugins/node.d/ipmi_.in
+@@ -73,7 +73,7 @@ export CONFIG MEASURE
+
+ #### Work is done in this awk script
+
+-ipmitool sensor | gawk -F'|' '
++ipmitool sensor | awk -F'|' '
+ BEGIN {
+ FANS = "";
+ TEMPS = "";
diff --git a/sysutils/munin-common/files/patch-plugins_node.d_multips__memory.in b/sysutils/munin-common/files/patch-plugins_node.d_multips__memory.in
new file mode 100644
index 000000000000..52ef14fa9920
--- /dev/null
+++ b/sysutils/munin-common/files/patch-plugins_node.d_multips__memory.in
@@ -0,0 +1,11 @@
+--- plugins/node.d/multips_memory.in.orig 2017-01-18 20:25:20 UTC
++++ plugins/node.d/multips_memory.in
+@@ -137,7 +137,7 @@ fi
+ for name in $names; do
+ fieldname="$(clean_fieldname "$name")"
+
+- ps -eo $monitor,comm | gawk '
++ ps -eo $monitor,comm | awk '
+ BEGIN { total = "U"; } # U = Unknown.
+ /grep/ { next; }
+ $2 ~ /^'"$name"'$/ { total = total + ($1*1024); }
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index b8bce1f37e6c..23444add9756 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -3,6 +3,7 @@
PORTNAME= munin
PORTVERSION= ${MUNIN_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= ${MUNIN_SITES}
PKGNAMESUFFIX= -node
diff --git a/sysutils/munin-node/files/plugins.conf.in b/sysutils/munin-node/files/plugins.conf.in
index 1b07f7902aa8..77ce939a9189 100644
--- a/sysutils/munin-node/files/plugins.conf.in
+++ b/sysutils/munin-node/files/plugins.conf.in
@@ -45,16 +45,18 @@ env.leasefile /var/db/dhcpd.leases
group mail
env.exim %%LOCALBASE%%/sbin/exim
-[smart_*]
+[fail2ban*]
user root
-group operator
-env.smartpath %%LOCALBASE%%/sbin/smartctl
+env.client %%LOCALBASE%%/bin/fail2ban-client
[hddtemp_smartctl]
user root
group operator
env.smartctl %%LOCALBASE%%/sbin/smartctl
+[ipmi_*]
+user root
+
[mbmon*]
env.mbmon %%LOCALBASE%%/bin/mbmon
@@ -63,6 +65,10 @@ env.mysql %%LOCALBASE%%/bin/mysql
env.mysqladmin %%LOCALBASE%%/bin/mysqladmin
env.mysqlshow %%LOCALBASE%%/bin/mysqlshow
+[nut*]
+env.upsc %%LOCALBASE%%/bin/upsc
+env.upsconf %%LOCALBASE%%/etc/nut/ups.conf
+
[postfix*]
user root
env.logfile maillog
@@ -72,11 +78,8 @@ group wheel
env.mspqueue /var/spool/clientmqueue
env.mailstats /usr/sbin/mailstats
-[fail2ban*]
+[smart_*]
user root
-env.client %%LOCALBASE%%/bin/fail2ban-client
-
-[nut*]
-env.upsc %%LOCALBASE%%/bin/upsc
-env.upsconf %%LOCALBASE%%/etc/nut/ups.conf
+group operator
+env.smartpath %%LOCALBASE%%/sbin/smartctl