aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-23 17:40:50 +0800
committerStefan Eßer <se@FreeBSD.org>2020-09-23 17:40:50 +0800
commitf37457350c2aa01db87f6d47fcfb15e7c1682ae4 (patch)
treefcefc7f2e6b0ae3d3061cba28b4bbaa746f37d8f /sysutils
parent81b47a6b61d1fd9eabacf61ec710ef418a3caa4e (diff)
downloadfreebsd-ports-gnome-f37457350c2aa01db87f6d47fcfb15e7c1682ae4.tar.gz
freebsd-ports-gnome-f37457350c2aa01db87f6d47fcfb15e7c1682ae4.tar.zst
freebsd-ports-gnome-f37457350c2aa01db87f6d47fcfb15e7c1682ae4.zip
New port of hexpeek
A hex file editor that is scriptable and supports patching of arbitrarily large files.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/hexpeek/Makefile27
-rw-r--r--sysutils/hexpeek/distinfo3
-rw-r--r--sysutils/hexpeek/files/patch-Makefile20
-rw-r--r--sysutils/hexpeek/pkg-descr8
5 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index cc65cd1937e8..6292d0ae8394 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -468,6 +468,7 @@
SUBDIR += healthd
SUBDIR += heirloom
SUBDIR += helm
+ SUBDIR += hexpeek
SUBDIR += hextools
SUBDIR += hexyl
SUBDIR += hfsexplorer
diff --git a/sysutils/hexpeek/Makefile b/sysutils/hexpeek/Makefile
new file mode 100644
index 000000000000..a8222bc534e8
--- /dev/null
+++ b/sysutils/hexpeek/Makefile
@@ -0,0 +1,27 @@
+# Created by: se@freebsd.org
+# $FreeBSD$
+
+PORTNAME= hexpeek
+DISTVERSION= 1.0.20200804
+CATEGORIES= sysutils
+MASTER_SITES= https://www.hexpeek.com/releases/${DISTNAME}/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= se@freebsd.org
+COMMENT= Hex file editor
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= tar:bzip2 libedit ncurses
+
+CFLAGS+= -Isrc -D_WITH_GETLINE -L${PREFIX}/lib
+
+PLIST_FILES= bin/hexdiff bin/hexDump bin/hexpack bin/hexpeek bin/hexview
+PLIST_FILES+= man/man1/hexpeek.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/etc/hexpeek.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/hexpeek/distinfo b/sysutils/hexpeek/distinfo
new file mode 100644
index 000000000000..01eaddd92d78
--- /dev/null
+++ b/sysutils/hexpeek/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1596616000
+SHA256 (hexpeek-v1.0.20200804.tar.bz2) = 03b676765e0dee55ff8515dd239a4beade9c65e31816ba5041da18bd3eaee176
+SIZE (hexpeek-v1.0.20200804.tar.bz2) = 1981134
diff --git a/sysutils/hexpeek/files/patch-Makefile b/sysutils/hexpeek/files/patch-Makefile
new file mode 100644
index 000000000000..d45494198de5
--- /dev/null
+++ b/sysutils/hexpeek/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2020-08-04 05:58:52 UTC
++++ Makefile
+@@ -26,13 +26,10 @@
+
+ # Note that libedit is optional. To build hexpeek without it, remove
+ # -DHEXPEEK_EDITABLE_CONSOLE and -ledit.
+-SRCDIR := src
+-BINDIR := bin
+-EXEC := $(BINDIR)/hexpeek
+-CC ?= clang
+-CFLAGS := -I$(SRCDIR) -O3 -Wall -fPIC
+-DFLAGS := -DHEXPEEK_EDITABLE_CONSOLE
+-LIBS := -ledit #-ltermcap
++SRCDIR = src
++BINDIR = bin
++EXEC = $(BINDIR)/hexpeek
++LIBS = -ledit
+
+ all: $(EXEC)
+ make -C test
diff --git a/sysutils/hexpeek/pkg-descr b/sysutils/hexpeek/pkg-descr
new file mode 100644
index 000000000000..d54f32b2b568
--- /dev/null
+++ b/sysutils/hexpeek/pkg-descr
@@ -0,0 +1,8 @@
+hexpeek is a binary editor designed for efficient operation on huge files,
+but works on any file.
+
+Operations supported are searching, patching, and insertions and deletions
+of binary data in a file. An undo feature allows to revert changes made in
+error.
+
+WWW: https://www.hexpeek.com/