aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-03-20 22:53:50 +0800
committermiwi <miwi@FreeBSD.org>2010-03-20 22:53:50 +0800
commitf487e718b331a6c3534cd11e64891b67840291bd (patch)
tree70bb43a301e90d7f32a21d8b12112a469fd3c0b7 /sysutils
parent8f8385125ddfcf06ce4371ad8f512aeeedb0bccb (diff)
downloadfreebsd-ports-gnome-f487e718b331a6c3534cd11e64891b67840291bd.tar.gz
freebsd-ports-gnome-f487e718b331a6c3534cd11e64891b67840291bd.tar.zst
freebsd-ports-gnome-f487e718b331a6c3534cd11e64891b67840291bd.zip
- Mark BROKEN on HEAD: fails to build with new utmpx
Reported by: pointyhat
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/su2/Makefile8
-rw-r--r--sysutils/syslog-ng2/Makefile8
-rw-r--r--sysutils/userinfo/Makefile8
-rw-r--r--sysutils/uwatch/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/sysutils/su2/Makefile b/sysutils/su2/Makefile
index 09b46914874d..c2d265f2821e 100644
--- a/sysutils/su2/Makefile
+++ b/sysutils/su2/Makefile
@@ -18,7 +18,13 @@ NO_CDROM= "Don't sell for profit"
MAN1= su2.1
PLIST_FILES= bin/su2
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's,/etc/super,${PREFIX}/etc/super,g' ${WRKSRC}/su2.man
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/syslog-ng2/Makefile b/sysutils/syslog-ng2/Makefile
index 0a2eaa526f71..d921c93286dd 100644
--- a/sysutils/syslog-ng2/Makefile
+++ b/sysutils/syslog-ng2/Makefile
@@ -33,6 +33,12 @@ CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --localstatedir=/var/db \
CONFIGURE_ENV= CFLAGS="`${LIBNET_CONFIG} --cflags`" \
LDFLAGS="`${LIBNET_CONFIG} --libs`"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if defined(WITH_TCP_WRAPPERS)
CONFIGURE_ARGS+=--enable-tcp-wrapper
.endif
@@ -58,4 +64,4 @@ post-install:
fi
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/userinfo/Makefile b/sysutils/userinfo/Makefile
index 1a2c82c66811..dba90224cbc7 100644
--- a/sysutils/userinfo/Makefile
+++ b/sysutils/userinfo/Makefile
@@ -19,4 +19,10 @@ GNU_CONFIGURE= yes
MAN1= ui.1
MLINKS= ui.1 userinfo.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/uwatch/Makefile b/sysutils/uwatch/Makefile
index caead303d391..1a595c21963f 100644
--- a/sysutils/uwatch/Makefile
+++ b/sysutils/uwatch/Makefile
@@ -17,4 +17,10 @@ MAN1= uwatch.1
MANCOMPRESSED= yes
PLIST_FILES= bin/uwatch
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>