aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-01-15 23:52:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-01-15 23:52:18 +0800
commitf963bff8b913e1cf5bb60d05dcccb1792f85d00f (patch)
treeba2f712129b5d1c690e2534e402fc442705eb787 /sysutils
parent65ae49e39114165654adda047980c85f705fe8c8 (diff)
downloadfreebsd-ports-gnome-f963bff8b913e1cf5bb60d05dcccb1792f85d00f.tar.gz
freebsd-ports-gnome-f963bff8b913e1cf5bb60d05dcccb1792f85d00f.tar.zst
freebsd-ports-gnome-f963bff8b913e1cf5bb60d05dcccb1792f85d00f.zip
- Add hardlink 0.1.1
hardlink is a tool which detects multiple copies of the same file and replaces them with hardlinks. WWW: http://jak-linux.org/projects/hardlink/ PR: ports/154020 Submitted by: Douglas William Thrift <douglas@douglasthrift.net> Feature safe: yes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/hardlink/Makefile34
-rw-r--r--sysutils/hardlink/distinfo2
-rw-r--r--sysutils/hardlink/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 032d37159b5b..46b624cba3e3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -353,6 +353,7 @@
SUBDIR += hal
SUBDIR += hal-info
SUBDIR += hammerhead
+ SUBDIR += hardlink
SUBDIR += hatop
SUBDIR += hdup
SUBDIR += healthd
diff --git a/sysutils/hardlink/Makefile b/sysutils/hardlink/Makefile
new file mode 100644
index 000000000000..f5b1da4b2887
--- /dev/null
+++ b/sysutils/hardlink/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: hardlink
+# Date created: 14 January 2011
+# Whom: Douglas Thrift
+#
+# $FreeBSD$
+#
+
+PORTNAME= hardlink
+PORTVERSION= 0.1.1
+CATEGORIES= sysutils python
+MASTER_SITES= http://jak-linux.org/projects/hardlink/ \
+ http://apt.douglasthrift.net/files/${PORTNAME}/ \
+ http://code.douglasthrift.net/files/${PORTNAME}/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Replace file copies using hardlinks
+
+LICENSE= MIT
+
+MAN1= hardlink.1
+NO_BUILD= yes
+PLIST_FILES= bin/hardlink
+USE_PYTHON= 2.5+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' ${WRKSRC}/hardlink.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/hardlink.py ${PREFIX}/bin/hardlink
+ ${INSTALL_MAN} ${WRKSRC}/hardlink.1 ${PREFIX}/man/man1/hardlink.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/hardlink/distinfo b/sysutils/hardlink/distinfo
new file mode 100644
index 000000000000..69680d02c68e
--- /dev/null
+++ b/sysutils/hardlink/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hardlink_0.1.1.tar.gz) = b6ecd4fee72b66054ed941e23177e46537abefd4cc71d9c05b1b587d766f8273
+SIZE (hardlink_0.1.1.tar.gz) = 6306
diff --git a/sysutils/hardlink/pkg-descr b/sysutils/hardlink/pkg-descr
new file mode 100644
index 000000000000..866b81e42756
--- /dev/null
+++ b/sysutils/hardlink/pkg-descr
@@ -0,0 +1,4 @@
+hardlink is a tool which detects multiple copies of the same file and replaces
+them with hardlinks.
+
+WWW: http://jak-linux.org/projects/hardlink/