aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-07-19 05:03:13 +0800
committerAdriaan de Groot <adridg@FreeBSD.org>2020-07-19 05:03:13 +0800
commitf9cc378798e76f4f5e933efe9d057d04adaabb61 (patch)
tree8cce168d2aeb24151ccbc662cf5a239cd13a877b /sysutils
parent1a359897a80a49376b55bc0bb91485a80251da99 (diff)
downloadfreebsd-ports-gnome-f9cc378798e76f4f5e933efe9d057d04adaabb61.tar.gz
freebsd-ports-gnome-f9cc378798e76f4f5e933efe9d057d04adaabb61.tar.zst
freebsd-ports-gnome-f9cc378798e76f4f5e933efe9d057d04adaabb61.zip
Fix sysutils/krename in the face of Taglib CMake-incompatibility
This fix is complicated by krename already having a big complex patch from git against exiv, and no newer releases, so I had to bodge in the new patch to avoid double-patching the same file or losing the existing comments and explanation.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/krename/Makefile2
-rw-r--r--sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch8
2 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/krename/Makefile b/sysutils/krename/Makefile
index 7552dd006061..86421d16faab 100644
--- a/sysutils/krename/Makefile
+++ b/sysutils/krename/Makefile
@@ -2,7 +2,7 @@
PORTNAME= krename
PORTVERSION= 5.0.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
diff --git a/sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch b/sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch
index 3c85db9a9f5c..79cba92754b9 100644
--- a/sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch
+++ b/sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch
@@ -153,8 +153,12 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
set(krename_SRCS ${krename_SRCS}
exiv2plugin.cpp
)
-@@ -137,9 +137,9 @@ if(TAGLIB_FOUND)
- ${TAGLIB_LIBRARIES}
+@@ -128,12 +128,12 @@ target_link_libraries(krename
+ )
+ if(TAGLIB_FOUND)
+ target_link_libraries(krename
+- ${TAGLIB_LIBRARIES}
++ Taglib::Taglib
)
endif()
-if(EXIV2_FOUND)