aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-11 16:29:36 +0800
committermiwi <miwi@FreeBSD.org>2007-06-11 16:29:36 +0800
commitfb2c085a3bb09b3677f5e2c94487131a75b0821d (patch)
treea596de0f4a2f8d990a67afe53fd88b7a5c466e14 /sysutils
parente8569ee89993b2fdd471988b85ffd33c1ce48c91 (diff)
downloadfreebsd-ports-gnome-fb2c085a3bb09b3677f5e2c94487131a75b0821d.tar.gz
freebsd-ports-gnome-fb2c085a3bb09b3677f5e2c94487131a75b0821d.tar.zst
freebsd-ports-gnome-fb2c085a3bb09b3677f5e2c94487131a75b0821d.zip
Perl interface to Gamin (File Access Monitor implementation)
Provides a somewhat higher-level and friendlier interface to the Gamin File Access Monitor API. This allows one to monitor both local and remote (NFS-mounted) files and directories for common filesystem events. To do so, you must register "monitors" on specified pathnames and wait for events to arrive pertaining to them. PR: ports/112386 Submitted by: Nick Hibma <n_hibma at freebsd.org> Thanks to: clsung for helping
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-Sys-Gamin/Makefile26
-rw-r--r--sysutils/p5-Sys-Gamin/distinfo3
-rw-r--r--sysutils/p5-Sys-Gamin/pkg-descr6
-rw-r--r--sysutils/p5-Sys-Gamin/pkg-plist20
5 files changed, 56 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 3d9127f5dc7e..932b34ad132c 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -455,6 +455,7 @@
SUBDIR += p5-Stat-lsMode
SUBDIR += p5-Sys-CpuLoad
SUBDIR += p5-Sys-Filesystem
+ SUBDIR += p5-Sys-Gamin
SUBDIR += p5-Sys-Hostname-FQDN
SUBDIR += p5-Sys-Hostname-Long
SUBDIR += p5-Sys-Utmp
diff --git a/sysutils/p5-Sys-Gamin/Makefile b/sysutils/p5-Sys-Gamin/Makefile
new file mode 100644
index 000000000000..4571e261c58c
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Sys-Gamin
+# Date created: 03 May 2007
+# Whom: Nick Hibma <n_hibma@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Gamin
+PORTVERSION= 0.1
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= n_hibma@freebsd.org
+COMMENT= Perl interface to Gamin (File Access Monitor implementation)
+
+PERL_CONFIGURE= yes
+USE_FAM= yes
+MAN1= monitor.1
+MAN3= Sys::Gamin.3
+
+pre-configure:
+ ${PERL} -pi -e 'm/LIBS =>/ && print " INC => \"-I${LOCALBASE}/include\",\n"' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Sys-Gamin/distinfo b/sysutils/p5-Sys-Gamin/distinfo
new file mode 100644
index 000000000000..7a21415df26d
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sys-Gamin-0.1.tar.gz) = 4eb05138c28e8a5f12340938b0823a4c
+SHA256 (Sys-Gamin-0.1.tar.gz) = e3a7395005240048e5c19a12f27c8ea5133f3066421e781de7ed23942fe53ffc
+SIZE (Sys-Gamin-0.1.tar.gz) = 6766
diff --git a/sysutils/p5-Sys-Gamin/pkg-descr b/sysutils/p5-Sys-Gamin/pkg-descr
new file mode 100644
index 000000000000..67cd9b0414b4
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/pkg-descr
@@ -0,0 +1,6 @@
+Perl interface to Gamin (File Access Monitor implementation)
+Provides a somewhat higher-level and friendlier interface to the Gamin File
+Access Monitor API. This allows one to monitor both local and remote
+(NFS-mounted) files and directories for common filesystem events. To do so, you
+must register "monitors" on specified pathnames and wait for events to arrive
+pertaining to them.
diff --git a/sysutils/p5-Sys-Gamin/pkg-plist b/sysutils/p5-Sys-Gamin/pkg-plist
new file mode 100644
index 000000000000..698996d6419a
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/pkg-plist
@@ -0,0 +1,20 @@
+bin/monitor
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/Gamin.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/Gamin.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/Sys/Gamin.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/new.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/pending.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/next_event.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/monitor.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/check_monitored.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/cancel.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/monitored.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/suspended.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/suspend.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/resume.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/which.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Sys