aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2000-11-20 19:16:00 +0800
committerlioux <lioux@FreeBSD.org>2000-11-20 19:16:00 +0800
commitfe414d7c4c8e6a4166d422fef433ceadf4d46fc9 (patch)
tree498f4fa7627f197ee86bf8cbb34d9362aa7d23c7 /sysutils
parent35827b56b64195135e2a860fbc604d715694bfcd (diff)
downloadfreebsd-ports-gnome-fe414d7c4c8e6a4166d422fef433ceadf4d46fc9.tar.gz
freebsd-ports-gnome-fe414d7c4c8e6a4166d422fef433ceadf4d46fc9.tar.zst
freebsd-ports-gnome-fe414d7c4c8e6a4166d422fef433ceadf4d46fc9.zip
Submitted by: Jos Backus <josb@cncdsl.com>
Fix adjust destination. Should be etc/clockspeed/adjust instead of just adjust. Add a PLIST uninstall target to remove this file since killing the daemon does not.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/clockspeed/files/patch-ac18
-rw-r--r--sysutils/clockspeed/pkg-plist1
2 files changed, 16 insertions, 3 deletions
diff --git a/sysutils/clockspeed/files/patch-ac b/sysutils/clockspeed/files/patch-ac
index 60237f121c61..6f94e6d95a0d 100644
--- a/sysutils/clockspeed/files/patch-ac
+++ b/sysutils/clockspeed/files/patch-ac
@@ -1,5 +1,5 @@
---- clockspeed.c.orig Fri Jun 16 23:37:32 2000
-+++ clockspeed.c Fri Jun 16 23:38:10 2000
+--- clockspeed.c.orig Tue Oct 13 15:37:28 1998
++++ clockspeed.c Mon Nov 20 09:06:34 2000
@@ -83,7 +83,7 @@
if (deriv <= 0) return;
if (deriv > 200000000) return; /* 5Hz ticks? be serious */
@@ -18,7 +18,7 @@
}
void main()
-@@ -136,7 +136,7 @@
+@@ -136,16 +136,16 @@
if (chdir(auto_home) == -1) _exit(1);
umask(033);
@@ -27,3 +27,15 @@
r = read(0,buf,sizeof buf);
if (r == sizeof buf)
deriv = nano(buf);
+ close(0);
+ }
+
+- if (fifo_make("adjust",0600) == -1) if (errno != error_exist) _exit(1);
+- if (open_read("adjust") != 0) _exit(1);
+- if (open_write("adjust") == -1) _exit(1);
++ if (fifo_make("etc/clockspeed/adjust",0600) == -1) if (errno != error_exist) _exit(1);
++ if (open_read("etc/clockspeed/adjust") != 0) _exit(1);
++ if (open_write("etc/clockspeed/adjust") == -1) _exit(1);
+
+ now(&first);
+
diff --git a/sysutils/clockspeed/pkg-plist b/sysutils/clockspeed/pkg-plist
index c724945af071..8138dbb05272 100644
--- a/sysutils/clockspeed/pkg-plist
+++ b/sysutils/clockspeed/pkg-plist
@@ -10,4 +10,5 @@ bin/taiclockd
@exec mkdir %D/etc/clockspeed
@unexec rm %D/etc/clockspeed/atto.tmp 2>/dev/null || true
@unexec rm %D/etc/clockspeed/atto 2>/dev/null || true
+@unexec rm %D/etc/clockspeed/adjust 2>/dev/null || true
@unexec rmdir %D/etc/clockspeed 2>/dev/null || true