aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-08 21:09:09 +0800
committertijl <tijl@FreeBSD.org>2014-07-08 21:09:09 +0800
commitff29cca069476bc5bfb7d4e1cafc5ab9e60fd03c (patch)
tree31b780620a9a73994325e16d0c6b2e9d2b91c71b /sysutils
parent0072474f151da60b08938a6b35366fe0a249f1d4 (diff)
downloadfreebsd-ports-gnome-ff29cca069476bc5bfb7d4e1cafc5ab9e60fd03c.tar.gz
freebsd-ports-gnome-ff29cca069476bc5bfb7d4e1cafc5ab9e60fd03c.tar.zst
freebsd-ports-gnome-ff29cca069476bc5bfb7d4e1cafc5ab9e60fd03c.zip
- Remove TRACE option and depend on libexecinfo unconditionally because
configure always detects it on FreeBSD 10 - Add INSTALL_TARGET=install-strip - USES=pathfix - Avoid USE_AUTOTOOLS - Fix pkg-plist after USES=libtool conversion
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/openipmi/Makefile22
-rw-r--r--sysutils/openipmi/files/patch-Makefile.am18
-rw-r--r--sysutils/openipmi/files/patch-configure.in10
-rw-r--r--sysutils/openipmi/pkg-plist3
4 files changed, 13 insertions, 40 deletions
diff --git a/sysutils/openipmi/Makefile b/sysutils/openipmi/Makefile
index 5582d3064b1d..d90c282b765e 100644
--- a/sysutils/openipmi/Makefile
+++ b/sysutils/openipmi/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openipmi
PORTVERSION= 2.0.19
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/OpenIPMI%202.0%20Library
DISTNAME= OpenIPMI-${PORTVERSION}
@@ -11,19 +11,18 @@ DISTNAME= OpenIPMI-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Complex IPMI management software
-LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libpopt.so:${PORTSDIR}/devel/popt
-USES= gmake pkgconfig libtool
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
-USE_AUTOTOOLS= autoconf autoheader automake aclocal
-AUTOMAKE_ARGS+= --add-missing --copy --foreign
-ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= SSL SNMP PERL PYTHON TCL TKINTER TRACE GDBM
+OPTIONS_DEFINE= SSL SNMP PERL PYTHON TCL TKINTER GDBM
OPTIONS_RADIO= GLIB
OPTIONS_RADIO_GLIB= GLIB12 GLIB20
SSL_DESC= IPMI 2.0 RMCP+ encryption and authentication
@@ -32,7 +31,6 @@ PERL_DESC= Perl interface for OpenIPMI library
PYTHON_DESC= Python interface for OpenIPMI library
TCL_DESC= TCL interface for OpenIPMI library
TKINTER_DESC= GUI for OpenIPMI, written in Python
-TRACE_DESC= Enable backtrace inspecting
GDBM_DESC= Local SDR caching on startup
GLIB12_DESC= Simply OS handler for glib 1.2
GLIB20_DESC= Simply OS handler for glib 2.0
@@ -101,10 +99,6 @@ CONFIGURE_ARGS+= --with-tcl=no
PLIST_SUB+= TCL="@comment "
.endif
-.if ${PORT_OPTIONS:MTRACE}
-LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-.endif
-
.if ${PORT_OPTIONS:MGDBM}
LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
.endif
@@ -127,4 +121,8 @@ CONFIGURE_ARGS+= --with-glib=no
PLIST_SUB+= GLIB20="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} '/libOpenIPMIutils_la_LIBADD =/s/$$/ -lexecinfo/' \
+ ${WRKSRC}/utils/Makefile.in
+
.include <bsd.port.mk>
diff --git a/sysutils/openipmi/files/patch-Makefile.am b/sysutils/openipmi/files/patch-Makefile.am
deleted file mode 100644
index f38206e767f6..000000000000
--- a/sysutils/openipmi/files/patch-Makefile.am
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.am.orig 2006-11-14 19:28:31.000000000 +0300
-+++ Makefile.am 2010-04-28 16:27:46.524370871 +0400
-@@ -16,12 +16,12 @@
- $(GLIB12_PKGCONF) $(TCL_PKGCONF)
-
- install-data-local: $(PKGCONFIGS)
-- $(mkinstalldirs) $(DESTDIR)$(libdir)/pkgconfig
-- $(INSTALL_DATA) $(PKGCONFIGS) $(DESTDIR)$(libdir)/pkgconfig
-+ $(mkinstalldirs) $(DESTDIR)$(prefix)/libdata/pkgconfig
-+ $(INSTALL_DATA) $(PKGCONFIGS) $(DESTDIR)$(prefix)/libdata/pkgconfig
-
- uninstall-local:
- for i in $(PKGCONFIGS); do \
-- rm -f $(DESTDIR)$(libdir)/pkgconfig/$$i; \
-+ rm -f $(DESTDIR)$(prefix)/libdata/pkgconfig/$$i; \
- done
-
- rpm: dist
diff --git a/sysutils/openipmi/files/patch-configure.in b/sysutils/openipmi/files/patch-configure.in
deleted file mode 100644
index 538d354a9d11..000000000000
--- a/sysutils/openipmi/files/patch-configure.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.in.orig 2011-11-25 01:40:43.243119438 +0400
-+++ configure.in 2011-11-25 01:42:18.859147897 +0400
-@@ -274,6 +274,7 @@
- AC_CHECK_FUNCS(getaddrinfo)
-
- AC_CHECK_HEADERS(execinfo.h)
-+AC_SEARCH_LIBS(backtrace_symbols, [execinfo])
-
- AC_SUBST(OPENIPMI_VERSION_MAJOR)
- AC_SUBST(OPENIPMI_VERSION_MINOR)
diff --git a/sysutils/openipmi/pkg-plist b/sysutils/openipmi/pkg-plist
index 55d1c5d6f52d..d7c7529622fd 100644
--- a/sysutils/openipmi/pkg-plist
+++ b/sysutils/openipmi/pkg-plist
@@ -105,16 +105,19 @@ man/man8/ipmilan.8.gz
%%GLIB12%%lib/libOpenIPMIglib12.a
%%GLIB12%%lib/libOpenIPMIglib12.so
%%GLIB12%%lib/libOpenIPMIglib12.so.0
+%%GLIB12%%lib/libOpenIPMIglib12.so.0.0.1
%%GLIB12%%libdata/pkgconfig/OpenIPMIglib12.pc
%%GLIB20%%@comment files list for GLIB20
%%GLIB20%%lib/libOpenIPMIglib.a
%%GLIB20%%lib/libOpenIPMIglib.so
%%GLIB20%%lib/libOpenIPMIglib.so.0
+%%GLIB20%%lib/libOpenIPMIglib.so.0.0.1
%%GLIB20%%libdata/pkgconfig/OpenIPMIglib.pc
%%TCL%%@comment files list for TCL
%%TCL%%lib/libOpenIPMItcl.a
%%TCL%%lib/libOpenIPMItcl.so
%%TCL%%lib/libOpenIPMItcl.so.0
+%%TCL%%lib/libOpenIPMItcl.so.0.0.1
%%TCL%%libdata/pkgconfig/OpenIPMItcl.pc
%%PERL%%@comment files list for PERL
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/OpenIPMI.pm