aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/cdiff
diff options
context:
space:
mode:
authoreivind <eivind@FreeBSD.org>2000-11-20 21:16:07 +0800
committereivind <eivind@FreeBSD.org>2000-11-20 21:16:07 +0800
commit6f07c32f7dd1bfa7231197887ad3425aaff00a11 (patch)
tree48f0c87838478846bb4db4719b3ffafc8881743b /textproc/cdiff
parentd2648a3953bfb5975a771ccceffb203283864e7e (diff)
downloadfreebsd-ports-gnome-6f07c32f7dd1bfa7231197887ad3425aaff00a11.tar.gz
freebsd-ports-gnome-6f07c32f7dd1bfa7231197887ad3425aaff00a11.tar.zst
freebsd-ports-gnome-6f07c32f7dd1bfa7231197887ad3425aaff00a11.zip
Handle compressed files
Diffstat (limited to 'textproc/cdiff')
-rw-r--r--textproc/cdiff/Makefile2
-rw-r--r--textproc/cdiff/src/cdiff.15
-rw-r--r--textproc/cdiff/src/cdiff.sh2
3 files changed, 5 insertions, 4 deletions
diff --git a/textproc/cdiff/Makefile b/textproc/cdiff/Makefile
index 9be85310cd39..48c96b990290 100644
--- a/textproc/cdiff/Makefile
+++ b/textproc/cdiff/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= cdiff
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= textproc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/textproc/cdiff/src/cdiff.1 b/textproc/cdiff/src/cdiff.1
index a399b04bf6c3..eaa617a574af 100644
--- a/textproc/cdiff/src/cdiff.1
+++ b/textproc/cdiff/src/cdiff.1
@@ -37,8 +37,9 @@
.Op Ar diff ...
.Sh DESCRIPTION
.Nm
-reads a unidiff or context diff from stdin or a set of files and URLs, adds color
-codes, expands tabs to 8 spaces, and passes the results to
+reads a unidiff or context diff from stdin or a set of (optionally compressed)
+files and URLs, adds color codes, expands tabs to 8 spaces, and passes the
+results to
.Xr less 1 .
If used on a color terminal, it makes diffs much easier to read.
.Sh AUTHORS
diff --git a/textproc/cdiff/src/cdiff.sh b/textproc/cdiff/src/cdiff.sh
index 6824cb89811c..73827e4587ef 100644
--- a/textproc/cdiff/src/cdiff.sh
+++ b/textproc/cdiff/src/cdiff.sh
@@ -6,7 +6,7 @@
fetch -q -o - $1
;;
*)
- cat $1
+ zcat -f $1
;;
esac
shift;