aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/cl-ppcre-clisp/Makefile
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
commitdb6c634e448bc8765cbc58ca91b1a4e4aa41610a (patch)
tree9c5ff04da0b9c023f86f7db9b932c7c9a9da8101 /textproc/cl-ppcre-clisp/Makefile
parente434a643efdf84c3dfcdc64e58706cc363f818d1 (diff)
downloadfreebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.gz
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.zst
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Diffstat (limited to 'textproc/cl-ppcre-clisp/Makefile')
-rw-r--r--textproc/cl-ppcre-clisp/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/textproc/cl-ppcre-clisp/Makefile b/textproc/cl-ppcre-clisp/Makefile
index 38b57fcfe133..9f72054d5158 100644
--- a/textproc/cl-ppcre-clisp/Makefile
+++ b/textproc/cl-ppcre-clisp/Makefile
@@ -6,31 +6,20 @@
PORTNAME= cl-ppcre
PORTVERSION= 0.5.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc lisp
MASTER_SITES= http://weitz.de/files/
-PKGNAMESUFFIX= -clisp
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Portable Perl-Compatible Regular Expression for Common Lisp
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/cl-ppcre/cl-ppcre.asd:${PORTSDIR}/textproc/cl-ppcre \
- ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
- clisp:${PORTSDIR}/lang/clisp
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/cl-ppcre/cl-ppcre.asd:${PORTSDIR}/textproc/cl-ppcre \
- ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
- clisp:${PORTSDIR}/lang/clisp
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/cl-ppcre/cl-ppcre.asd:${PORTSDIR}/textproc/cl-ppcre
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/cl-ppcre/cl-ppcre.asd:${PORTSDIR}/textproc/cl-ppcre
-do-build:
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
- clisp -q -ansi -norc \
- -i ${LOCALBASE}/etc/asdf-init \
- -x "(asdf:oos 'asdf:compile-op :cl-ppcre)"
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/common-lisp/cl-ppcre/clispfasl
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/cl-ppcre/clispfasl/
+USE_ASDF_FASL= yes
+FASL_TARGET= clisp
+FASL_BUILD= yes
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>