aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/exempi
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /textproc/exempi
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadfreebsd-ports-gnome-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
freebsd-ports-gnome-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.zst
freebsd-ports-gnome-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Diffstat (limited to 'textproc/exempi')
-rw-r--r--textproc/exempi/Makefile30
-rw-r--r--textproc/exempi/distinfo3
-rw-r--r--textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp11
-rw-r--r--textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp20
-rw-r--r--textproc/exempi/pkg-descr3
-rw-r--r--textproc/exempi/pkg-plist10
6 files changed, 77 insertions, 0 deletions
diff --git a/textproc/exempi/Makefile b/textproc/exempi/Makefile
new file mode 100644
index 000000000000..b71435688511
--- /dev/null
+++ b/textproc/exempi/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: exempi
+# Date created: 2008-02-26
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/textproc/exempi/Makefile,v 1.1 2008/02/26 18:50:26 ahze Exp $
+
+PORTNAME= exempi
+PORTVERSION= 1.99.9
+CATEGORIES= textproc
+MASTER_SITES= http://libopenraw.freedesktop.org/download/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A port of Adobe XMP SDK to work on UNIX
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= ltverhack gnomehack
+CONFIGURE_ARGS= --enable-unittest=no
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
+ LIBS="-liconv"
+USE_ICONV= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${libdir}/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/textproc/exempi/distinfo b/textproc/exempi/distinfo
new file mode 100644
index 000000000000..045db78a114b
--- /dev/null
+++ b/textproc/exempi/distinfo
@@ -0,0 +1,3 @@
+MD5 (exempi-1.99.9.tar.gz) = 8fb6c6230a4862b8c82b4b76be6ffb1e
+SHA256 (exempi-1.99.9.tar.gz) = 10104ff8405604b32583fb8c8731c038525aeacf6c4a44f2845649964a3c9a7b
+SIZE (exempi-1.99.9.tar.gz) = 3063146
diff --git a/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp
new file mode 100644
index 000000000000..658138633b92
--- /dev/null
+++ b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp
@@ -0,0 +1,11 @@
+--- source/XMPFiles/FormatSupport/EndianUtils.hpp.orig 2008-02-26 11:51:10.000000000 -0500
++++ source/XMPFiles/FormatSupport/EndianUtils.hpp 2008-02-26 11:51:17.000000000 -0500
+@@ -38,7 +38,7 @@
+ #endif
+ #endif
+ #elif XMP_UNIXBuild
+-#include <endian.h>
++#include <machine/endian.h>
+ #if BYTE_ORDER == BIG_ENDIAN
+ #define kBigEndianHost 1
+ #elif BYTE_ORDER == LITTLE_ENDIAN
diff --git a/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp
new file mode 100644
index 000000000000..90e3f7c221e5
--- /dev/null
+++ b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp
@@ -0,0 +1,20 @@
+--- source/XMPFiles/FormatSupport/Reconcile_Impl.cpp.orig 2008-02-26 11:56:56.000000000 -0500
++++ source/XMPFiles/FormatSupport/Reconcile_Impl.cpp 2008-02-26 12:04:09.000000000 -0500
+@@ -249,7 +249,7 @@
+
+ iconv_t cd = iconv_open( "ISO8859-1", "UTF-8" );
+
+- char * in = (char *)utf8Ptr;
++ const char * in = (char *)utf8Ptr;
+ size_t inLen = utf8Len;
+ size_t outLen = utf8Len * 4;
+ char * buf = (char *)calloc( outLen, 1 );
+@@ -406,7 +406,7 @@
+
+ iconv_t cd = iconv_open( "UTF-8", "ISO8859-1" );
+
+- char * in = (char *)_latin1Ptr;
++ const char * in = (char *)_latin1Ptr;
+ size_t inLen = latin1Len;
+ size_t outLen = latin1Len * 4;
+ char * buf = (char *)calloc( outLen, 1 );
diff --git a/textproc/exempi/pkg-descr b/textproc/exempi/pkg-descr
new file mode 100644
index 000000000000..543d5a0c3fea
--- /dev/null
+++ b/textproc/exempi/pkg-descr
@@ -0,0 +1,3 @@
+Exempi is an implementation of XMP and is based on Adobe XMP SDK
+
+WWW: http://libopenraw.freedesktop.org/wiki/Exempi
diff --git a/textproc/exempi/pkg-plist b/textproc/exempi/pkg-plist
new file mode 100644
index 000000000000..2e039e9feda0
--- /dev/null
+++ b/textproc/exempi/pkg-plist
@@ -0,0 +1,10 @@
+include/exempi-2.0/exempi/xmp.h
+include/exempi-2.0/exempi/xmpconsts.h
+include/exempi-2.0/exempi/xmperrors.h
+lib/libexempi.a
+lib/libexempi.la
+lib/libexempi.so
+lib/libexempi.so.3
+libdata/pkgconfig/exempi-2.0.pc
+@dirrm include/exempi-2.0/exempi
+@dirrm include/exempi-2.0